summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/hostapd
diff options
context:
space:
mode:
authorDenis Carikli <GNUtoo@no-log.org>2012-07-18 22:00:17 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-07-19 11:09:47 +0200
commit7839b41773962011696ed02924136b00447cb382 (patch)
tree25c247e6c7b5220fee4dd2a77d438fc7a3749c46 /meta-oe/recipes-connectivity/hostapd
parente8402b1583c0c1e1c85aacf54349b58e32142c7c (diff)
downloadmeta-openembedded-7839b41773962011696ed02924136b00447cb382.tar.gz
Add hostapd 1.0 recipe
This recipe was based on the hostap-daemon_0.7.3.bb recipe in openembedded-classic at commit c1f52c58deee65c7498a3b3e82b4cc3ae5231b0e Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@no-log.org> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-connectivity/hostapd')
-rw-r--r--meta-oe/recipes-connectivity/hostapd/hostap-daemon-1.0/defconfig145
-rw-r--r--meta-oe/recipes-connectivity/hostapd/hostap-daemon-1.0/init37
-rw-r--r--meta-oe/recipes-connectivity/hostapd/hostap-daemon_1.0.bb44
3 files changed, 226 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/hostapd/hostap-daemon-1.0/defconfig b/meta-oe/recipes-connectivity/hostapd/hostap-daemon-1.0/defconfig
new file mode 100644
index 000000000..1f3c6f408
--- /dev/null
+++ b/meta-oe/recipes-connectivity/hostapd/hostap-daemon-1.0/defconfig
@@ -0,0 +1,145 @@
1# Example hostapd build time configuration
2#
3# This file lists the configuration options that are used when building the
4# hostapd binary. All lines starting with # are ignored. Configuration option
5# lines must be commented out complete, if they are not to be included, i.e.,
6# just setting VARIABLE=n is not disabling that variable.
7#
8# This file is included in Makefile, so variables like CFLAGS and LIBS can also
9# be modified from here. In most cass, these lines should use += in order not
10# to override previous values of the variables.
11
12# Driver interface for Host AP driver
13CONFIG_DRIVER_HOSTAP=y
14
15# Driver interface for wired authenticator
16CONFIG_DRIVER_WIRED=y
17
18# Driver interface for madwifi driver
19#CONFIG_DRIVER_MADWIFI=y
20#CFLAGS += -I../../madwifi # change to the madwifi source directory
21
22# Driver interface for Prism54 driver
23CONFIG_DRIVER_PRISM54=y
24
25# Driver interface for drivers using the nl80211 kernel interface
26CONFIG_DRIVER_NL80211=y
27CONFIG_LIBNL20=y
28# driver_nl80211.c requires a rather new libnl (version 1.1) which may not be
29# shipped with your distribution yet. If that is the case, you need to build
30# newer libnl version and point the hostapd build to use it.
31#LIBNL=/usr/src/libnl
32#CFLAGS += -I$(LIBNL)/include
33#LIBS += -L$(LIBNL)/lib
34
35# Driver interface for FreeBSD net80211 layer (e.g., Atheros driver)
36#CONFIG_DRIVER_BSD=y
37#CFLAGS += -I/usr/local/include
38#LIBS += -L/usr/local/lib
39
40# Driver interface for no driver (e.g., RADIUS server only)
41#CONFIG_DRIVER_NONE=y
42
43# IEEE 802.11F/IAPP
44CONFIG_IAPP=y
45
46# WPA2/IEEE 802.11i RSN pre-authentication
47CONFIG_RSN_PREAUTH=y
48
49# PeerKey handshake for Station to Station Link (IEEE 802.11e DLS)
50CONFIG_PEERKEY=y
51
52# IEEE 802.11w (management frame protection)
53# This version is an experimental implementation based on IEEE 802.11w/D1.0
54# draft and is subject to change since the standard has not yet been finalized.
55# Driver support is also needed for IEEE 802.11w.
56#CONFIG_IEEE80211W=y
57
58# Integrated EAP server
59CONFIG_EAP=y
60
61# EAP-MD5 for the integrated EAP server
62CONFIG_EAP_MD5=y
63
64# EAP-TLS for the integrated EAP server
65CONFIG_EAP_TLS=y
66
67# EAP-MSCHAPv2 for the integrated EAP server
68CONFIG_EAP_MSCHAPV2=y
69
70# EAP-PEAP for the integrated EAP server
71CONFIG_EAP_PEAP=y
72
73# EAP-GTC for the integrated EAP server
74CONFIG_EAP_GTC=y
75
76# EAP-TTLS for the integrated EAP server
77CONFIG_EAP_TTLS=y
78
79# EAP-SIM for the integrated EAP server
80#CONFIG_EAP_SIM=y
81
82# EAP-AKA for the integrated EAP server
83#CONFIG_EAP_AKA=y
84
85# EAP-AKA' for the integrated EAP server
86# This requires CONFIG_EAP_AKA to be enabled, too.
87#CONFIG_EAP_AKA_PRIME=y
88
89# EAP-PAX for the integrated EAP server
90#CONFIG_EAP_PAX=y
91
92# EAP-PSK for the integrated EAP server (this is _not_ needed for WPA-PSK)
93#CONFIG_EAP_PSK=y
94
95# EAP-SAKE for the integrated EAP server
96#CONFIG_EAP_SAKE=y
97
98# EAP-GPSK for the integrated EAP server
99#CONFIG_EAP_GPSK=y
100# Include support for optional SHA256 cipher suite in EAP-GPSK
101#CONFIG_EAP_GPSK_SHA256=y
102
103# EAP-FAST for the integrated EAP server
104# Note: Default OpenSSL package does not include support for all the
105# functionality needed for EAP-FAST. If EAP-FAST is enabled with OpenSSL,
106# the OpenSSL library must be patched (openssl-0.9.9-session-ticket.patch)
107# to add the needed functions.
108#CONFIG_EAP_FAST=y
109
110# Wi-Fi Protected Setup (WPS)
111CONFIG_WPS=y
112# Enable UPnP support for external WPS Registrars
113#CONFIG_WPS_UPNP=y
114
115# EAP-IKEv2
116#CONFIG_EAP_IKEV2=y
117
118# Trusted Network Connect (EAP-TNC)
119#CONFIG_EAP_TNC=y
120
121# PKCS#12 (PFX) support (used to read private key and certificate file from
122# a file that usually has extension .p12 or .pfx)
123CONFIG_PKCS12=y
124
125# RADIUS authentication server. This provides access to the integrated EAP
126# server from external hosts using RADIUS.
127CONFIG_RADIUS_SERVER=y
128
129# Build IPv6 support for RADIUS operations
130CONFIG_IPV6=y
131
132# IEEE Std 802.11r-2008 (Fast BSS Transition)
133#CONFIG_IEEE80211R=y
134
135# Use the hostapd's IEEE 802.11 authentication (ACL), but without
136# the IEEE 802.11 Management capability (e.g., madwifi or FreeBSD/net80211)
137CONFIG_DRIVER_RADIUS_ACL=y
138
139# IEEE 802.11n (High Throughput) support
140CONFIG_IEEE80211N=y
141
142# Remove debugging code that is printing out debug messages to stdout.
143# This can be used to reduce the size of the hostapd considerably if debugging
144# code is not needed.
145#CONFIG_NO_STDOUT_DEBUG=y
diff --git a/meta-oe/recipes-connectivity/hostapd/hostap-daemon-1.0/init b/meta-oe/recipes-connectivity/hostapd/hostap-daemon-1.0/init
new file mode 100644
index 000000000..79f74b681
--- /dev/null
+++ b/meta-oe/recipes-connectivity/hostapd/hostap-daemon-1.0/init
@@ -0,0 +1,37 @@
1#!/bin/sh
2DAEMON=/usr/sbin/hostapd
3NAME=hostapd
4DESC="HOSTAP Daemon"
5ARGS="/etc/hostapd.conf -B"
6
7test -f $DAEMON || exit 0
8
9set -e
10
11case "$1" in
12 start)
13 echo -n "Starting $DESC: "
14 start-stop-daemon -S -x $DAEMON -- $ARGS
15 echo "$NAME."
16 ;;
17 stop)
18 echo -n "Stopping $DESC: "
19 start-stop-daemon -K -x $DAEMON
20 echo "$NAME."
21 ;;
22 restart)
23 $0 stop
24 $0 start
25 ;;
26 reload)
27 echo -n "Reloading $DESC: "
28 killall -HUP $(basename ${DAEMON})
29 echo "$NAME."
30 ;;
31 *)
32 echo "Usage: $0 {start|stop|restart|reload}"
33 exit 1
34 ;;
35esac
36
37exit 0
diff --git a/meta-oe/recipes-connectivity/hostapd/hostap-daemon_1.0.bb b/meta-oe/recipes-connectivity/hostapd/hostap-daemon_1.0.bb
new file mode 100644
index 000000000..0ae0b702a
--- /dev/null
+++ b/meta-oe/recipes-connectivity/hostapd/hostap-daemon_1.0.bb
@@ -0,0 +1,44 @@
1HOMEPAGE = "http://hostap.epitest.fi"
2SECTION = "kernel/userland"
3PRIORITY = "optional"
4LICENSE = "GPLv2 | BSD"
5LIC_FILES_CHKSUM = "file://README;md5=4d709ce0f9c84b87d148e16731f647e1"
6DEPENDS = "libnl openssl"
7DESCRIPTION = "User space daemon for extended IEEE 802.11 management"
8
9inherit update-rc.d
10INITSCRIPT_NAME = "hostapd"
11
12PR = "r0"
13
14DEFAULT_PREFERENCE = "-1"
15
16SRC_URI = " \
17 http://hostap.epitest.fi/releases/hostapd-${PV}.tar.gz \
18 file://defconfig \
19 file://init \
20"
21
22S = "${WORKDIR}/hostapd-${PV}/hostapd"
23
24
25do_configure() {
26 install -m 0644 ${WORKDIR}/defconfig ${S}/.config
27}
28
29do_compile() {
30 make
31}
32
33do_install() {
34 install -d ${D}${sbindir} ${D}${sysconfdir}/init.d
35 install -m 0644 ${S}/hostapd.conf ${D}${sysconfdir}
36 install -m 0755 ${S}/hostapd ${D}${sbindir}
37 install -m 0755 ${S}/hostapd_cli ${D}${sbindir}
38 install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/hostapd
39}
40
41CONFFILES_${PN} += "${sysconfdir}/hostapd.conf"
42
43SRC_URI[md5sum] = "236247a7bbd4f60d5fa3e99849d1ffc9"
44SRC_URI[sha256sum] = "002e9dcb7e46cf82b5900a2fcf92b30fc8cdfd32a72d7fd4488588f1c013dfcc"