summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/hostapd
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-connectivity/hostapd
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-connectivity/hostapd')
-rw-r--r--meta-oe/recipes-connectivity/hostapd/hostapd-2.2/defconfig145
-rw-r--r--meta-oe/recipes-connectivity/hostapd/hostapd-2.2/hostapd.service11
-rw-r--r--meta-oe/recipes-connectivity/hostapd/hostapd-2.2/init58
-rw-r--r--meta-oe/recipes-connectivity/hostapd/hostapd_2.2.bb48
4 files changed, 262 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/hostapd/hostapd-2.2/defconfig b/meta-oe/recipes-connectivity/hostapd/hostapd-2.2/defconfig
new file mode 100644
index 000000000..278964017
--- /dev/null
+++ b/meta-oe/recipes-connectivity/hostapd/hostapd-2.2/defconfig
@@ -0,0 +1,145 @@
1# Example hostapd build time configuration
2#
3# This file lists the configuration options that are used when building the
4# hostapd binary. All lines starting with # are ignored. Configuration option
5# lines must be commented out complete, if they are not to be included, i.e.,
6# just setting VARIABLE=n is not disabling that variable.
7#
8# This file is included in Makefile, so variables like CFLAGS and LIBS can also
9# be modified from here. In most cass, these lines should use += in order not
10# to override previous values of the variables.
11
12# Driver interface for Host AP driver
13CONFIG_DRIVER_HOSTAP=y
14
15# Driver interface for wired authenticator
16CONFIG_DRIVER_WIRED=y
17
18# Driver interface for madwifi driver
19#CONFIG_DRIVER_MADWIFI=y
20#CFLAGS += -I../../madwifi # change to the madwifi source directory
21
22# Driver interface for Prism54 driver
23CONFIG_DRIVER_PRISM54=y
24
25# Driver interface for drivers using the nl80211 kernel interface
26CONFIG_DRIVER_NL80211=y
27CONFIG_LIBNL32=y
28# driver_nl80211.c requires a rather new libnl (version 1.1) which may not be
29# shipped with your distribution yet. If that is the case, you need to build
30# newer libnl version and point the hostapd build to use it.
31#LIBNL=/usr/src/libnl
32#CFLAGS += -I$(LIBNL)/include
33#LIBS += -L$(LIBNL)/lib
34
35# Driver interface for FreeBSD net80211 layer (e.g., Atheros driver)
36#CONFIG_DRIVER_BSD=y
37#CFLAGS += -I/usr/local/include
38#LIBS += -L/usr/local/lib
39
40# Driver interface for no driver (e.g., RADIUS server only)
41#CONFIG_DRIVER_NONE=y
42
43# IEEE 802.11F/IAPP
44CONFIG_IAPP=y
45
46# WPA2/IEEE 802.11i RSN pre-authentication
47CONFIG_RSN_PREAUTH=y
48
49# PeerKey handshake for Station to Station Link (IEEE 802.11e DLS)
50CONFIG_PEERKEY=y
51
52# IEEE 802.11w (management frame protection)
53# This version is an experimental implementation based on IEEE 802.11w/D1.0
54# draft and is subject to change since the standard has not yet been finalized.
55# Driver support is also needed for IEEE 802.11w.
56#CONFIG_IEEE80211W=y
57
58# Integrated EAP server
59CONFIG_EAP=y
60
61# EAP-MD5 for the integrated EAP server
62CONFIG_EAP_MD5=y
63
64# EAP-TLS for the integrated EAP server
65CONFIG_EAP_TLS=y
66
67# EAP-MSCHAPv2 for the integrated EAP server
68CONFIG_EAP_MSCHAPV2=y
69
70# EAP-PEAP for the integrated EAP server
71CONFIG_EAP_PEAP=y
72
73# EAP-GTC for the integrated EAP server
74CONFIG_EAP_GTC=y
75
76# EAP-TTLS for the integrated EAP server
77CONFIG_EAP_TTLS=y
78
79# EAP-SIM for the integrated EAP server
80#CONFIG_EAP_SIM=y
81
82# EAP-AKA for the integrated EAP server
83#CONFIG_EAP_AKA=y
84
85# EAP-AKA' for the integrated EAP server
86# This requires CONFIG_EAP_AKA to be enabled, too.
87#CONFIG_EAP_AKA_PRIME=y
88
89# EAP-PAX for the integrated EAP server
90#CONFIG_EAP_PAX=y
91
92# EAP-PSK for the integrated EAP server (this is _not_ needed for WPA-PSK)
93#CONFIG_EAP_PSK=y
94
95# EAP-SAKE for the integrated EAP server
96#CONFIG_EAP_SAKE=y
97
98# EAP-GPSK for the integrated EAP server
99#CONFIG_EAP_GPSK=y
100# Include support for optional SHA256 cipher suite in EAP-GPSK
101#CONFIG_EAP_GPSK_SHA256=y
102
103# EAP-FAST for the integrated EAP server
104# Note: Default OpenSSL package does not include support for all the
105# functionality needed for EAP-FAST. If EAP-FAST is enabled with OpenSSL,
106# the OpenSSL library must be patched (openssl-0.9.9-session-ticket.patch)
107# to add the needed functions.
108#CONFIG_EAP_FAST=y
109
110# Wi-Fi Protected Setup (WPS)
111CONFIG_WPS=y
112# Enable UPnP support for external WPS Registrars
113#CONFIG_WPS_UPNP=y
114
115# EAP-IKEv2
116#CONFIG_EAP_IKEV2=y
117
118# Trusted Network Connect (EAP-TNC)
119#CONFIG_EAP_TNC=y
120
121# PKCS#12 (PFX) support (used to read private key and certificate file from
122# a file that usually has extension .p12 or .pfx)
123CONFIG_PKCS12=y
124
125# RADIUS authentication server. This provides access to the integrated EAP
126# server from external hosts using RADIUS.
127CONFIG_RADIUS_SERVER=y
128
129# Build IPv6 support for RADIUS operations
130CONFIG_IPV6=y
131
132# IEEE Std 802.11r-2008 (Fast BSS Transition)
133#CONFIG_IEEE80211R=y
134
135# Use the hostapd's IEEE 802.11 authentication (ACL), but without
136# the IEEE 802.11 Management capability (e.g., madwifi or FreeBSD/net80211)
137CONFIG_DRIVER_RADIUS_ACL=y
138
139# IEEE 802.11n (High Throughput) support
140CONFIG_IEEE80211N=y
141
142# Remove debugging code that is printing out debug messages to stdout.
143# This can be used to reduce the size of the hostapd considerably if debugging
144# code is not needed.
145#CONFIG_NO_STDOUT_DEBUG=y
diff --git a/meta-oe/recipes-connectivity/hostapd/hostapd-2.2/hostapd.service b/meta-oe/recipes-connectivity/hostapd/hostapd-2.2/hostapd.service
new file mode 100644
index 000000000..151c0504f
--- /dev/null
+++ b/meta-oe/recipes-connectivity/hostapd/hostapd-2.2/hostapd.service
@@ -0,0 +1,11 @@
1[Unit]
2Description=Hostapd IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/EAP/RADIUS Authenticator
3After=network.target
4
5[Service]
6Type=forking
7PIDFile=/run/hostapd.pid
8ExecStart=@SBINDIR@/hostapd @SYSCONFDIR@/hostapd.conf -P /run/hostapd.pid -B
9
10[Install]
11WantedBy=multi-user.target
diff --git a/meta-oe/recipes-connectivity/hostapd/hostapd-2.2/init b/meta-oe/recipes-connectivity/hostapd/hostapd-2.2/init
new file mode 100644
index 000000000..8ba4e0794
--- /dev/null
+++ b/meta-oe/recipes-connectivity/hostapd/hostapd-2.2/init
@@ -0,0 +1,58 @@
1#!/bin/sh
2DAEMON=/usr/sbin/hostapd
3NAME=hostapd
4DESC="HOSTAP Daemon"
5ARGS="/etc/hostapd.conf -B"
6
7test -f $DAEMON || exit 0
8
9set -e
10
11# source function library
12. /etc/init.d/functions
13
14delay_stop() {
15 count=0
16 while [ $count -lt 9 ] ; do
17 if pidof $DAEMON >/dev/null; then
18 sleep 1
19 else
20 return 0
21 fi
22 count=`expr $count + 1`
23 done
24 echo "Failed to stop $DESC."
25 return 1
26}
27
28case "$1" in
29 start)
30 echo -n "Starting $DESC: "
31 start-stop-daemon -S -x $DAEMON -- $ARGS
32 echo "$NAME."
33 ;;
34 stop)
35 echo -n "Stopping $DESC: "
36 start-stop-daemon -K --oknodo -x $DAEMON
37 echo "$NAME."
38 ;;
39 restart)
40 $0 stop
41 delay_stop && $0 start
42 ;;
43 reload)
44 echo -n "Reloading $DESC: "
45 killall -HUP $(basename ${DAEMON})
46 echo "$NAME."
47 ;;
48 status)
49 status $DAEMON
50 exit $?
51 ;;
52 *)
53 echo "Usage: $0 {start|stop|restart|reload|status}"
54 exit 1
55 ;;
56esac
57
58exit 0
diff --git a/meta-oe/recipes-connectivity/hostapd/hostapd_2.2.bb b/meta-oe/recipes-connectivity/hostapd/hostapd_2.2.bb
new file mode 100644
index 000000000..b75f2b9a7
--- /dev/null
+++ b/meta-oe/recipes-connectivity/hostapd/hostapd_2.2.bb
@@ -0,0 +1,48 @@
1HOMEPAGE = "http://hostap.epitest.fi"
2SECTION = "kernel/userland"
3LICENSE = "GPLv2 | BSD"
4LIC_FILES_CHKSUM = "file://README;md5=0854a4da34ac3990770794d771fac7fd"
5DEPENDS = "libnl openssl"
6SUMMARY = "User space daemon for extended IEEE 802.11 management"
7
8inherit update-rc.d systemd
9INITSCRIPT_NAME = "hostapd"
10
11SYSTEMD_SERVICE_${PN} = "hostapd.service"
12SYSTEMD_AUTO_ENABLE_${PN} = "disable"
13
14DEFAULT_PREFERENCE = "-1"
15
16SRC_URI = " \
17 http://hostap.epitest.fi/releases/hostapd-${PV}.tar.gz \
18 file://defconfig \
19 file://init \
20 file://hostapd.service \
21"
22
23S = "${WORKDIR}/hostapd-${PV}/hostapd"
24
25
26do_configure() {
27 install -m 0644 ${WORKDIR}/defconfig ${S}/.config
28}
29
30do_compile() {
31 export CFLAGS="-MMD -O2 -Wall -g -I${STAGING_INCDIR}/libnl3"
32 make
33}
34
35do_install() {
36 install -d ${D}${sbindir} ${D}${sysconfdir}/init.d ${D}${systemd_unitdir}/system/
37 install -m 0644 ${S}/hostapd.conf ${D}${sysconfdir}
38 install -m 0755 ${S}/hostapd ${D}${sbindir}
39 install -m 0755 ${S}/hostapd_cli ${D}${sbindir}
40 install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/hostapd
41 install -m 0644 ${WORKDIR}/hostapd.service ${D}${systemd_unitdir}/system/
42 sed -i -e 's,@SBINDIR@,${sbindir},g' -e 's,@SYSCONFDIR@,${sysconfdir},g' ${D}${systemd_unitdir}/system/hostapd.service
43}
44
45CONFFILES_${PN} += "${sysconfdir}/hostapd.conf"
46
47SRC_URI[md5sum] = "23c1f78a693c3288802d516adb7fd289"
48SRC_URI[sha256sum] = "f15b6bcb434378860ea5b88dffed7f54d8cb71fff2146de0f006977a5e25a882"