summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/hostapd/hostapd_2.6.bb
diff options
context:
space:
mode:
authorHuang Qiyu <huangqy.fnst@cn.fujitsu.com>2017-04-26 10:22:03 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2017-04-26 20:14:16 +0200
commitba89d451fba299f00f3dff902cc6456106525fc9 (patch)
tree749eec8daa681fe82f45a2a6f92099061eefba8f /meta-oe/recipes-connectivity/hostapd/hostapd_2.6.bb
parentff85915aa00f44f108cb0e6fda7f11de08f33803 (diff)
downloadmeta-openembedded-ba89d451fba299f00f3dff902cc6456106525fc9.tar.gz
hostapd: 2.5 -> 2.6
1) Upgrade hostapd from 2.5 to 2.6. 2) License checksum changed,since the copyright years were updated. 2) Delete patch "0001-WPS-Reject-a-Credential-with-invalid-passphrase.patch", since it is integrated upstream. Signed-off-by: Huang Qiyu <huangqy.fnst@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity/hostapd/hostapd_2.6.bb')
-rw-r--r--meta-oe/recipes-connectivity/hostapd/hostapd_2.6.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/hostapd/hostapd_2.6.bb b/meta-oe/recipes-connectivity/hostapd/hostapd_2.6.bb
new file mode 100644
index 000000000..3b74f482a
--- /dev/null
+++ b/meta-oe/recipes-connectivity/hostapd/hostapd_2.6.bb
@@ -0,0 +1,47 @@
1HOMEPAGE = "http://w1.fi/hostapd/"
2SECTION = "kernel/userland"
3LICENSE = "GPLv2 | BSD"
4LIC_FILES_CHKSUM = "file://${B}/README;md5=8aa4e8c78b59b12016c4cb2d0a8db350"
5DEPENDS = "libnl openssl"
6SUMMARY = "User space daemon for extended IEEE 802.11 management"
7
8inherit update-rc.d systemd
9INITSCRIPT_NAME = "hostapd"
10
11SYSTEMD_SERVICE_${PN} = "hostapd.service"
12SYSTEMD_AUTO_ENABLE_${PN} = "disable"
13
14SRC_URI = " \
15 http://w1.fi/releases/hostapd-${PV}.tar.gz \
16 file://defconfig \
17 file://init \
18 file://hostapd.service \
19"
20
21S = "${WORKDIR}/hostapd-${PV}"
22B = "${WORKDIR}/hostapd-${PV}/hostapd"
23
24do_configure() {
25 install -m 0644 ${WORKDIR}/defconfig ${B}/.config
26}
27
28do_compile() {
29 export CFLAGS="-MMD -O2 -Wall -g -I${STAGING_INCDIR}/libnl3"
30 make
31}
32
33do_install() {
34 install -d ${D}${sbindir} ${D}${sysconfdir}/init.d ${D}${systemd_unitdir}/system/
35 install -m 0644 ${B}/hostapd.conf ${D}${sysconfdir}
36 install -m 0755 ${B}/hostapd ${D}${sbindir}
37 install -m 0755 ${B}/hostapd_cli ${D}${sbindir}
38 install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/hostapd
39 install -m 0644 ${WORKDIR}/hostapd.service ${D}${systemd_unitdir}/system/
40 sed -i -e 's,@SBINDIR@,${sbindir},g' -e 's,@SYSCONFDIR@,${sysconfdir},g' ${D}${systemd_unitdir}/system/hostapd.service
41}
42
43CONFFILES_${PN} += "${sysconfdir}/hostapd.conf"
44
45SRC_URI[md5sum] = "eaa56dce9bd8f1d195eb62596eab34c7"
46SRC_URI[sha256sum] = "01526b90c1d23bec4b0f052039cc4456c2fd19347b4d830d1d58a0a6aea7117d"
47