summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/gateone/gateone_git.bb
diff options
context:
space:
mode:
authorDan McDougall <daniel.mcdougall@liftoffsoftware.com>2014-05-03 11:19:23 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2014-05-04 17:14:11 +0200
commit25ca3cf168103ca2591658ffa83946ebd24733b5 (patch)
tree35fdabf9808607d50468364278d8986ef0f0a420 /meta-oe/recipes-connectivity/gateone/gateone_git.bb
parent55b09e522ca88c0c0b2dd7a36e4861a1cf6ca9c6 (diff)
downloadmeta-openembedded-25ca3cf168103ca2591658ffa83946ebd24733b5.tar.gz
gateone: Updated to version 1.2
This new version of Gate One uses a new configuration file format which means the old server.conf is gone. It now stores configuration files in /etc/gateone/conf.d. The /opt/gateone directory is also gone and instead the package installs like a regular Python module in site-packages. SSL certificates/keys are stored in /etc/gateone/ssl/. The new version requires python-tornado 3.1.1 (which was submitted earlier today) and the python-futures package (which was also submitted today). An 80oe.conf file has been added specific to OpenEmbedded that replaces the old pre-configured server.conf functionality. The old patch that removes the init script checks has been deprecated by the use of the --skip_init_scripts option which is now being passed to setup.py. Lastly, Gate One 1.2 is about twice as fast (benchmarked) as Gate One 1.1 on the Beaglebone platform. Signed-off-by: Dan McDougall <daniel.mcdougall@liftoffsoftware.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity/gateone/gateone_git.bb')
-rw-r--r--meta-oe/recipes-connectivity/gateone/gateone_git.bb42
1 files changed, 27 insertions, 15 deletions
diff --git a/meta-oe/recipes-connectivity/gateone/gateone_git.bb b/meta-oe/recipes-connectivity/gateone/gateone_git.bb
index 0069c26c1..edc997721 100644
--- a/meta-oe/recipes-connectivity/gateone/gateone_git.bb
+++ b/meta-oe/recipes-connectivity/gateone/gateone_git.bb
@@ -1,14 +1,14 @@
1SUMMARY = "HTML5 (plugin-free) web-based terminal emulator and SSH client" 1SUMMARY = "HTML5 (plugin-free) web-based terminal emulator and SSH client"
2LICENSE = "AGPL-3.0" 2LICENSE = "AGPL-3.0"
3LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=ee5b168fc7de89a0cadc49e27830aa2c" 3LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=834cbc6995db88433db17cdf8953a428"
4HOMEPAGE = "http://liftoffsoftware.com/Products/GateOne"
4 5
5PR = "r13" 6PV = "1.2"
6 7SRCREV = "1528d324088fc1c180b7fdf50f5b5c1af057eef6"
7PV = "1.1"
8SRCREV = "ea5db3dcb3bbbe445ae6d1a5611c1f8d547c57b9"
9SRC_URI = "git://github.com/liftoff/GateOne.git \ 8SRC_URI = "git://github.com/liftoff/GateOne.git \
9 file://0001-configuration.py-Hack-around-broken-gethostname-thin.patch \
10 file://gateone-avahi.service \ 10 file://gateone-avahi.service \
11 file://server.conf \ 11 file://80oe.conf \
12 file://gateone.service \ 12 file://gateone.service \
13 file://gateone-init \ 13 file://gateone-init \
14" 14"
@@ -16,33 +16,44 @@ SRC_URI = "git://github.com/liftoff/GateOne.git \
16S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"
17 17
18inherit distutils python-dir systemd update-rc.d 18inherit distutils python-dir systemd update-rc.d
19export prefix = "${localstatedir}"
19 20
20export prefix = "${localstatedir}/lib" 21DISTUTILS_INSTALL_ARGS = "--root=${D} \
22 --prefix=${prefix} \
23 --install-lib=${PYTHON_SITEPACKAGES_DIR} \
24 --install-data=${PYTHON_SITEPACKAGES_DIR} \
25 --install-scripts=${bindir} \
26 --skip_init_scripts"
21 27
22do_install_append() { 28do_install_append() {
23 install -d ${D}${localstatedir}/log/${BPN}
24 29
25 install -m 0755 -d ${D}${sysconfdir}/avahi/services/ 30 # fix up hardcoded paths
26 install -m 0644 ${WORKDIR}/gateone-avahi.service ${D}${sysconfdir}/avahi/services/ 31 sed -i -e s:/usr/bin:${bindir}:g ${WORKDIR}/gateone.service
27
28 install -m 0644 ${WORKDIR}/server.conf ${D}/var/lib/gateone/server.conf
29 32
30 install -d ${D}${systemd_unitdir}/system 33 install -d ${D}${systemd_unitdir}/system
31 install -m 0644 ${WORKDIR}/gateone.service ${D}${systemd_unitdir}/system 34 install -m 0644 ${WORKDIR}/gateone.service ${D}${systemd_unitdir}/system
32 35
33 install -d ${D}${sysconfdir}/init.d 36 install -d ${D}${sysconfdir}/init.d
34 install -m 0755 ${WORKDIR}/gateone-init ${D}${sysconfdir}/init.d/gateone 37 install -m 0755 ${WORKDIR}/gateone-init ${D}${sysconfdir}/init.d/gateone
38
39 install -m 0755 -d ${D}${sysconfdir}/avahi/services/
40 install -m 0644 ${WORKDIR}/gateone-avahi.service ${D}${sysconfdir}/avahi/services/
41
42 install -m 0755 -d ${D}${sysconfdir}/gateone/conf.d/
43 install -m 0644 ${WORKDIR}/80oe.conf ${D}${sysconfdir}/gateone/conf.d/80oe.conf
44
45 install -d ${D}${localstatedir}/lib/gateone
35} 46}
36 47
37FILES_${PN} = "${localstatedir}/lib ${localstatedir}/log ${localstatedir}/volatile/log ${base_libdir} ${sysconfdir} ${PYTHON_SITEPACKAGES_DIR}" 48FILES_${PN} = "${localstatedir}/lib ${bindir} ${base_libdir} ${sysconfdir} ${PYTHON_SITEPACKAGES_DIR}"
38RDEPENDS_${PN} = "file \ 49RDEPENDS_${PN} = "mime-support \
39 mime-support \
40 openssh-ssh \ 50 openssh-ssh \
41 python-compression \ 51 python-compression \
42 python-crypt \ 52 python-crypt \
43 python-datetime \ 53 python-datetime \
44 python-email \ 54 python-email \
45 python-fcntl \ 55 python-fcntl \
56 python-futures \
46 python-html \ 57 python-html \
47 python-imaging \ 58 python-imaging \
48 python-io \ 59 python-io \
@@ -55,6 +66,7 @@ RDEPENDS_${PN} = "file \
55 python-pyopenssl \ 66 python-pyopenssl \
56 python-re \ 67 python-re \
57 python-readline \ 68 python-readline \
69 python-setuptools \
58 python-shell \ 70 python-shell \
59 python-simplejson \ 71 python-simplejson \
60 python-subprocess \ 72 python-subprocess \