summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-bsp
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-05-14 10:05:20 -0700
committerKhem Raj <raj.khem@gmail.com>2024-05-23 08:44:44 -0700
commitc33cfad1b0e1f84f6605689457e16fb0518ee383 (patch)
tree9a280a37e62ddbfda807dea68419ab457bbe657a /meta-oe/recipes-bsp
parentffc64e9c6fee0af7eea3466135416d011172a5e6 (diff)
downloadmeta-openembedded-c33cfad1b0e1f84f6605689457e16fb0518ee383.tar.gz
recipes: Switch away from S = WORKDIR
Make it dependent on UNPACKDIR instead Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-bsp')
-rw-r--r--meta-oe/recipes-bsp/lm_sensors/lmsensors-config_1.0.bb13
-rw-r--r--meta-oe/recipes-bsp/pointercal/pointercal_0.0.bb3
2 files changed, 9 insertions, 7 deletions
diff --git a/meta-oe/recipes-bsp/lm_sensors/lmsensors-config_1.0.bb b/meta-oe/recipes-bsp/lm_sensors/lmsensors-config_1.0.bb
index 25ab44f75..6fad255c8 100644
--- a/meta-oe/recipes-bsp/lm_sensors/lmsensors-config_1.0.bb
+++ b/meta-oe/recipes-bsp/lm_sensors/lmsensors-config_1.0.bb
@@ -12,7 +12,8 @@ SRC_URI = "file://fancontrol \
12 file://sensors.conf \ 12 file://sensors.conf \
13 file://sensord \ 13 file://sensord \
14" 14"
15S = "${WORKDIR}" 15S = "${WORKDIR}/sources"
16UNPACKDIR = "${S}"
16 17
17PACKAGECONFIG ??= "sensord" 18PACKAGECONFIG ??= "sensord"
18PACKAGECONFIG[sensord] = ",," 19PACKAGECONFIG[sensord] = ",,"
@@ -22,20 +23,20 @@ RDEPENDS:${PN}-dev = ""
22do_install() { 23do_install() {
23 # Install fancontrol configuration file 24 # Install fancontrol configuration file
24 install -d ${D}${sysconfdir}/sysconfig 25 install -d ${D}${sysconfdir}/sysconfig
25 install -m 0644 ${WORKDIR}/fancontrol ${D}${sysconfdir} 26 install -m 0644 ${UNPACKDIR}/fancontrol ${D}${sysconfdir}
26 install -m 0644 ${WORKDIR}/sensord ${D}${sysconfdir}/sysconfig 27 install -m 0644 ${UNPACKDIR}/sensord ${D}${sysconfdir}/sysconfig
27 # Install libsensors configuration file 28 # Install libsensors configuration file
28 install -d ${D}${sysconfdir}/sensors.d 29 install -d ${D}${sysconfdir}/sensors.d
29 install -m 0644 ${WORKDIR}/sensors.conf ${D}${sysconfdir}/sensors.d 30 install -m 0644 ${UNPACKDIR}/sensors.conf ${D}${sysconfdir}/sensors.d
30 31
31 if ${@bb.utils.contains('PACKAGECONFIG', 'sensord', 'true', 'false', d)}; then 32 if ${@bb.utils.contains('PACKAGECONFIG', 'sensord', 'true', 'false', d)}; then
32 # Install sensord configuration file 33 # Install sensord configuration file
33 install -m 0644 ${WORKDIR}/sensord.conf ${D}${sysconfdir} 34 install -m 0644 ${UNPACKDIR}/sensord.conf ${D}${sysconfdir}
34 35
35 # Install sensord.cgi script and create world-writable 36 # Install sensord.cgi script and create world-writable
36 # web-accessible sensord directory 37 # web-accessible sensord directory
37 install -d ${D}/www/pages/cgi-bin 38 install -d ${D}/www/pages/cgi-bin
38 install -m 0755 ${WORKDIR}/sensord.cgi ${D}/www/pages/cgi-bin 39 install -m 0755 ${UNPACKDIR}/sensord.cgi ${D}/www/pages/cgi-bin
39 install -d -m a=rwxs ${D}/www/pages/sensord 40 install -d -m a=rwxs ${D}/www/pages/sensord
40 fi 41 fi
41} 42}
diff --git a/meta-oe/recipes-bsp/pointercal/pointercal_0.0.bb b/meta-oe/recipes-bsp/pointercal/pointercal_0.0.bb
index 61be5b2dc..20e870ccb 100644
--- a/meta-oe/recipes-bsp/pointercal/pointercal_0.0.bb
+++ b/meta-oe/recipes-bsp/pointercal/pointercal_0.0.bb
@@ -6,7 +6,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=4b5fcfc87fb615860d398b5e38685edf"
6SRC_URI = "file://pointercal \ 6SRC_URI = "file://pointercal \
7 file://COPYING" 7 file://COPYING"
8 8
9S = "${WORKDIR}" 9S = "${WORKDIR}/sources"
10UNPACKDIR = "${S}"
10 11
11do_install() { 12do_install() {
12 # Only install file if it has a contents 13 # Only install file if it has a contents