summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-bsp
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2017-10-26 14:26:01 -0700
committerArmin Kuster <akuster808@gmail.com>2018-03-01 16:10:37 -0800
commit9646fb8ced5a8eeb806b08ba0e97f359f866e8d3 (patch)
tree1b9e8597044973f70b498629423da0e2d515c899 /meta-oe/recipes-bsp
parent503a572e1420c650ea0279e3e7db1cb401239196 (diff)
downloadmeta-openembedded-9646fb8ced5a8eeb806b08ba0e97f359f866e8d3.tar.gz
efibootmgr: move to recipes-bsps
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-bsp')
-rw-r--r--meta-oe/recipes-bsp/efibootmgr/efibootmgr_0.15.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-oe/recipes-bsp/efibootmgr/efibootmgr_0.15.bb b/meta-oe/recipes-bsp/efibootmgr/efibootmgr_0.15.bb
new file mode 100644
index 000000000..9cc62a959
--- /dev/null
+++ b/meta-oe/recipes-bsp/efibootmgr/efibootmgr_0.15.bb
@@ -0,0 +1,27 @@
1DESCRIPTION = "Linux user-space application to modify the EFI Boot Manager."
2SUMMARY = "EFI Boot Manager"
3HOMEPAGE = "https://github.com/rhinstaller/efibootmgr"
4SECTION = "base"
5
6LICENSE = "GPLv2+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
8
9DEPENDS = "pciutils zlib efivar"
10
11COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
12
13SRCREV = "5c14da22802576a99ebb854f7aa174f796f7b031"
14SRC_URI = "git://github.com/rhinstaller/efibootmgr.git;protocol=https \
15 "
16S = "${WORKDIR}/git"
17
18inherit pkgconfig
19
20EXTRA_OEMAKE = "'EFIDIR=/' 'CC=${CC}' 'CFLAGS=${CFLAGS} -I${S}/src/include `pkg-config --cflags efivar`'"
21
22CFLAGS_append_toolchain-clang = " -Wno-error"
23do_install () {
24 install -D -p -m0755 ${B}/src/efibootmgr ${D}/${sbindir}/efibootmgr
25}
26
27CLEANBROKEN = "1"