summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-bsp
diff options
context:
space:
mode:
authorStefan Wiehler <stefan.wiehler@missinglinkelectronics.com>2018-10-10 11:29:04 +0200
committerKhem Raj <raj.khem@gmail.com>2018-10-10 08:53:21 -0700
commit62d21c0ca2ec269bbfb96530e934544f328256f7 (patch)
tree146e8cd5dc1ab26635da19a6ffb04c8cfc0091b7 /meta-oe/recipes-bsp
parent8e3db630d13d110387eeed08f789ab3b18a3920e (diff)
downloadmeta-openembedded-62d21c0ca2ec269bbfb96530e934544f328256f7.tar.gz
nvme-cli: add recipe
NVMe management command line interface. Signed-off-by: Stefan Wiehler <stefan.wiehler@missinglinkelectronics.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-bsp')
-rw-r--r--meta-oe/recipes-bsp/nvme-cli/files/0001-Makefile-fix-bash-completion-install-path.patch33
-rw-r--r--meta-oe/recipes-bsp/nvme-cli/nvme-cli_1.6.bb21
2 files changed, 54 insertions, 0 deletions
diff --git a/meta-oe/recipes-bsp/nvme-cli/files/0001-Makefile-fix-bash-completion-install-path.patch b/meta-oe/recipes-bsp/nvme-cli/files/0001-Makefile-fix-bash-completion-install-path.patch
new file mode 100644
index 000000000..154e1401a
--- /dev/null
+++ b/meta-oe/recipes-bsp/nvme-cli/files/0001-Makefile-fix-bash-completion-install-path.patch
@@ -0,0 +1,33 @@
1From ef64032b34190079aab591c64a25f7535a977390 Mon Sep 17 00:00:00 2001
2From: Stefan Wiehler <stefan.wiehler@missinglinkelectronics.com>
3Date: Tue, 9 Oct 2018 11:26:34 +0200
4Subject: [PATCH] Makefile: fix bash completion install path
5
6Change path to bash-completion upstream recommendation used by most
7distributions.
8
9Upstream-Status: Accepted
10
11Signed-off-by: Stefan Wiehler <stefan.wiehler@missinglinkelectronics.com>
12---
13 Makefile | 4 ++--
14 1 file changed, 2 insertions(+), 2 deletions(-)
15
16diff --git a/Makefile b/Makefile
17index fa587dd..433bc41 100644
18--- a/Makefile
19+++ b/Makefile
20@@ -69,8 +69,8 @@ install-bin: default
21 $(INSTALL) -m 755 nvme $(DESTDIR)$(SBINDIR)
22
23 install-bash-completion:
24- $(INSTALL) -d $(DESTDIR)$(PREFIX)/share/bash_completion.d
25- $(INSTALL) -m 644 -T ./completions/bash-nvme-completion.sh $(DESTDIR)$(PREFIX)/share/bash_completion.d/nvme
26+ $(INSTALL) -d $(DESTDIR)$(PREFIX)/share/bash-completion/completions
27+ $(INSTALL) -m 644 -T ./completions/bash-nvme-completion.sh $(DESTDIR)$(PREFIX)/share/bash-completion/completions/nvme
28
29 install: install-bin install-man install-bash-completion
30
31--
321.9.1
33
diff --git a/meta-oe/recipes-bsp/nvme-cli/nvme-cli_1.6.bb b/meta-oe/recipes-bsp/nvme-cli/nvme-cli_1.6.bb
new file mode 100644
index 000000000..9b7e6cd4d
--- /dev/null
+++ b/meta-oe/recipes-bsp/nvme-cli/nvme-cli_1.6.bb
@@ -0,0 +1,21 @@
1SUMMARY = "NVMe management command line interface"
2AUTHOR = "Stefan Wiehler <stefan.wiehler@missinglinkelectronics.com>"
3HOMEPAGE = "https://github.com/linux-nvme/nvme-cli"
4SECTION = "console/utils"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=8264535c0c4e9c6c335635c4026a8022"
7DEPENDS = "util-linux"
8PV .= "+git${SRCPV}"
9
10SRC_URI = "git://github.com/linux-nvme/nvme-cli.git \
11 file://0001-Makefile-fix-bash-completion-install-path.patch \
12 "
13SRCREV = "642d426faf8a67ed01e90f7c35c0d967f8cc52a3"
14
15S = "${WORKDIR}/git"
16
17inherit bash-completion
18
19do_install() {
20 oe_runmake PREFIX=${prefix} DESTDIR=${D} install
21}