summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2016-08-08 11:39:55 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2016-08-15 12:31:57 +0200
commit98c0577972fe6843c8b81d3751b197b4dbd62d22 (patch)
tree132c77886030e695826529b3c10e544f91e993f0 /meta-oe/recipes-benchmark
parentc29c7ed7642c9e58a8e46f24a3d29e9dfed7da5a (diff)
downloadmeta-openembedded-98c0577972fe6843c8b81d3751b197b4dbd62d22.tar.gz
glmark2: Fix gcc 6 deprecated declaration error
Replace auto_ptr with unique_ptr. Upstream-Status: Pending Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-benchmark')
-rw-r--r--meta-oe/recipes-benchmark/glmark2/files/Fix-deprecated-declarations.patch61
-rw-r--r--meta-oe/recipes-benchmark/glmark2/glmark2_git.bb3
2 files changed, 63 insertions, 1 deletions
diff --git a/meta-oe/recipes-benchmark/glmark2/files/Fix-deprecated-declarations.patch b/meta-oe/recipes-benchmark/glmark2/files/Fix-deprecated-declarations.patch
new file mode 100644
index 000000000..7a25de790
--- /dev/null
+++ b/meta-oe/recipes-benchmark/glmark2/files/Fix-deprecated-declarations.patch
@@ -0,0 +1,61 @@
1Index: git/src/image-reader.cpp
2===================================================================
3--- git.orig/src/image-reader.cpp 2016-07-29 16:17:51.000000000 -0500
4+++ git/src/image-reader.cpp 2016-07-29 16:18:43.000000000 -0500
5@@ -120,7 +120,7 @@
6
7 Log::debug("Reading PNG file %s\n", filename.c_str());
8
9- const std::auto_ptr<std::istream> is_ptr(Util::get_resource(filename));
10+ const std::unique_ptr<std::istream> is_ptr(Util::get_resource(filename));
11 if (!(*is_ptr)) {
12 Log::error("Cannot open file %s!\n", filename.c_str());
13 return false;
14Index: git/src/libmatrix/shader-source.cc
15===================================================================
16--- git.orig/src/libmatrix/shader-source.cc 2016-07-29 16:18:14.000000000 -0500
17+++ git/src/libmatrix/shader-source.cc 2016-07-29 16:18:43.000000000 -0500
18@@ -34,7 +34,7 @@
19 bool
20 ShaderSource::load_file(const std::string& filename, std::string& str)
21 {
22- std::auto_ptr<std::istream> is_ptr(Util::get_resource(filename));
23+ std::unique_ptr<std::istream> is_ptr(Util::get_resource(filename));
24 std::istream& inputFile(*is_ptr);
25
26 if (!inputFile)
27Index: git/src/model.cpp
28===================================================================
29--- git.orig/src/model.cpp 2016-07-29 16:18:00.000000000 -0500
30+++ git/src/model.cpp 2016-07-29 16:18:43.000000000 -0500
31@@ -361,7 +361,7 @@
32
33 Log::debug("Loading model from 3ds file '%s'\n", filename.c_str());
34
35- const std::auto_ptr<std::istream> input_file_ptr(Util::get_resource(filename));
36+ const std::unique_ptr<std::istream> input_file_ptr(Util::get_resource(filename));
37 std::istream& input_file(*input_file_ptr);
38
39 if (!input_file) {
40@@ -681,7 +681,7 @@
41 {
42 Log::debug("Loading model from obj file '%s'\n", filename.c_str());
43
44- const std::auto_ptr<std::istream> input_file_ptr(Util::get_resource(filename));
45+ const std::unique_ptr<std::istream> input_file_ptr(Util::get_resource(filename));
46 std::istream& inputFile(*input_file_ptr);
47 if (!inputFile)
48 {
49Index: git/src/scene-jellyfish.cpp
50===================================================================
51--- git.orig/src/scene-jellyfish.cpp 2016-07-29 16:18:08.000000000 -0500
52+++ git/src/scene-jellyfish.cpp 2016-07-29 16:18:43.000000000 -0500
53@@ -272,7 +272,7 @@
54 {
55 Log::debug("Loading model from file '%s'\n", filename.c_str());
56
57- const std::auto_ptr<std::istream> input_file_ptr(Util::get_resource(filename));
58+ const std::unique_ptr<std::istream> input_file_ptr(Util::get_resource(filename));
59 std::istream& inputFile(*input_file_ptr);
60 if (!inputFile)
61 {
diff --git a/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb b/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb
index 18267e96f..3a1c2e21a 100644
--- a/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb
+++ b/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb
@@ -15,7 +15,8 @@ PV = "2014.03+${SRCPV}"
15SRC_URI = "git://github.com/glmark2/glmark2.git;protocol=https \ 15SRC_URI = "git://github.com/glmark2/glmark2.git;protocol=https \
16 file://build-Check-packages-to-be-used-by-the-enabled-flavo.patch \ 16 file://build-Check-packages-to-be-used-by-the-enabled-flavo.patch \
17 file://0001-Fix-wl_surface-should-be-destoryed-after-the-wl_wind.patch \ 17 file://0001-Fix-wl_surface-should-be-destoryed-after-the-wl_wind.patch \
18 file://Fix-configure-for-sqrt-check.patch" 18 file://Fix-configure-for-sqrt-check.patch \
19 file://Fix-deprecated-declarations.patch"
19SRCREV = "fa71af2dfab711fac87b9504b6fc9862f44bf72a" 20SRCREV = "fa71af2dfab711fac87b9504b6fc9862f44bf72a"
20 21
21S = "${WORKDIR}/git" 22S = "${WORKDIR}/git"