summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark
diff options
context:
space:
mode:
authorJoe Slater <joe.slater@windriver.com>2023-02-08 16:54:08 -0800
committerKhem Raj <raj.khem@gmail.com>2023-02-09 15:56:25 -0800
commit32a0ff55166ae67931d48825e669893718663040 (patch)
tree36b8ac8effb640f8fda94f365359380bdebe8b51 /meta-oe/recipes-benchmark
parent21a0a86141a5c1d030ee9ad9fb5c5ba4fc474c03 (diff)
downloadmeta-openembedded-32a0ff55166ae67931d48825e669893718663040.tar.gz
phoronix-test-suite: fix CVE-2022-40704
CVE fix added after latest release (10.8.4). Signed-off-by: Joe Slater <joe.slater@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-benchmark')
-rw-r--r--meta-oe/recipes-benchmark/phoronix-test-suite/files/CVE-2022-40704.patch46
-rw-r--r--meta-oe/recipes-benchmark/phoronix-test-suite/phoronix-test-suite_10.8.4.bb5
2 files changed, 50 insertions, 1 deletions
diff --git a/meta-oe/recipes-benchmark/phoronix-test-suite/files/CVE-2022-40704.patch b/meta-oe/recipes-benchmark/phoronix-test-suite/files/CVE-2022-40704.patch
new file mode 100644
index 000000000..8b6405b4a
--- /dev/null
+++ b/meta-oe/recipes-benchmark/phoronix-test-suite/files/CVE-2022-40704.patch
@@ -0,0 +1,46 @@
1From d3880d9d3ba795138444da83f1153c3c3ac27640 Mon Sep 17 00:00:00 2001
2From: Michael Larabel <michael@phoronix.com>
3Date: Sat, 23 Jul 2022 07:32:43 -0500
4Subject: [PATCH] phoromatic: Explicitly check both $_GET abd $_POST in
5 phoromatic_quit_if_invalid_input_found()
6
7Fixes: https://github.com/phoronix-test-suite/phoronix-test-suite/issues/650#issuecomment-1193116678
8
9Upstream-Status: Backport
10CVE: CVE-2022-40704
11
12Reference to upstream patch:
13https://github.com/phoronix-test-suite/phoronix-test-suite/commit/d3880d9d3ba795138444da83f1153c3c3ac27640
14
15Signed-off-by: Li Wang <li.wang@windriver.com>
16---
17 pts-core/phoromatic/phoromatic_functions.php | 15 +++++++++++++--
18 1 file changed, 13 insertions(+), 2 deletions(-)
19
20diff --git a/pts-core/phoromatic/phoromatic_functions.php b/pts-core/phoromatic/phoromatic_functions.php
21index 74ccc5444c..c2313dcdea 100644
22--- a/pts-core/phoromatic/phoromatic_functions.php
23+++ b/pts-core/phoromatic/phoromatic_functions.php
24@@ -37,9 +37,20 @@ function phoromatic_quit_if_invalid_input_found($input_keys = null)
25 {
26 foreach($input_keys as $key)
27 {
28- if(isset($_REQUEST[$key]) && !empty($_REQUEST[$key]))
29+ if(isset($_GET[$key]) && !empty($_GET[$key]))
30 {
31- foreach(pts_arrays::to_array($_REQUEST[$key]) as $val_to_check)
32+ foreach(pts_arrays::to_array($_GET[$key]) as $val_to_check)
33+ {
34+ if(stripos($val_to_check, $invalid_string) !== false)
35+ {
36+ echo '<strong>Exited due to invalid input ( ' . $invalid_string . ') attempted:</strong> ' . htmlspecialchars($val_to_check);
37+ exit;
38+ }
39+ }
40+ }
41+ if(isset($_POST[$key]) && !empty($_POST[$key]))
42+ {
43+ foreach(pts_arrays::to_array($_POST[$key]) as $val_to_check)
44 {
45 if(stripos($val_to_check, $invalid_string) !== false)
46 {
diff --git a/meta-oe/recipes-benchmark/phoronix-test-suite/phoronix-test-suite_10.8.4.bb b/meta-oe/recipes-benchmark/phoronix-test-suite/phoronix-test-suite_10.8.4.bb
index be9756d9a..8de3314b3 100644
--- a/meta-oe/recipes-benchmark/phoronix-test-suite/phoronix-test-suite_10.8.4.bb
+++ b/meta-oe/recipes-benchmark/phoronix-test-suite/phoronix-test-suite_10.8.4.bb
@@ -5,7 +5,10 @@ LICENSE = "GPL-3.0-only"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" 5LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
6SECTION = "console/tests" 6SECTION = "console/tests"
7 7
8SRC_URI = "http://www.phoronix-test-suite.com/releases/${BP}.tar.gz" 8SRC_URI = "http://www.phoronix-test-suite.com/releases/${BP}.tar.gz \
9 file://CVE-2022-40704.patch \
10 "
11
9SRC_URI[sha256sum] = "1f2092d536c0a3193efc53e4a50f3cee65c0ef1a78d31e5404f1c663fff7b7f4" 12SRC_URI[sha256sum] = "1f2092d536c0a3193efc53e4a50f3cee65c0ef1a78d31e5404f1c663fff7b7f4"
10 13
11S = "${WORKDIR}/phoronix-test-suite" 14S = "${WORKDIR}/phoronix-test-suite"