summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-08-24 18:19:20 -0700
committerKhem Raj <raj.khem@gmail.com>2022-08-25 23:08:11 -0700
commit0e045dd97880bc10a6183fb15d2ceaf90892b752 (patch)
treeafb0f51ab2d72126fe15b68f4dbb71c36ed30cbe /meta-oe/recipes-benchmark
parent68c96b4ac30e7c47e6638d91e7b416438b190382 (diff)
downloadmeta-openembedded-0e045dd97880bc10a6183fb15d2ceaf90892b752.tar.gz
fio: Fix additional warnings seen with musl
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-benchmark')
-rw-r--r--meta-oe/recipes-benchmark/fio/fio/0001-io_uring-Replace-pthread_self-with-s-tid.patch45
-rw-r--r--meta-oe/recipes-benchmark/fio/fio_3.31.bb3
2 files changed, 47 insertions, 1 deletions
diff --git a/meta-oe/recipes-benchmark/fio/fio/0001-io_uring-Replace-pthread_self-with-s-tid.patch b/meta-oe/recipes-benchmark/fio/fio/0001-io_uring-Replace-pthread_self-with-s-tid.patch
new file mode 100644
index 000000000..766b1fe27
--- /dev/null
+++ b/meta-oe/recipes-benchmark/fio/fio/0001-io_uring-Replace-pthread_self-with-s-tid.patch
@@ -0,0 +1,45 @@
1From 269164337e0168b93661bb95c6a4e462ae6d8b61 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 24 Aug 2022 18:08:53 -0700
4Subject: [PATCH] io_uring: Replace pthread_self with s->tid
5
6__init_rand64 takes 64bit value and srand48 takes unsigned 32bit value,
7pthread_t is opaque type and some libcs ( e.g. musl ) do not define them
8in plain old data types and ends up with errors
9
10| t/io_uring.c:809:32: error: incompatible pointer to integer conversion passing 'pthread_t' (aka 'struct __pthread *') to parameter of type 'uint64_t' (aka 'unsigned long') [-Wint-conver
11sion]
12| __init_rand64(&s->rand_state, pthread_self());
13| ^~~~~~~~~~~~~~
14
15Upstream-Status: Submitted [https://github.com/axboe/fio/pull/1455]
16Signed-off-by: Khem Raj <raj.khem@gmail.com>
17---
18 t/io_uring.c | 5 ++---
19 1 file changed, 2 insertions(+), 3 deletions(-)
20
21diff --git a/t/io_uring.c b/t/io_uring.c
22index 35bf1956..f34a3554 100644
23--- a/t/io_uring.c
24+++ b/t/io_uring.c
25@@ -799,15 +799,14 @@ static int submitter_init(struct submitter *s)
26 int i, nr_batch, err;
27 static int init_printed;
28 char buf[80];
29-
30 s->tid = gettid();
31 printf("submitter=%d, tid=%d, file=%s, node=%d\n", s->index, s->tid,
32 s->filename, s->numa_node);
33
34 set_affinity(s);
35
36- __init_rand64(&s->rand_state, pthread_self());
37- srand48(pthread_self());
38+ __init_rand64(&s->rand_state, s->tid);
39+ srand48(s->tid);
40
41 for (i = 0; i < MAX_FDS; i++)
42 s->files[i].fileno = i;
43--
442.37.2
45
diff --git a/meta-oe/recipes-benchmark/fio/fio_3.31.bb b/meta-oe/recipes-benchmark/fio/fio_3.31.bb
index d655d6c98..f8d63014a 100644
--- a/meta-oe/recipes-benchmark/fio/fio_3.31.bb
+++ b/meta-oe/recipes-benchmark/fio/fio_3.31.bb
@@ -24,7 +24,8 @@ PACKAGECONFIG[numa] = ",--disable-numa,numactl"
24 24
25SRCREV = "6cafe8445fd1e04e5f7d67bbc73029a538d1b253" 25SRCREV = "6cafe8445fd1e04e5f7d67bbc73029a538d1b253"
26SRC_URI = "git://git.kernel.dk/fio.git;branch=master \ 26SRC_URI = "git://git.kernel.dk/fio.git;branch=master \
27" 27 file://0001-io_uring-Replace-pthread_self-with-s-tid.patch \
28 "
28 29
29S = "${WORKDIR}/git" 30S = "${WORKDIR}/git"
30 31