summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2022-09-05 17:02:09 +0800
committerKhem Raj <raj.khem@gmail.com>2022-09-05 22:49:34 -0700
commit05110a0ab499af7afa1956b8f11cc1ff7ff22706 (patch)
treeaa7541b56db4e6ef5ad139dd4bbae12a659bbf48 /meta-oe/recipes-benchmark
parent7ff4625e3d594a7002fc68f8de1b50652fd320c7 (diff)
downloadmeta-openembedded-05110a0ab499af7afa1956b8f11cc1ff7ff22706.tar.gz
fio: upgrade 3.31 -> 3.32
0001-io_uring-Replace-pthread_self-with-s-tid.patch removed since it's included in 3.32 Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-benchmark')
-rw-r--r--meta-oe/recipes-benchmark/fio/fio/0001-io_uring-Replace-pthread_self-with-s-tid.patch45
-rw-r--r--meta-oe/recipes-benchmark/fio/fio_3.32.bb (renamed from meta-oe/recipes-benchmark/fio/fio_3.31.bb)6
2 files changed, 2 insertions, 49 deletions
diff --git a/meta-oe/recipes-benchmark/fio/fio/0001-io_uring-Replace-pthread_self-with-s-tid.patch b/meta-oe/recipes-benchmark/fio/fio/0001-io_uring-Replace-pthread_self-with-s-tid.patch
deleted file mode 100644
index 766b1fe27..000000000
--- a/meta-oe/recipes-benchmark/fio/fio/0001-io_uring-Replace-pthread_self-with-s-tid.patch
+++ /dev/null
@@ -1,45 +0,0 @@
1From 269164337e0168b93661bb95c6a4e462ae6d8b61 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 24 Aug 2022 18:08:53 -0700
4Subject: [PATCH] io_uring: Replace pthread_self with s->tid
5
6__init_rand64 takes 64bit value and srand48 takes unsigned 32bit value,
7pthread_t is opaque type and some libcs ( e.g. musl ) do not define them
8in plain old data types and ends up with errors
9
10| t/io_uring.c:809:32: error: incompatible pointer to integer conversion passing 'pthread_t' (aka 'struct __pthread *') to parameter of type 'uint64_t' (aka 'unsigned long') [-Wint-conver
11sion]
12| __init_rand64(&s->rand_state, pthread_self());
13| ^~~~~~~~~~~~~~
14
15Upstream-Status: Submitted [https://github.com/axboe/fio/pull/1455]
16Signed-off-by: Khem Raj <raj.khem@gmail.com>
17---
18 t/io_uring.c | 5 ++---
19 1 file changed, 2 insertions(+), 3 deletions(-)
20
21diff --git a/t/io_uring.c b/t/io_uring.c
22index 35bf1956..f34a3554 100644
23--- a/t/io_uring.c
24+++ b/t/io_uring.c
25@@ -799,15 +799,14 @@ static int submitter_init(struct submitter *s)
26 int i, nr_batch, err;
27 static int init_printed;
28 char buf[80];
29-
30 s->tid = gettid();
31 printf("submitter=%d, tid=%d, file=%s, node=%d\n", s->index, s->tid,
32 s->filename, s->numa_node);
33
34 set_affinity(s);
35
36- __init_rand64(&s->rand_state, pthread_self());
37- srand48(pthread_self());
38+ __init_rand64(&s->rand_state, s->tid);
39+ srand48(s->tid);
40
41 for (i = 0; i < MAX_FDS; i++)
42 s->files[i].fileno = i;
43--
442.37.2
45
diff --git a/meta-oe/recipes-benchmark/fio/fio_3.31.bb b/meta-oe/recipes-benchmark/fio/fio_3.32.bb
index f8d63014a..90e28340c 100644
--- a/meta-oe/recipes-benchmark/fio/fio_3.31.bb
+++ b/meta-oe/recipes-benchmark/fio/fio_3.32.bb
@@ -22,10 +22,8 @@ PACKAGECONFIG_NUMA:armeb = ""
22PACKAGECONFIG ??= "${PACKAGECONFIG_NUMA}" 22PACKAGECONFIG ??= "${PACKAGECONFIG_NUMA}"
23PACKAGECONFIG[numa] = ",--disable-numa,numactl" 23PACKAGECONFIG[numa] = ",--disable-numa,numactl"
24 24
25SRCREV = "6cafe8445fd1e04e5f7d67bbc73029a538d1b253" 25SRCREV = "db7fc8d864dc4fb607a0379333a0db60431bd649"
26SRC_URI = "git://git.kernel.dk/fio.git;branch=master \ 26SRC_URI = "git://git.kernel.dk/fio.git;branch=master"
27 file://0001-io_uring-Replace-pthread_self-with-s-tid.patch \
28 "
29 27
30S = "${WORKDIR}/git" 28S = "${WORKDIR}/git"
31 29