summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark/phoronix-test-suite/phoronix-test-suite_6.0.1.bb
diff options
context:
space:
mode:
authorRoy Li <rongqing.li@windriver.com>2015-12-14 12:54:17 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-12-18 12:36:56 +0100
commit253c292d0edbff68b520f7c0b8ee04fefa1cffb6 (patch)
tree95cc94d26b08b1f8818a1cc5ffdd8447baed8e02 /meta-oe/recipes-benchmark/phoronix-test-suite/phoronix-test-suite_6.0.1.bb
parent58739d4a7986f14b4776ef1173a2d02778cfafdf (diff)
downloadmeta-openembedded-253c292d0edbff68b520f7c0b8ee04fefa1cffb6.tar.gz
phoronix-test-suite: uprev it to 6.0.1
1. inherit systemd and move the systemd unit files to correct dir 2. inherit allarch 3. add bash/python to RDEDEPENDS Signed-off-by: Roy Li <rongqing.li@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-benchmark/phoronix-test-suite/phoronix-test-suite_6.0.1.bb')
-rw-r--r--meta-oe/recipes-benchmark/phoronix-test-suite/phoronix-test-suite_6.0.1.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/phoronix-test-suite/phoronix-test-suite_6.0.1.bb b/meta-oe/recipes-benchmark/phoronix-test-suite/phoronix-test-suite_6.0.1.bb
new file mode 100644
index 000000000..5acfbf1bb
--- /dev/null
+++ b/meta-oe/recipes-benchmark/phoronix-test-suite/phoronix-test-suite_6.0.1.bb
@@ -0,0 +1,35 @@
1SUMMARY = "Phoronix Test Suite"
2DESCRIPTION = "The Phoronix Test Suite is designed to carry out both qualitative \
3and quantitative benchmarks in a clean, reproducible, and easy-to-use manner."
4LICENSE = "GPLv3"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
6SECTION = "console/tests"
7
8SRC_URI = "http://www.phoronix-test-suite.com/releases/${BP}.tar.gz"
9SRC_URI[md5sum] = "c3b26fcc57a3a253e558f759fdc1089f"
10SRC_URI[sha256sum] = "27add54f4ecb464549de580cece84b4a4945b99df3ef7ff7034eb7f23ffb3b39"
11S = "${WORKDIR}/phoronix-test-suite"
12
13inherit systemd allarch
14
15do_install() {
16 DESTDIR=${D} ./install-sh ${exec_prefix}
17
18 if [ "${systemd_unitdir}" != "/usr/lib/systemd" ]; then
19 install -d ${D}/${systemd_unitdir}/system/
20 mv ${D}/usr/lib/systemd/system/* ${D}/${systemd_unitdir}/system/
21 rm -rf ${D}/usr/lib/
22 fi
23}
24
25SYSTEMD_SERVICE_${PN} = "phoromatic-client.service phoromatic-server.service"
26RDEPENDS_${PN} += "bash python php-cli"
27
28FILES_${PN} += " \
29 ${datadir}/phoronix-test-suite \
30 ${datadir}/appdata/phoronix-test-suite.appdata.xml \
31 ${datadir}/icons/hicolor/48x48/apps/phoronix-test-suite.png \
32 ${datadir}/icons/hicolor/64x64/mimetypes/application-x-openbenchmarking.png \
33 ${datadir}/mime/packages/openbenchmarking-mime.xml \
34 ${systemd_unitdir}/* \
35"