summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark/memtester
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-benchmark/memtester
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-benchmark/memtester')
-rw-r--r--meta-oe/recipes-benchmark/memtester/files/Makefile.patch28
-rw-r--r--meta-oe/recipes-benchmark/memtester/memtester_4.1.3.bb25
2 files changed, 53 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/memtester/files/Makefile.patch b/meta-oe/recipes-benchmark/memtester/files/Makefile.patch
new file mode 100644
index 000000000..971e52ac7
--- /dev/null
+++ b/meta-oe/recipes-benchmark/memtester/files/Makefile.patch
@@ -0,0 +1,28 @@
1From 9a950b14b9f7767d83e5faac2e1e8203c500e2c2 Mon Sep 17 00:00:00 2001
2From: Rod Whitby <rod@whitby.id.au>
3Date: Tue, 25 Oct 2011 18:43:50 -0500
4Subject: [PATCH] memtester: Added patch to Makefile to change no-longer-supported 'head -1' syntax to 'head -n 1'.
5
6Signed-off-by: Joel A Fernandes <joelagnel@ti.com>
7---
8 Makefile | 4 ++--
9 1 files changed, 2 insertions(+), 2 deletions(-)
10
11diff --git a/Makefile b/Makefile
12index a271bf5..6bccff3 100644
13--- a/Makefile
14+++ b/Makefile
15@@ -32,8 +32,8 @@ install: all
16 auto-ccld.sh: \
17 conf-cc conf-ld warn-auto.sh
18 ( cat warn-auto.sh; \
19- echo CC=\'`head -1 conf-cc`\'; \
20- echo LD=\'`head -1 conf-ld`\' \
21+ echo CC=\'`head -n 1 conf-cc`\'; \
22+ echo LD=\'`head -n 1 conf-ld`\' \
23 ) > auto-ccld.sh
24
25 compile: \
26--
271.7.0.4
28
diff --git a/meta-oe/recipes-benchmark/memtester/memtester_4.1.3.bb b/meta-oe/recipes-benchmark/memtester/memtester_4.1.3.bb
new file mode 100644
index 000000000..74e704b7b
--- /dev/null
+++ b/meta-oe/recipes-benchmark/memtester/memtester_4.1.3.bb
@@ -0,0 +1,25 @@
1SUMMARY = "Utility to test for faulty memory subsystem"
2HOMEPAGE = "http://pyropus.ca/software/memtester/"
3SECTION = "console/utils"
4LICENSE = "GPLv2"
5
6LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
7
8SRC_URI = "http://pyropus.ca/software/memtester/old-versions/memtester-${PV}.tar.gz"
9SRC_URI += "file://Makefile.patch"
10
11SRC_URI[md5sum] = "e562451620cf5343016950462bc0dc38"
12SRC_URI[sha256sum] = "ac56f0b6d6d6e58bcf2a3fa7f2c9b29894f5177871f21115a1906c535106acf6"
13
14do_compile () {
15 echo '${CC} ${CFLAGS} -DPOSIX -c' > conf-cc
16 echo '${CC} ${LDFLAGS}' > conf-ld
17 oe_runmake
18}
19
20do_install () {
21 install -d ${D}${bindir}
22 install -d ${D}${mandir}/man8
23 install -m 0755 memtester ${D}${bindir}/
24 install -m 0755 memtester.8 ${D}${mandir}/man8/
25}