diff options
author | Ming Liu <liu.ming50@gmail.com> | 2017-11-15 15:41:16 +0100 |
---|---|---|
committer | Armin Kuster <akuster808@gmail.com> | 2017-11-19 13:41:58 -0800 |
commit | dafa2929e137e57e821e96b27d8880b5c8a293f1 (patch) | |
tree | 432917c4b4b3b40fb0b95354cfd618c00293f5d4 /meta-oe/recipes-benchmark/libc-bench | |
parent | 6363c0d0ee412b80877f890544df8343f5556be6 (diff) | |
download | meta-openembedded-dafa2929e137e57e821e96b27d8880b5c8a293f1.tar.gz |
libc-bench: add recipe
libc-bench is a set of time- and memory-efficiency tests to compare
implementations of various C/POSIX standard library functions.
Coverage includes:
- Malloc throughput with varying degrees and forms of contention between
threads.
- Malloc overhead and ability to return freed memory to the OS.
- Literal string and regular expression searches.
- Thread creation and joining throughput.
- UTF-8 decoding.
- Stdio buffered reads and writes.
Signed-off-by: Ming Liu <liu.ming50@gmail.com>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-benchmark/libc-bench')
-rw-r--r-- | meta-oe/recipes-benchmark/libc-bench/libc-bench_20110206.bb | 17 |
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/libc-bench/libc-bench_20110206.bb b/meta-oe/recipes-benchmark/libc-bench/libc-bench_20110206.bb new file mode 100644 index 000000000..f534c73b5 --- /dev/null +++ b/meta-oe/recipes-benchmark/libc-bench/libc-bench_20110206.bb | |||
@@ -0,0 +1,17 @@ | |||
1 | SUMMARY = "Tests to compare standard functions of different libc implementations" | ||
2 | DESCRIPTION = "libc-bench is a set of time- and memory-efficiency tests to compare \ | ||
3 | implementations of various C/POSIX standard library functions." | ||
4 | HOMEPAGE = "http://www.etalabs.net/libc-bench.html" | ||
5 | SECTION = "console/utils" | ||
6 | LICENSE = "GPLv2" | ||
7 | LIC_FILES_CHKSUM = "file://Makefile;md5=e12f113da27dfe9cfb6c2c537da8d8df" | ||
8 | |||
9 | SRC_URI = "http://www.etalabs.net/releases/${BPN}-${PV}.tar.gz" | ||
10 | |||
11 | SRC_URI[md5sum] = "f763de90f95fe68e4e03e5b6f49698ac" | ||
12 | SRC_URI[sha256sum] = "6825260aa5f15f4fbc7957ec578e9c859cbbe210e025ec74c4a0d05677523794" | ||
13 | |||
14 | do_install () { | ||
15 | install -d ${D}${bindir} | ||
16 | install -m 0755 ${B}/libc-bench ${D}${bindir} | ||
17 | } | ||