summaryrefslogtreecommitdiffstats
path: root/meta-oe/dynamic-layers
diff options
context:
space:
mode:
authorGyorgy Sarvari <skandigraun@gmail.com>2025-02-27 19:32:38 +0100
committerKhem Raj <raj.khem@gmail.com>2025-02-27 13:10:00 -0800
commit8dad29ad58e237e67d7d4f5b0dc68b10b9d86065 (patch)
tree041dc7349311828d2144e2a407db4ac08bcbd36a /meta-oe/dynamic-layers
parenta271d827afb29b225eb6adbc6da252d2943abf1d (diff)
downloadmeta-openembedded-8dad29ad58e237e67d7d4f5b0dc68b10b9d86065.tar.gz
thin-provisioning-tools: add target and sysroot to bindgen flags
BUILD_CFLAGS doesn't contain information about the recipe sysroot nor about the target system - and in case these are not specified for bindgen, then it builds against the build system's headers, using the build system's arch. Instead of BUILD_CFLAGS pass HOST_CC_ARCH and TOOLCHAIN_OPTIONS, which contain the sysroot and the requred cross-compiling flags, beside passing the target flag also. Fixes the following do_compile error: | /usr/include/linux/types.h:5:10: fatal error: 'asm/types.h' file not found | thread 'main' panicked at /yocto/sandbox/build/tmp/work/cortexa72-poky-linux/thin-provisioning-tools/1.1.0/sources-unpack/cargo_home/bitbake/devicemapper-sys-0.3.0/build.rs:24:10: | Could not generate dm.h bindings: ClangDiagnostic("/usr/include/linux/types.h:5:10: fatal error: 'asm/types.h' file not found\n") Signed-off-by: Gyorgy Sarvari <skandigraun@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/dynamic-layers')
-rw-r--r--meta-oe/dynamic-layers/clang-layer/recipes-support/thin-provisioning-tools/thin-provisioning-tools_1.1.0.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/dynamic-layers/clang-layer/recipes-support/thin-provisioning-tools/thin-provisioning-tools_1.1.0.bb b/meta-oe/dynamic-layers/clang-layer/recipes-support/thin-provisioning-tools/thin-provisioning-tools_1.1.0.bb
index bb4b53c28b..d0241c7016 100644
--- a/meta-oe/dynamic-layers/clang-layer/recipes-support/thin-provisioning-tools/thin-provisioning-tools_1.1.0.bb
+++ b/meta-oe/dynamic-layers/clang-layer/recipes-support/thin-provisioning-tools/thin-provisioning-tools_1.1.0.bb
@@ -21,7 +21,7 @@ inherit pkgconfig
21DEPENDS += "udev libdevmapper libdevmapper-native clang-native" 21DEPENDS += "udev libdevmapper libdevmapper-native clang-native"
22 22
23export LIBCLANG_PATH = "${WORKDIR}/recipe-sysroot-native${libdir}" 23export LIBCLANG_PATH = "${WORKDIR}/recipe-sysroot-native${libdir}"
24export BINDGEN_EXTRA_CLANG_ARGS = "${BUILD_CFLAGS}" 24export BINDGEN_EXTRA_CLANG_ARGS = "${HOST_CC_ARCH}${TOOLCHAIN_OPTIONS} --target=${TARGET_SYS}"
25 25
26require ${BPN}-crates.inc 26require ${BPN}-crates.inc
27require ${BPN}-git-crates.inc 27require ${BPN}-git-crates.inc