diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2021-07-29 17:04:53 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-08-03 10:21:25 -0700 |
commit | c61dc077bbd81260e4f167fa2251643ba0ba6974 (patch) | |
tree | 66c3243f8f64ae60f66f70a16e8128c247254a65 /meta-oe/dynamic-layers/meta-python | |
parent | c5f7cfb8db54cfa4257797db5bd87828dea43296 (diff) | |
download | meta-openembedded-c61dc077bbd81260e4f167fa2251643ba0ba6974.tar.gz |
Convert to new override syntax
This is the result of automated script (0.9.1) conversion:
oe-core/scripts/contrib/convert-overrides.py .
converting the metadata to use ":" as the override character instead of "_".
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/dynamic-layers/meta-python')
9 files changed, 90 insertions, 90 deletions
diff --git a/meta-oe/dynamic-layers/meta-python/recipes-benchmark/speedtest-cli/speedtest-cli_2.1.3.bb b/meta-oe/dynamic-layers/meta-python/recipes-benchmark/speedtest-cli/speedtest-cli_2.1.3.bb index 949b45ba8e..004c04e007 100644 --- a/meta-oe/dynamic-layers/meta-python/recipes-benchmark/speedtest-cli/speedtest-cli_2.1.3.bb +++ b/meta-oe/dynamic-layers/meta-python/recipes-benchmark/speedtest-cli/speedtest-cli_2.1.3.bb | |||
@@ -11,4 +11,4 @@ SRCREV = "42e96b13dda2afabbcec2622612d13495a415caa" | |||
11 | 11 | ||
12 | S = "${WORKDIR}/git" | 12 | S = "${WORKDIR}/git" |
13 | 13 | ||
14 | RDEPENDS_${PN} = "python3 python3-setuptools-scm" | 14 | RDEPENDS:${PN} = "python3 python3-setuptools-scm" |
diff --git a/meta-oe/dynamic-layers/meta-python/recipes-connectivity/lirc/lirc_0.10.1.bb b/meta-oe/dynamic-layers/meta-python/recipes-connectivity/lirc/lirc_0.10.1.bb index b68303241e..d8cf9b9f54 100644 --- a/meta-oe/dynamic-layers/meta-python/recipes-connectivity/lirc/lirc_0.10.1.bb +++ b/meta-oe/dynamic-layers/meta-python/recipes-connectivity/lirc/lirc_0.10.1.bb | |||
@@ -1,8 +1,8 @@ | |||
1 | DESCRIPTION = "LIRC is a package that allows you to decode and send infra-red signals of many commonly used remote controls." | 1 | DESCRIPTION = "LIRC is a package that allows you to decode and send infra-red signals of many commonly used remote controls." |
2 | DESCRIPTION_append_lirc = " This package contains the lirc daemon, libraries and tools." | 2 | DESCRIPTION:append_lirc = " This package contains the lirc daemon, libraries and tools." |
3 | DESCRIPTION_append_lirc-exec = " This package contains a daemon that runs programs on IR signals." | 3 | DESCRIPTION:append_lirc-exec = " This package contains a daemon that runs programs on IR signals." |
4 | DESCRIPTION_append_lirc-remotes = " This package contains some config files for remotes." | 4 | DESCRIPTION:append_lirc-remotes = " This package contains some config files for remotes." |
5 | DESCRIPTION_append_lirc-nslu2example = " This package contains a working config for RC5 remotes and a modified NSLU2." | 5 | DESCRIPTION:append_lirc-nslu2example = " This package contains a working config for RC5 remotes and a modified NSLU2." |
6 | HOMEPAGE = "http://www.lirc.org" | 6 | HOMEPAGE = "http://www.lirc.org" |
7 | SECTION = "console/network" | 7 | SECTION = "console/network" |
8 | LICENSE = "GPLv2" | 8 | LICENSE = "GPLv2" |
@@ -24,10 +24,10 @@ SRC_URI[md5sum] = "86c3f8e4efaba10571addb8313d1e040" | |||
24 | SRC_URI[sha256sum] = "8b753c60df2a7f5dcda2db72c38e448ca300c3b4f6000c1501fcb0bd5df414f2" | 24 | SRC_URI[sha256sum] = "8b753c60df2a7f5dcda2db72c38e448ca300c3b4f6000c1501fcb0bd5df414f2" |
25 | 25 | ||
26 | SYSTEMD_PACKAGES = "lirc lirc-exec" | 26 | SYSTEMD_PACKAGES = "lirc lirc-exec" |
27 | SYSTEMD_SERVICE_${PN} = "lircd.service lircmd.service lircd-setup.service lircd-uinput.service" | 27 | SYSTEMD_SERVICE:${PN} = "lircd.service lircmd.service lircd-setup.service lircd-uinput.service" |
28 | SYSTEMD_SERVICE_${PN}-exec = "irexec.service" | 28 | SYSTEMD_SERVICE:${PN}-exec = "irexec.service" |
29 | SYSTEMD_AUTO_ENABLE_lirc = "enable" | 29 | SYSTEMD_AUTO_ENABLE:lirc = "enable" |
30 | SYSTEMD_AUTO_ENABLE_lirc-exec = "enable" | 30 | SYSTEMD_AUTO_ENABLE:lirc-exec = "enable" |
31 | 31 | ||
32 | inherit autotools pkgconfig systemd python3native distutils-common-base | 32 | inherit autotools pkgconfig systemd python3native distutils-common-base |
33 | 33 | ||
@@ -43,12 +43,12 @@ CACHED_CONFIGUREVARS = "HAVE_WORKING_POLL=yes" | |||
43 | #EXTRA_OEMAKE = 'SUBDIRS="lib daemons tools"' | 43 | #EXTRA_OEMAKE = 'SUBDIRS="lib daemons tools"' |
44 | 44 | ||
45 | # Ensure python-pkg/VERSION exists | 45 | # Ensure python-pkg/VERSION exists |
46 | do_configure_append() { | 46 | do_configure:append() { |
47 | cp ${S}/VERSION ${S}/python-pkg/ | 47 | cp ${S}/VERSION ${S}/python-pkg/ |
48 | } | 48 | } |
49 | 49 | ||
50 | # Create PYTHON_TARBALL which LIRC needs for install-nodist_pkgdataDATA | 50 | # Create PYTHON_TARBALL which LIRC needs for install-nodist_pkgdataDATA |
51 | do_install_prepend() { | 51 | do_install:prepend() { |
52 | rm -rf ${WORKDIR}/${PN}-${PV}/python-pkg/dist/ | 52 | rm -rf ${WORKDIR}/${PN}-${PV}/python-pkg/dist/ |
53 | mkdir ${WORKDIR}/${PN}-${PV}/python-pkg/dist/ | 53 | mkdir ${WORKDIR}/${PN}-${PV}/python-pkg/dist/ |
54 | tar --exclude='${WORKDIR}/${PN}-${PV}/python-pkg/*' -czf ${WORKDIR}/${PN}-${PV}/python-pkg/dist/${PN}-${PV}.tar.gz ${S} | 54 | tar --exclude='${WORKDIR}/${PN}-${PV}/python-pkg/*' -czf ${WORKDIR}/${PN}-${PV}/python-pkg/dist/${PN}-${PV}.tar.gz ${S} |
@@ -57,7 +57,7 @@ do_install_prepend() { | |||
57 | # In code, path to python is a variable that is replaced with path to native version of it | 57 | # In code, path to python is a variable that is replaced with path to native version of it |
58 | # during the configure stage, e.g ../recipe-sysroot-native/usr/bin/python3-native/python3. | 58 | # during the configure stage, e.g ../recipe-sysroot-native/usr/bin/python3-native/python3. |
59 | # Replace it with #!/usr/bin/env python3 | 59 | # Replace it with #!/usr/bin/env python3 |
60 | do_install_append() { | 60 | do_install:append() { |
61 | sed -i '1c#!/usr/bin/env python3' ${D}${bindir}/lirc-setup \ | 61 | sed -i '1c#!/usr/bin/env python3' ${D}${bindir}/lirc-setup \ |
62 | ${D}${PYTHON_SITEPACKAGES_DIR}/lirc-setup/lirc-setup \ | 62 | ${D}${PYTHON_SITEPACKAGES_DIR}/lirc-setup/lirc-setup \ |
63 | ${D}${bindir}/irtext2udp \ | 63 | ${D}${bindir}/irtext2udp \ |
@@ -82,28 +82,28 @@ do_install_append() { | |||
82 | 82 | ||
83 | PACKAGES =+ "${PN}-contrib ${PN}-exec ${PN}-plugins ${PN}-python" | 83 | PACKAGES =+ "${PN}-contrib ${PN}-exec ${PN}-plugins ${PN}-python" |
84 | 84 | ||
85 | RDEPENDS_${PN} = "bash python3" | 85 | RDEPENDS:${PN} = "bash python3" |
86 | RDEPENDS_${PN}-exec = "${PN}" | 86 | RDEPENDS:${PN}-exec = "${PN}" |
87 | RDEPENDS_${PN}-python = "python3-shell python3-pyyaml python3-datetime python3-netclient python3-stringold" | 87 | RDEPENDS:${PN}-python = "python3-shell python3-pyyaml python3-datetime python3-netclient python3-stringold" |
88 | 88 | ||
89 | RRECOMMENDS_${PN} = "${PN}-exec ${PN}-plugins" | 89 | RRECOMMENDS:${PN} = "${PN}-exec ${PN}-plugins" |
90 | 90 | ||
91 | FILES_${PN}-plugins = "${libdir}/lirc/plugins/*.so ${datadir}/lirc/configs" | 91 | FILES:${PN}-plugins = "${libdir}/lirc/plugins/*.so ${datadir}/lirc/configs" |
92 | FILES_${PN}-contrib = "${datadir}/lirc/contrib" | 92 | FILES:${PN}-contrib = "${datadir}/lirc/contrib" |
93 | FILES_${PN}-exec = "${bindir}/irexec ${sysconfdir}/lircexec ${systemd_unitdir}/system/irexec.service" | 93 | FILES:${PN}-exec = "${bindir}/irexec ${sysconfdir}/lircexec ${systemd_unitdir}/system/irexec.service" |
94 | FILES_${PN} += "${systemd_unitdir}/system/lircexec.init" | 94 | FILES:${PN} += "${systemd_unitdir}/system/lircexec.init" |
95 | FILES_${PN} += "${systemd_unitdir}/system/lircd.service" | 95 | FILES:${PN} += "${systemd_unitdir}/system/lircd.service" |
96 | FILES_${PN} += "${systemd_unitdir}/system/lircd.socket" | 96 | FILES:${PN} += "${systemd_unitdir}/system/lircd.socket" |
97 | FILES_${PN} += "${libdir}/tmpfiles.d/lirc.conf" | 97 | FILES:${PN} += "${libdir}/tmpfiles.d/lirc.conf" |
98 | FILES_${PN}-dbg += "${libdir}/lirc/plugins/.debug" | 98 | FILES:${PN}-dbg += "${libdir}/lirc/plugins/.debug" |
99 | FILES_${PN}-python += "${bindir}/irdb-get ${bindir}/irtext2udp ${bindir}/lircd-setup ${bindir}/pronto2lirc ${libdir}/python*/site-packages" | 99 | FILES:${PN}-python += "${bindir}/irdb-get ${bindir}/irtext2udp ${bindir}/lircd-setup ${bindir}/pronto2lirc ${libdir}/python*/site-packages" |
100 | 100 | ||
101 | INITSCRIPT_PACKAGES = "lirc lirc-exec" | 101 | INITSCRIPT_PACKAGES = "lirc lirc-exec" |
102 | INITSCRIPT_NAME_lirc-exec = "lircexec" | 102 | INITSCRIPT_NAME:lirc-exec = "lircexec" |
103 | INITSCRIPT_PARAMS_lirc-exec = "defaults 21" | 103 | INITSCRIPT_PARAMS:lirc-exec = "defaults 21" |
104 | 104 | ||
105 | # this is for distributions that don't use udev | 105 | # this is for distributions that don't use udev |
106 | pkg_postinst_${PN}_append() { | 106 | pkg_postinst:${PN}:append() { |
107 | if [ ! -c $D/dev/lirc -a ! -f /sbin/udevd ]; then mknod $D/dev/lirc c 61 0; fi | 107 | if [ ! -c $D/dev/lirc -a ! -f /sbin/udevd ]; then mknod $D/dev/lirc c 61 0; fi |
108 | } | 108 | } |
109 | 109 | ||
diff --git a/meta-oe/dynamic-layers/meta-python/recipes-connectivity/thingsboard-gateway/thingsboard-gateway_2.5.2.bb b/meta-oe/dynamic-layers/meta-python/recipes-connectivity/thingsboard-gateway/thingsboard-gateway_2.5.2.bb index 2f0ef16c80..3c89c377a7 100644 --- a/meta-oe/dynamic-layers/meta-python/recipes-connectivity/thingsboard-gateway/thingsboard-gateway_2.5.2.bb +++ b/meta-oe/dynamic-layers/meta-python/recipes-connectivity/thingsboard-gateway/thingsboard-gateway_2.5.2.bb | |||
@@ -14,7 +14,7 @@ inherit pypi setuptools3 | |||
14 | 14 | ||
15 | PYPI_PACKAGE = "thingsboard-gateway" | 15 | PYPI_PACKAGE = "thingsboard-gateway" |
16 | 16 | ||
17 | RDEPENDS_${PN} += " python3-jsonpath-rw \ | 17 | RDEPENDS:${PN} += " python3-jsonpath-rw \ |
18 | python3-regex \ | 18 | python3-regex \ |
19 | python3-paho-mqtt \ | 19 | python3-paho-mqtt \ |
20 | python3-pyyaml \ | 20 | python3-pyyaml \ |
@@ -45,14 +45,14 @@ SRC_URI += "file://bacnet.json \ | |||
45 | inherit systemd | 45 | inherit systemd |
46 | 46 | ||
47 | SYSTEMD_PACKAGES = "${PN}" | 47 | SYSTEMD_PACKAGES = "${PN}" |
48 | SYSTEMD_SERVICE_${PN} = "thingsboard-gateway.service" | 48 | SYSTEMD_SERVICE:${PN} = "thingsboard-gateway.service" |
49 | 49 | ||
50 | FILES_${PN} += "/etc \ | 50 | FILES:${PN} += "/etc \ |
51 | /lib \ | 51 | /lib \ |
52 | /usr \ | 52 | /usr \ |
53 | " | 53 | " |
54 | 54 | ||
55 | do_install_append(){ | 55 | do_install:append(){ |
56 | 56 | ||
57 | install -d ${D}${sysconfdir}/thingsboard-gateway/config | 57 | install -d ${D}${sysconfdir}/thingsboard-gateway/config |
58 | 58 | ||
diff --git a/meta-oe/dynamic-layers/meta-python/recipes-core/packagegroups/packagegroup-meta-oe.bbappend b/meta-oe/dynamic-layers/meta-python/recipes-core/packagegroups/packagegroup-meta-oe.bbappend index 50da5e5d0d..09f3e34f4c 100644 --- a/meta-oe/dynamic-layers/meta-python/recipes-core/packagegroups/packagegroup-meta-oe.bbappend +++ b/meta-oe/dynamic-layers/meta-python/recipes-core/packagegroups/packagegroup-meta-oe.bbappend | |||
@@ -1,20 +1,20 @@ | |||
1 | RDEPENDS_packagegroup-meta-oe-devtools += "\ | 1 | RDEPENDS:packagegroup-meta-oe-devtools += "\ |
2 | python3-distutils-extra \ | 2 | python3-distutils-extra \ |
3 | rwmem \ | 3 | rwmem \ |
4 | speedtest-cli \ | 4 | speedtest-cli \ |
5 | mongodb \ | 5 | mongodb \ |
6 | " | 6 | " |
7 | 7 | ||
8 | RDEPENDS_packagegroup-meta-oe-connectivity += "\ | 8 | RDEPENDS:packagegroup-meta-oe-connectivity += "\ |
9 | lirc \ | 9 | lirc \ |
10 | " | 10 | " |
11 | 11 | ||
12 | RDEPENDS_packagegroup-meta-oe-extended += "\ | 12 | RDEPENDS:packagegroup-meta-oe-extended += "\ |
13 | lcdproc \ | 13 | lcdproc \ |
14 | mozjs \ | 14 | mozjs \ |
15 | " | 15 | " |
16 | RDEPENDS_packagegroup-meta-oe-support += "\ | 16 | RDEPENDS:packagegroup-meta-oe-support += "\ |
17 | smem \ | 17 | smem \ |
18 | " | 18 | " |
19 | RDEPENDS_packagegroup-meta-oe-extended_remove_libc-musl = "lcdproc" | 19 | RDEPENDS:packagegroup-meta-oe-extended:remove:libc-musl = "lcdproc" |
20 | 20 | ||
diff --git a/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb b/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb index 9d461078ae..eff014a4cb 100644 --- a/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb +++ b/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb | |||
@@ -33,13 +33,13 @@ SRC_URI = "git://github.com/mongodb/mongo.git;branch=v4.4 \ | |||
33 | file://0001-Use-explicit-typecast-to-size_t.patch \ | 33 | file://0001-Use-explicit-typecast-to-size_t.patch \ |
34 | file://PTHREAD_STACK_MIN.patch \ | 34 | file://PTHREAD_STACK_MIN.patch \ |
35 | " | 35 | " |
36 | SRC_URI_append_libc-musl ="\ | 36 | SRC_URI:append:libc-musl ="\ |
37 | file://0001-Mark-one-of-strerror_r-implementation-glibc-specific.patch \ | 37 | file://0001-Mark-one-of-strerror_r-implementation-glibc-specific.patch \ |
38 | file://0002-Fix-default-stack-size-to-256K.patch \ | 38 | file://0002-Fix-default-stack-size-to-256K.patch \ |
39 | file://0004-wiredtiger-Disable-strtouq-on-musl.patch \ | 39 | file://0004-wiredtiger-Disable-strtouq-on-musl.patch \ |
40 | " | 40 | " |
41 | 41 | ||
42 | SRC_URI_append_toolchain-clang = "\ | 42 | SRC_URI:append:toolchain-clang = "\ |
43 | file://0001-asio-Dont-use-experimental-with-clang.patch \ | 43 | file://0001-asio-Dont-use-experimental-with-clang.patch \ |
44 | " | 44 | " |
45 | 45 | ||
@@ -51,20 +51,20 @@ COMPATIBLE_HOST ?= '(x86_64|i.86|powerpc64|arm|aarch64).*-linux' | |||
51 | PACKAGECONFIG ??= "tcmalloc system-pcre" | 51 | PACKAGECONFIG ??= "tcmalloc system-pcre" |
52 | # gperftools compilation fails for arm below v7 because of missing support of | 52 | # gperftools compilation fails for arm below v7 because of missing support of |
53 | # dmb operation. So we use system-allocator instead of tcmalloc | 53 | # dmb operation. So we use system-allocator instead of tcmalloc |
54 | PACKAGECONFIG_remove_armv6 = "tcmalloc" | 54 | PACKAGECONFIG:remove:armv6 = "tcmalloc" |
55 | PACKAGECONFIG_remove_libc-musl = "tcmalloc" | 55 | PACKAGECONFIG:remove:libc-musl = "tcmalloc" |
56 | PACKAGECONFIG_remove_riscv64 = "tcmalloc" | 56 | PACKAGECONFIG:remove:riscv64 = "tcmalloc" |
57 | PACKAGECONFIG_remove_riscv32 = "tcmalloc" | 57 | PACKAGECONFIG:remove:riscv32 = "tcmalloc" |
58 | 58 | ||
59 | PACKAGECONFIG[tcmalloc] = "--use-system-tcmalloc,--allocator=system,gperftools," | 59 | PACKAGECONFIG[tcmalloc] = "--use-system-tcmalloc,--allocator=system,gperftools," |
60 | PACKAGECONFIG[shell] = ",--js-engine=none,," | 60 | PACKAGECONFIG[shell] = ",--js-engine=none,," |
61 | PACKAGECONFIG[system-pcre] = "--use-system-pcre,,libpcre," | 61 | PACKAGECONFIG[system-pcre] = "--use-system-pcre,,libpcre," |
62 | 62 | ||
63 | MONGO_ARCH ?= "${HOST_ARCH}" | 63 | MONGO_ARCH ?= "${HOST_ARCH}" |
64 | MONGO_ARCH_powerpc64le = "ppc64le" | 64 | MONGO_ARCH:powerpc64le = "ppc64le" |
65 | WIREDTIGER ?= "off" | 65 | WIREDTIGER ?= "off" |
66 | WIREDTIGER_x86-64 = "on" | 66 | WIREDTIGER:x86-64 = "on" |
67 | WIREDTIGER_aarch64 = "on" | 67 | WIREDTIGER:aarch64 = "on" |
68 | 68 | ||
69 | EXTRA_OESCONS = "PREFIX=${prefix} \ | 69 | EXTRA_OESCONS = "PREFIX=${prefix} \ |
70 | DESTDIR=${D} \ | 70 | DESTDIR=${D} \ |
@@ -85,7 +85,7 @@ EXTRA_OESCONS = "PREFIX=${prefix} \ | |||
85 | 85 | ||
86 | 86 | ||
87 | USERADD_PACKAGES = "${PN}" | 87 | USERADD_PACKAGES = "${PN}" |
88 | USERADD_PARAM_${PN} = "--system --no-create-home --home-dir /var/run/${BPN} --shell /bin/false --user-group ${BPN}" | 88 | USERADD_PARAM:${PN} = "--system --no-create-home --home-dir /var/run/${BPN} --shell /bin/false --user-group ${BPN}" |
89 | 89 | ||
90 | 90 | ||
91 | scons_do_compile() { | 91 | scons_do_compile() { |
@@ -123,6 +123,6 @@ scons_do_install() { | |||
123 | chown ${PN}:${PN} ${D}${localstatedir}/log/${BPN} | 123 | chown ${PN}:${PN} ${D}${localstatedir}/log/${BPN} |
124 | } | 124 | } |
125 | 125 | ||
126 | CONFFILES_${PN} = "${sysconfdir}/mongod.conf" | 126 | CONFFILES:${PN} = "${sysconfdir}/mongod.conf" |
127 | 127 | ||
128 | SYSTEMD_SERVICE_${PN} = "mongod.service" | 128 | SYSTEMD_SERVICE:${PN} = "mongod.service" |
diff --git a/meta-oe/dynamic-layers/meta-python/recipes-devtools/nanopb/nanopb_0.4.5.bb b/meta-oe/dynamic-layers/meta-python/recipes-devtools/nanopb/nanopb_0.4.5.bb index b2f8db9c0c..6ccefd22e5 100644 --- a/meta-oe/dynamic-layers/meta-python/recipes-devtools/nanopb/nanopb_0.4.5.bb +++ b/meta-oe/dynamic-layers/meta-python/recipes-devtools/nanopb/nanopb_0.4.5.bb | |||
@@ -11,16 +11,16 @@ S = "${WORKDIR}/git" | |||
11 | 11 | ||
12 | inherit cmake python3native | 12 | inherit cmake python3native |
13 | 13 | ||
14 | do_install_append() { | 14 | do_install:append() { |
15 | install -Dm 0755 ${S}/generator/nanopb_generator.py ${D}${bindir}/nanopb_generator.py | 15 | install -Dm 0755 ${S}/generator/nanopb_generator.py ${D}${bindir}/nanopb_generator.py |
16 | install -Dm 0755 ${S}/generator/protoc-gen-nanopb ${D}${bindir}/protoc-gen-nanopb | 16 | install -Dm 0755 ${S}/generator/protoc-gen-nanopb ${D}${bindir}/protoc-gen-nanopb |
17 | install -Dm 0755 ${S}/generator/proto/__init__.py ${D}${PYTHON_SITEPACKAGES_DIR}/proto/__init__.py | 17 | install -Dm 0755 ${S}/generator/proto/__init__.py ${D}${PYTHON_SITEPACKAGES_DIR}/proto/__init__.py |
18 | } | 18 | } |
19 | 19 | ||
20 | FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}" | 20 | FILES:${PN} += "${PYTHON_SITEPACKAGES_DIR}" |
21 | FILES_${PN}-dev += "${libdir}/cmake/${BPN}" | 21 | FILES:${PN}-dev += "${libdir}/cmake/${BPN}" |
22 | 22 | ||
23 | RDEPENDS_${PN} += "\ | 23 | RDEPENDS:${PN} += "\ |
24 | ${PYTHON_PN}-protobuf \ | 24 | ${PYTHON_PN}-protobuf \ |
25 | protobuf-compiler \ | 25 | protobuf-compiler \ |
26 | " | 26 | " |
diff --git a/meta-oe/dynamic-layers/meta-python/recipes-extended/lcdproc/lcdproc_git.bb b/meta-oe/dynamic-layers/meta-python/recipes-extended/lcdproc/lcdproc_git.bb index 35585d0690..4442793097 100644 --- a/meta-oe/dynamic-layers/meta-python/recipes-extended/lcdproc/lcdproc_git.bb +++ b/meta-oe/dynamic-layers/meta-python/recipes-extended/lcdproc/lcdproc_git.bb | |||
@@ -24,9 +24,9 @@ inherit autotools pkgconfig update-rc.d | |||
24 | 24 | ||
25 | LCD_DRIVERS ?= "all,!irman,!svga${SERIALVFD}" | 25 | LCD_DRIVERS ?= "all,!irman,!svga${SERIALVFD}" |
26 | SERIALVFD ?= "" | 26 | SERIALVFD ?= "" |
27 | SERIALVFD_libc-musl = ",!serialVFD" | 27 | SERIALVFD:libc-musl = ",!serialVFD" |
28 | SERIALVFD_libc-musl_x86 = "" | 28 | SERIALVFD:libc-musl:x86 = "" |
29 | SERIALVFD_libc-musl_x86-64 = "" | 29 | SERIALVFD:libc-musl:x86-64 = "" |
30 | 30 | ||
31 | LCD_DEFAULT_DRIVER ?= "curses" | 31 | LCD_DEFAULT_DRIVER ?= "curses" |
32 | 32 | ||
@@ -37,7 +37,7 @@ PACKAGECONFIG[g15] = ",,libg15 g15daemon libg15render," | |||
37 | PACKAGECONFIG[hid] = "--enable-libhid,--disable-libhid,libhid" | 37 | PACKAGECONFIG[hid] = "--enable-libhid,--disable-libhid,libhid" |
38 | PACKAGECONFIG[png] = "--enable-libpng,--disable-libpng,libpng" | 38 | PACKAGECONFIG[png] = "--enable-libpng,--disable-libpng,libpng" |
39 | 39 | ||
40 | LCD_DRIVERS_append = "${@bb.utils.contains('PACKAGECONFIG', 'g15', '', ',!g15', d)}" | 40 | LCD_DRIVERS:append = "${@bb.utils.contains('PACKAGECONFIG', 'g15', '', ',!g15', d)}" |
41 | 41 | ||
42 | EXTRA_OECONF = "--enable-drivers='${LCD_DRIVERS}'" | 42 | EXTRA_OECONF = "--enable-drivers='${LCD_DRIVERS}'" |
43 | 43 | ||
@@ -74,31 +74,31 @@ do_install () { | |||
74 | 74 | ||
75 | PACKAGES =+ "lcdd lcdvc" | 75 | PACKAGES =+ "lcdd lcdvc" |
76 | 76 | ||
77 | RRECOMMENDS_${PN} = "lcdd" | 77 | RRECOMMENDS:${PN} = "lcdd" |
78 | 78 | ||
79 | FILES_lcdd = "${sysconfdir}/LCDd.conf \ | 79 | FILES:lcdd = "${sysconfdir}/LCDd.conf \ |
80 | ${sbindir}/LCDd \ | 80 | ${sbindir}/LCDd \ |
81 | ${sysconfdir}/init.d/lcdd" | 81 | ${sysconfdir}/init.d/lcdd" |
82 | 82 | ||
83 | CONFFILES_lcdd = "${sysconfdir}/LCDd.conf" | 83 | CONFFILES:lcdd = "${sysconfdir}/LCDd.conf" |
84 | CONFFILES_${PN} = "${sysconfdir}/lcdproc.conf" | 84 | CONFFILES:${PN} = "${sysconfdir}/lcdproc.conf" |
85 | CONFFILES_lcdvc = "${sysconfdir}/lcdvc.conf" | 85 | CONFFILES:lcdvc = "${sysconfdir}/lcdvc.conf" |
86 | FILES_lcdvc = "${sysconfdir}/lcdvc.conf ${sbindir}/lcdvc" | 86 | FILES:lcdvc = "${sysconfdir}/lcdvc.conf ${sbindir}/lcdvc" |
87 | 87 | ||
88 | # Driver packages | 88 | # Driver packages |
89 | 89 | ||
90 | # USB / no USB trickery | 90 | # USB / no USB trickery |
91 | 91 | ||
92 | RCONFLICTS_lcdd-driver-hd47780nousb = "lcdd-driver-hd44780" | 92 | RCONFLICTS:lcdd-driver-hd47780nousb = "lcdd-driver-hd44780" |
93 | RCONFLICTS_lcdd-driver-hd47780 = "lcdd-driver-hd44780nousb" | 93 | RCONFLICTS:lcdd-driver-hd47780 = "lcdd-driver-hd44780nousb" |
94 | 94 | ||
95 | INITSCRIPT_PACKAGES = "lcdd lcdproc" | 95 | INITSCRIPT_PACKAGES = "lcdd lcdproc" |
96 | INITSCRIPT_NAME_lcdd = "lcdd" | 96 | INITSCRIPT_NAME:lcdd = "lcdd" |
97 | INITSCRIPT_NAME_lcdproc = "lcdproc" | 97 | INITSCRIPT_NAME:lcdproc = "lcdproc" |
98 | INITSCRIPT_PARAMS_lcdd = "defaults 70 21" | 98 | INITSCRIPT_PARAMS:lcdd = "defaults 70 21" |
99 | INITSCRIPT_PARAMS_lcdproc = "defaults 71 20" | 99 | INITSCRIPT_PARAMS:lcdproc = "defaults 71 20" |
100 | 100 | ||
101 | python populate_packages_prepend() { | 101 | python populate_packages:prepend() { |
102 | plugindir = d.expand('${libdir}/lcdproc') | 102 | plugindir = d.expand('${libdir}/lcdproc') |
103 | do_split_packages(d, plugindir, '(.*)\.so$', 'lcdd-driver-%s', 'LCDd driver for %s', prepend=True) | 103 | do_split_packages(d, plugindir, '(.*)\.so$', 'lcdd-driver-%s', 'LCDd driver for %s', prepend=True) |
104 | } | 104 | } |
diff --git a/meta-oe/dynamic-layers/meta-python/recipes-extended/mozjs/mozjs_60.9.0.bb b/meta-oe/dynamic-layers/meta-python/recipes-extended/mozjs/mozjs_60.9.0.bb index 7367c30a5e..1747e6b293 100644 --- a/meta-oe/dynamic-layers/meta-python/recipes-extended/mozjs/mozjs_60.9.0.bb +++ b/meta-oe/dynamic-layers/meta-python/recipes-extended/mozjs/mozjs_60.9.0.bb | |||
@@ -20,11 +20,11 @@ SRC_URI = " \ | |||
20 | file://0013-riscv-Disable-atomic-operations.patch \ | 20 | file://0013-riscv-Disable-atomic-operations.patch \ |
21 | file://0014-remove-JS_VOLATIME_ARM.patch \ | 21 | file://0014-remove-JS_VOLATIME_ARM.patch \ |
22 | " | 22 | " |
23 | SRC_URI_append_libc-musl = " \ | 23 | SRC_URI:append:libc-musl = " \ |
24 | file://musl/0001-support-musl.patch \ | 24 | file://musl/0001-support-musl.patch \ |
25 | file://musl/0002-js-Fix-build-with-musl.patch \ | 25 | file://musl/0002-js-Fix-build-with-musl.patch \ |
26 | " | 26 | " |
27 | SRC_URI_append_mipsarchn32 = " \ | 27 | SRC_URI:append:mipsarchn32 = " \ |
28 | file://mipsarchn32/0001-fix-compiling-failure-on-mips64-n32-bsp.patch \ | 28 | file://mipsarchn32/0001-fix-compiling-failure-on-mips64-n32-bsp.patch \ |
29 | " | 29 | " |
30 | SRC_URI[md5sum] = "69a0be9ce695e5dc4941ed0c78ef00c2" | 30 | SRC_URI[md5sum] = "69a0be9ce695e5dc4941ed0c78ef00c2" |
@@ -35,7 +35,7 @@ S = "${WORKDIR}/firefox-${@d.getVar("PV").replace("esr", "")}" | |||
35 | inherit autotools pkgconfig perlnative python3native | 35 | inherit autotools pkgconfig perlnative python3native |
36 | 36 | ||
37 | inherit features_check | 37 | inherit features_check |
38 | CONFLICT_DISTRO_FEATURES_mipsarchn32 = "ld-is-gold" | 38 | CONFLICT_DISTRO_FEATURES:mipsarchn32 = "ld-is-gold" |
39 | 39 | ||
40 | DEPENDS += " \ | 40 | DEPENDS += " \ |
41 | nspr zlib autoconf-2.13-native \ | 41 | nspr zlib autoconf-2.13-native \ |
@@ -62,18 +62,18 @@ EXTRA_OECONF = " \ | |||
62 | " | 62 | " |
63 | 63 | ||
64 | # Without this, JS_Init() will fail for mips64. | 64 | # Without this, JS_Init() will fail for mips64. |
65 | EXTRA_OECONF_append_mipsarch = " --with-intl-api=build" | 65 | EXTRA_OECONF:append:mipsarch = " --with-intl-api=build" |
66 | EXTRA_OECONF_append_powerpc = " --with-intl-api=build" | 66 | EXTRA_OECONF:append:powerpc = " --with-intl-api=build" |
67 | 67 | ||
68 | EXTRA_OECONF_append_mipsarch = " --disable-ion" | 68 | EXTRA_OECONF:append:mipsarch = " --disable-ion" |
69 | EXTRA_OECONF_append_riscv64 = " --disable-ion" | 69 | EXTRA_OECONF:append:riscv64 = " --disable-ion" |
70 | EXTRA_OECONF_append_riscv32 = " --disable-ion" | 70 | EXTRA_OECONF:append:riscv32 = " --disable-ion" |
71 | 71 | ||
72 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}" | 72 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}" |
73 | PACKAGECONFIG[x11] = "--x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR},--x-includes=no --x-libraries=no,virtual/libx11" | 73 | PACKAGECONFIG[x11] = "--x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR},--x-includes=no --x-libraries=no,virtual/libx11" |
74 | 74 | ||
75 | EXTRA_OEMAKE_task-compile += "BUILD_OPT=1 OS_LDFLAGS='-Wl,-latomic ${LDFLAGS}'" | 75 | EXTRA_OEMAKE:task-compile += "BUILD_OPT=1 OS_LDFLAGS='-Wl,-latomic ${LDFLAGS}'" |
76 | EXTRA_OEMAKE_task-install += "STATIC_LIBRARY_NAME=js_static" | 76 | EXTRA_OEMAKE:task-install += "STATIC_LIBRARY_NAME=js_static" |
77 | 77 | ||
78 | export HOST_CC = "${BUILD_CC}" | 78 | export HOST_CC = "${BUILD_CC}" |
79 | export HOST_CXX = "${BUILD_CXX}" | 79 | export HOST_CXX = "${BUILD_CXX}" |
@@ -110,12 +110,12 @@ do_configure() { | |||
110 | touch ${B}/config.status | 110 | touch ${B}/config.status |
111 | } | 111 | } |
112 | 112 | ||
113 | do_compile_prepend() { | 113 | do_compile:prepend() { |
114 | export SHELL="/bin/sh" | 114 | export SHELL="/bin/sh" |
115 | export PYTHONPATH=`cat ${B}/PYTHONPATH` | 115 | export PYTHONPATH=`cat ${B}/PYTHONPATH` |
116 | } | 116 | } |
117 | 117 | ||
118 | do_install_prepend() { | 118 | do_install:prepend() { |
119 | export SHELL="/bin/sh" | 119 | export SHELL="/bin/sh" |
120 | export PYTHONPATH=`cat ${B}/PYTHONPATH` | 120 | export PYTHONPATH=`cat ${B}/PYTHONPATH` |
121 | } | 121 | } |
@@ -124,15 +124,15 @@ inherit multilib_script multilib_header | |||
124 | 124 | ||
125 | MULTILIB_SCRIPTS += " ${PN}-dev:${bindir}/js60-config" | 125 | MULTILIB_SCRIPTS += " ${PN}-dev:${bindir}/js60-config" |
126 | 126 | ||
127 | do_install_append() { | 127 | do_install:append() { |
128 | oe_multilib_header mozjs-60/js-config.h | 128 | oe_multilib_header mozjs-60/js-config.h |
129 | sed -e 's@${STAGING_DIR_HOST}@@g' \ | 129 | sed -e 's@${STAGING_DIR_HOST}@@g' \ |
130 | -i ${D}${bindir}/js60-config | 130 | -i ${D}${bindir}/js60-config |
131 | } | 131 | } |
132 | 132 | ||
133 | PACKAGES =+ "lib${BPN}" | 133 | PACKAGES =+ "lib${BPN}" |
134 | FILES_lib${BPN} += "${libdir}/lib*.so" | 134 | FILES:lib${BPN} += "${libdir}/lib*.so" |
135 | FILES_${PN}-dev += "${bindir}/js60-config" | 135 | FILES:${PN}-dev += "${bindir}/js60-config" |
136 | 136 | ||
137 | # Fails to build with thumb-1 (qemuarm) | 137 | # Fails to build with thumb-1 (qemuarm) |
138 | #| {standard input}: Assembler messages: | 138 | #| {standard input}: Assembler messages: |
@@ -141,7 +141,7 @@ FILES_${PN}-dev += "${bindir}/js60-config" | |||
141 | #| {standard input}:2174: Error: unshifted register required -- `orr r1,r1,#(1<<20)' | 141 | #| {standard input}:2174: Error: unshifted register required -- `orr r1,r1,#(1<<20)' |
142 | #| {standard input}:2176: Error: instruction not supported in Thumb16 mode -- `subs r2,r2,#0x300' | 142 | #| {standard input}:2176: Error: instruction not supported in Thumb16 mode -- `subs r2,r2,#0x300' |
143 | #| {standard input}:2178: Error: instruction not supported in Thumb16 mode -- `subs r5,r2,#52' | 143 | #| {standard input}:2178: Error: instruction not supported in Thumb16 mode -- `subs r5,r2,#52' |
144 | ARM_INSTRUCTION_SET_armv5 = "arm" | 144 | ARM_INSTRUCTION_SET:armv5 = "arm" |
145 | ARM_INSTRUCTION_SET_armv4 = "arm" | 145 | ARM_INSTRUCTION_SET:armv4 = "arm" |
146 | 146 | ||
147 | DISABLE_STATIC = "" | 147 | DISABLE_STATIC = "" |
diff --git a/meta-oe/dynamic-layers/meta-python/recipes-support/smem/smem_1.5.bb b/meta-oe/dynamic-layers/meta-python/recipes-support/smem/smem_1.5.bb index 90db9c3f3e..544c15421b 100644 --- a/meta-oe/dynamic-layers/meta-python/recipes-support/smem/smem_1.5.bb +++ b/meta-oe/dynamic-layers/meta-python/recipes-support/smem/smem_1.5.bb | |||
@@ -33,11 +33,11 @@ do_install() { | |||
33 | install -m 0644 ${S}/smem.8 ${D}/${mandir}/man8/ | 33 | install -m 0644 ${S}/smem.8 ${D}/${mandir}/man8/ |
34 | } | 34 | } |
35 | 35 | ||
36 | RDEPENDS_${PN} = "python3-core python3-compression" | 36 | RDEPENDS:${PN} = "python3-core python3-compression" |
37 | RRECOMMENDS_${PN} = "python3-matplotlib python3-numpy" | 37 | RRECOMMENDS:${PN} = "python3-matplotlib python3-numpy" |
38 | 38 | ||
39 | PACKAGE_BEFORE_PN = "smemcap" | 39 | PACKAGE_BEFORE_PN = "smemcap" |
40 | 40 | ||
41 | FILES_smemcap = "${bindir}/smemcap" | 41 | FILES:smemcap = "${bindir}/smemcap" |
42 | 42 | ||
43 | BBCLASSEXTEND = "native" | 43 | BBCLASSEXTEND = "native" |