diff options
author | Martin Jansa <martin.jansa@gmail.com> | 2023-09-22 16:14:23 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-09-22 07:36:16 -0700 |
commit | 4377cea9dd6efdf07a82f6308818503588212323 (patch) | |
tree | 42897a035243454f07f7b09514db930d199d3a76 /meta-oe/dynamic-layers/meta-python | |
parent | 9d4964c709720496275205c7a338223e2b65c994 (diff) | |
download | meta-openembedded-4377cea9dd6efdf07a82f6308818503588212323.tar.gz |
mongodb: Fix build on 32bit
Signed-off-by: Martin Jansa <martin.jansa@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/dynamic-layers/meta-python')
-rw-r--r-- | meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb/0001-Fix-build-on-32bit.patch | 38 | ||||
-rw-r--r-- | meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb | 1 |
2 files changed, 39 insertions, 0 deletions
diff --git a/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb/0001-Fix-build-on-32bit.patch b/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb/0001-Fix-build-on-32bit.patch new file mode 100644 index 000000000..4abc04415 --- /dev/null +++ b/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb/0001-Fix-build-on-32bit.patch | |||
@@ -0,0 +1,38 @@ | |||
1 | From b172ebe7e709b10338c1b260310dacc15c557cff Mon Sep 17 00:00:00 2001 | ||
2 | From: Martin Jansa <martin.jansa@gmail.com> | ||
3 | Date: Fri, 22 Sep 2023 15:37:29 +0200 | ||
4 | Subject: [PATCH] Fix build on 32bit | ||
5 | |||
6 | * fixes: | ||
7 | src/mongo/util/net/http_client_curl.cpp: In function 'size_t mongo::{anonymous}::ReadMemoryCallback(char*, size_t, size_t, void*)': | ||
8 | src/mongo/util/net/http_client_curl.cpp:172:21: error: no matching function for call to 'min(size_t, long unsigned int)' | ||
9 | 172 | std::min(size * nitems, static_cast<unsigned long>(bufReader->remaining())); | ||
10 | | ~~~~~~~~^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ | ||
11 | |||
12 | * reported in: | ||
13 | https://jira.mongodb.org/browse/SERVER-73007 | ||
14 | but will probably get closed like: | ||
15 | mongodb/0001-Fix-type-mismatch-on-32bit-arches.patch | ||
16 | submitted in: | ||
17 | https://jira.mongodb.org/browse/SERVER-74633 | ||
18 | as they don't support 32bit builds | ||
19 | |||
20 | Signed-off-by: Martin Jansa <martin.jansa@gmail.com> | ||
21 | Upstream-Status: Pending | ||
22 | --- | ||
23 | src/mongo/util/net/http_client_curl.cpp | 2 +- | ||
24 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
25 | |||
26 | diff --git a/src/mongo/util/net/http_client_curl.cpp b/src/mongo/util/net/http_client_curl.cpp | ||
27 | index 57290d0f8ed..f251fe2a550 100644 | ||
28 | --- a/src/mongo/util/net/http_client_curl.cpp | ||
29 | +++ b/src/mongo/util/net/http_client_curl.cpp | ||
30 | @@ -169,7 +169,7 @@ size_t ReadMemoryCallback(char* buffer, size_t size, size_t nitems, void* instre | ||
31 | |||
32 | if (bufReader->remaining() > 0) { | ||
33 | size_t readSize = | ||
34 | - std::min(size * nitems, static_cast<unsigned long>(bufReader->remaining())); | ||
35 | + std::min(size * nitems, static_cast<size_t>(bufReader->remaining())); | ||
36 | auto buf = bufReader->readBytes(readSize); | ||
37 | memcpy(buffer, buf.rawData(), readSize); | ||
38 | ret = readSize; | ||
diff --git a/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb b/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb index f1a508f3f..037d58cf1 100644 --- a/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb +++ b/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb | |||
@@ -35,6 +35,7 @@ SRC_URI = "git://github.com/mongodb/mongo.git;branch=v4.4;protocol=https \ | |||
35 | file://0001-free_mon-Include-missing-cstdint.patch \ | 35 | file://0001-free_mon-Include-missing-cstdint.patch \ |
36 | file://0001-apply-msvc-workaround-for-clang-16.patch \ | 36 | file://0001-apply-msvc-workaround-for-clang-16.patch \ |
37 | file://0001-Fix-type-mismatch-on-32bit-arches.patch \ | 37 | file://0001-Fix-type-mismatch-on-32bit-arches.patch \ |
38 | file://0001-Fix-build-on-32bit.patch \ | ||
38 | " | 39 | " |
39 | SRC_URI:append:libc-musl ="\ | 40 | SRC_URI:append:libc-musl ="\ |
40 | file://0001-Mark-one-of-strerror_r-implementation-glibc-specific.patch \ | 41 | file://0001-Mark-one-of-strerror_r-implementation-glibc-specific.patch \ |