summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-08-29 13:03:26 -0700
committerKhem Raj <raj.khem@gmail.com>2022-08-30 00:14:58 -0700
commite2b1b060b038ce26578e1672a1211b948f789bd6 (patch)
tree1d01afb4f45b8431e6aa13c710df0ee39756fbf5 /meta-networking
parent5408788e2b846df6bffbb9e007e2467b8d741f7d (diff)
downloadmeta-openembedded-e2b1b060b038ce26578e1672a1211b948f789bd6.tar.gz
openflow: Include sys/stat.h for fchmod
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-protocols/openflow/openflow/0001-socket-util-Include-sys-stat.h-for-fchmod.patch23
-rw-r--r--meta-networking/recipes-protocols/openflow/openflow_git.bb4
2 files changed, 25 insertions, 2 deletions
diff --git a/meta-networking/recipes-protocols/openflow/openflow/0001-socket-util-Include-sys-stat.h-for-fchmod.patch b/meta-networking/recipes-protocols/openflow/openflow/0001-socket-util-Include-sys-stat.h-for-fchmod.patch
new file mode 100644
index 0000000000..97e3422166
--- /dev/null
+++ b/meta-networking/recipes-protocols/openflow/openflow/0001-socket-util-Include-sys-stat.h-for-fchmod.patch
@@ -0,0 +1,23 @@
1From b875c6e264eaf7350ad4e4ebf427692d8fd3cd72 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 29 Aug 2022 12:58:53 -0700
4Subject: [PATCH] socket-util: Include sys/stat.h for fchmod
5
6Upstream-Status: Pending
7Signed-off-by: Khem Raj <raj.khem@gmail.com>
8---
9 lib/socket-util.c | 1 +
10 1 file changed, 1 insertion(+)
11
12diff --git a/lib/socket-util.c b/lib/socket-util.c
13index c7b5d6d..5b3d602 100644
14--- a/lib/socket-util.c
15+++ b/lib/socket-util.c
16@@ -42,6 +42,7 @@
17 #include <stdio.h>
18 #include <string.h>
19 #include <sys/resource.h>
20+#include <sys/stat.h>
21 #include <sys/un.h>
22 #include <unistd.h>
23 #include "fatal-signal.h"
diff --git a/meta-networking/recipes-protocols/openflow/openflow_git.bb b/meta-networking/recipes-protocols/openflow/openflow_git.bb
index b6cef0730a..1ac5dd4105 100644
--- a/meta-networking/recipes-protocols/openflow/openflow_git.bb
+++ b/meta-networking/recipes-protocols/openflow/openflow_git.bb
@@ -3,8 +3,8 @@ include ${BPN}.inc
3SRCREV = "c84f33f09d5dbcfc9b489f64cb30475bf36f653a" 3SRCREV = "c84f33f09d5dbcfc9b489f64cb30475bf36f653a"
4PV = "1.0+git${SRCPV}" 4PV = "1.0+git${SRCPV}"
5 5
6SRC_URI += "\ 6SRC_URI += "file://0001-Check-and-use-strlcpy-from-libc-before-defining-own.patch \
7 file://0001-Check-and-use-strlcpy-from-libc-before-defining-own.patch \
8 file://0002-lib-netdev-Adjust-header-include-sequence.patch \ 7 file://0002-lib-netdev-Adjust-header-include-sequence.patch \
9 file://0001-generate-not-static-get_dh-functions.patch \ 8 file://0001-generate-not-static-get_dh-functions.patch \
9 file://0001-socket-util-Include-sys-stat.h-for-fchmod.patch \
10 " 10 "