summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-03-06 16:34:46 -0800
committerKhem Raj <raj.khem@gmail.com>2024-03-08 10:07:26 -0800
commitdafd02adc5ae850fd426d33d65ad07aab41b947f (patch)
tree640e89bf0a170ee9480347ce7400ca4f1ffe0c02 /meta-networking
parentbf30c08dd568edf0fe2e910efe228958b1afa1a3 (diff)
downloadmeta-openembedded-dafd02adc5ae850fd426d33d65ad07aab41b947f.tar.gz
squid: Upgrade to 6.8
Drop a patch which was needed for older gcc Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-daemons/squid/files/0001-configure-Check-for-Wno-error-format-truncation-comp.patch120
-rw-r--r--meta-networking/recipes-daemons/squid/files/0002-squid-make-squid-conf-tests-run-on-target-device.patch4
-rw-r--r--meta-networking/recipes-daemons/squid/files/Set-up-for-cross-compilation.patch2
-rw-r--r--meta-networking/recipes-daemons/squid/files/Skip-AC_RUN_IFELSE-tests.patch6
-rw-r--r--meta-networking/recipes-daemons/squid/files/squid-use-serial-tests-config-needed-by-ptest.patch2
-rw-r--r--meta-networking/recipes-daemons/squid/squid_6.8.bb (renamed from meta-networking/recipes-daemons/squid/squid_6.7.bb)7
6 files changed, 3 insertions, 138 deletions
diff --git a/meta-networking/recipes-daemons/squid/files/0001-configure-Check-for-Wno-error-format-truncation-comp.patch b/meta-networking/recipes-daemons/squid/files/0001-configure-Check-for-Wno-error-format-truncation-comp.patch
deleted file mode 100644
index a478dcd80..000000000
--- a/meta-networking/recipes-daemons/squid/files/0001-configure-Check-for-Wno-error-format-truncation-comp.patch
+++ /dev/null
@@ -1,120 +0,0 @@
1From 38e7e90cc2075952c1b74f5fca826f9c6cadb2f0 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 22 Apr 2017 11:54:57 -0700
4Subject: [PATCH] configure: Check for -Wno-error=format-truncation compiler
5 option
6
7If this option is supported by compiler then disable it ( gcc7+)
8Fixes
9client.c:834:23: error: '%s' directive output may be truncated writing up to 1023 bytes into a region of size 1010 [-Werror=format-truncation=]
10
11Signed-off-by: Khem Raj <raj.khem@gmail.com>
12
13---
14Upstream-Status: Pending
15
16 acinclude/ax_check_compile_flag.m4 | 74 ++++++++++++++++++++++++++++++
17 configure.ac | 2 +
18 2 files changed, 76 insertions(+)
19 create mode 100644 acinclude/ax_check_compile_flag.m4
20
21diff --git a/acinclude/ax_check_compile_flag.m4 b/acinclude/ax_check_compile_flag.m4
22new file mode 100644
23index 0000000..dcabb92
24--- /dev/null
25+++ b/acinclude/ax_check_compile_flag.m4
26@@ -0,0 +1,74 @@
27+# ===========================================================================
28+# https://www.gnu.org/software/autoconf-archive/ax_check_compile_flag.html
29+# ===========================================================================
30+#
31+# SYNOPSIS
32+#
33+# AX_CHECK_COMPILE_FLAG(FLAG, [ACTION-SUCCESS], [ACTION-FAILURE], [EXTRA-FLAGS], [INPUT])
34+#
35+# DESCRIPTION
36+#
37+# Check whether the given FLAG works with the current language's compiler
38+# or gives an error. (Warnings, however, are ignored)
39+#
40+# ACTION-SUCCESS/ACTION-FAILURE are shell commands to execute on
41+# success/failure.
42+#
43+# If EXTRA-FLAGS is defined, it is added to the current language's default
44+# flags (e.g. CFLAGS) when the check is done. The check is thus made with
45+# the flags: "CFLAGS EXTRA-FLAGS FLAG". This can for example be used to
46+# force the compiler to issue an error when a bad flag is given.
47+#
48+# INPUT gives an alternative input source to AC_COMPILE_IFELSE.
49+#
50+# NOTE: Implementation based on AX_CFLAGS_GCC_OPTION. Please keep this
51+# macro in sync with AX_CHECK_{PREPROC,LINK}_FLAG.
52+#
53+# LICENSE
54+#
55+# Copyright (c) 2008 Guido U. Draheim <guidod@gmx.de>
56+# Copyright (c) 2011 Maarten Bosmans <mkbosmans@gmail.com>
57+#
58+# This program is free software: you can redistribute it and/or modify it
59+# under the terms of the GNU General Public License as published by the
60+# Free Software Foundation, either version 3 of the License, or (at your
61+# option) any later version.
62+#
63+# This program is distributed in the hope that it will be useful, but
64+# WITHOUT ANY WARRANTY; without even the implied warranty of
65+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General
66+# Public License for more details.
67+#
68+# You should have received a copy of the GNU General Public License along
69+# with this program. If not, see <https://www.gnu.org/licenses/>.
70+#
71+# As a special exception, the respective Autoconf Macro's copyright owner
72+# gives unlimited permission to copy, distribute and modify the configure
73+# scripts that are the output of Autoconf when processing the Macro. You
74+# need not follow the terms of the GNU General Public License when using
75+# or distributing such scripts, even though portions of the text of the
76+# Macro appear in them. The GNU General Public License (GPL) does govern
77+# all other use of the material that constitutes the Autoconf Macro.
78+#
79+# This special exception to the GPL applies to versions of the Autoconf
80+# Macro released by the Autoconf Archive. When you make and distribute a
81+# modified version of the Autoconf Macro, you may extend this special
82+# exception to the GPL to apply to your modified version as well.
83+
84+#serial 5
85+
86+AC_DEFUN([AX_CHECK_COMPILE_FLAG],
87+[AC_PREREQ(2.64)dnl for _AC_LANG_PREFIX and AS_VAR_IF
88+AS_VAR_PUSHDEF([CACHEVAR],[ax_cv_check_[]_AC_LANG_ABBREV[]flags_$4_$1])dnl
89+AC_CACHE_CHECK([whether _AC_LANG compiler accepts $1], CACHEVAR, [
90+ ax_check_save_flags=$[]_AC_LANG_PREFIX[]FLAGS
91+ _AC_LANG_PREFIX[]FLAGS="$[]_AC_LANG_PREFIX[]FLAGS $4 $1"
92+ AC_COMPILE_IFELSE([m4_default([$5],[AC_LANG_PROGRAM()])],
93+ [AS_VAR_SET(CACHEVAR,[yes])],
94+ [AS_VAR_SET(CACHEVAR,[no])])
95+ _AC_LANG_PREFIX[]FLAGS=$ax_check_save_flags])
96+AS_VAR_IF(CACHEVAR,yes,
97+ [m4_default([$2], :)],
98+ [m4_default([$3], :)])
99+AS_VAR_POPDEF([CACHEVAR])dnl
100+])dnl AX_CHECK_COMPILE_FLAGS
101diff --git a/configure.ac b/configure.ac
102index 2543676..4635474 100644
103--- a/configure.ac
104+++ b/configure.ac
105@@ -28,6 +28,7 @@ m4_include([acinclude/pkg.m4])
106 m4_include([acinclude/tdb.m4])
107 m4_include([acinclude/lib-checks.m4])
108 m4_include([acinclude/ax_cxx_compile_stdcxx.m4])
109+m4_include([acinclude/ax_check_compile_flag.m4])
110
111 HOSTCXX="$BUILD_CXX"
112 PRESET_CFLAGS="$CFLAGS"
113@@ -59,6 +60,7 @@ AC_USE_SYSTEM_EXTENSIONS
114
115 AC_LANG([C++])
116
117+AX_CHECK_COMPILE_FLAG([-Werror=format-truncation],[CFLAGS="$CFLAGS -Wno-error=format-truncation" CXXFLAGS="$CXXFLAGS -Wno-error=format-truncation"])
118 # Clang 3.2 on some CPUs requires -march-native to detect correctly.
119 # GCC 4.3+ can also produce faster executables when its used.
120 # But building inside a virtual machine environment has been found to
diff --git a/meta-networking/recipes-daemons/squid/files/0002-squid-make-squid-conf-tests-run-on-target-device.patch b/meta-networking/recipes-daemons/squid/files/0002-squid-make-squid-conf-tests-run-on-target-device.patch
index 56c91de3c..ca1c16b83 100644
--- a/meta-networking/recipes-daemons/squid/files/0002-squid-make-squid-conf-tests-run-on-target-device.patch
+++ b/meta-networking/recipes-daemons/squid/files/0002-squid-make-squid-conf-tests-run-on-target-device.patch
@@ -17,8 +17,6 @@ Signed-off-by: Patrick Wicki <patrick.wicki@siemens.com>
17 test-suite/test-squid-conf.sh | 2 +- 17 test-suite/test-squid-conf.sh | 2 +-
18 2 files changed, 9 insertions(+), 9 deletions(-) 18 2 files changed, 9 insertions(+), 9 deletions(-)
19 19
20diff --git a/test-suite/Makefile.am b/test-suite/Makefile.am
21index 8becdbc..eccd49c 100644
22--- a/test-suite/Makefile.am 20--- a/test-suite/Makefile.am
23+++ b/test-suite/Makefile.am 21+++ b/test-suite/Makefile.am
24@@ -21,7 +21,7 @@ LDADD = \ 22@@ -21,7 +21,7 @@ LDADD = \
@@ -59,8 +57,6 @@ index 8becdbc..eccd49c 100644
59 57
60-CLEANFILES += squid-conf-tests squid-stderr.log 58-CLEANFILES += squid-conf-tests squid-stderr.log
61+CLEANFILES += squid-conf-tests /var/log/squid-stderr.log 59+CLEANFILES += squid-conf-tests /var/log/squid-stderr.log
62diff --git a/test-suite/test-squid-conf.sh b/test-suite/test-squid-conf.sh
63index 05fcaf3..a5a8a5a 100755
64--- a/test-suite/test-squid-conf.sh 60--- a/test-suite/test-squid-conf.sh
65+++ b/test-suite/test-squid-conf.sh 61+++ b/test-suite/test-squid-conf.sh
66@@ -111,7 +111,7 @@ then 62@@ -111,7 +111,7 @@ then
diff --git a/meta-networking/recipes-daemons/squid/files/Set-up-for-cross-compilation.patch b/meta-networking/recipes-daemons/squid/files/Set-up-for-cross-compilation.patch
index ae8706df7..18bc78e6b 100644
--- a/meta-networking/recipes-daemons/squid/files/Set-up-for-cross-compilation.patch
+++ b/meta-networking/recipes-daemons/squid/files/Set-up-for-cross-compilation.patch
@@ -16,8 +16,6 @@ Upstream-Status: Pending
16 configure.ac | 1 + 16 configure.ac | 1 +
17 1 file changed, 1 insertion(+) 17 1 file changed, 1 insertion(+)
18 18
19diff --git a/configure.ac b/configure.ac
20index ca0bc79..c222851 100644
21--- a/configure.ac 19--- a/configure.ac
22+++ b/configure.ac 20+++ b/configure.ac
23@@ -29,6 +29,7 @@ m4_include([acinclude/tdb.m4]) 21@@ -29,6 +29,7 @@ m4_include([acinclude/tdb.m4])
diff --git a/meta-networking/recipes-daemons/squid/files/Skip-AC_RUN_IFELSE-tests.patch b/meta-networking/recipes-daemons/squid/files/Skip-AC_RUN_IFELSE-tests.patch
index 5bb30bfcb..e0d002c68 100644
--- a/meta-networking/recipes-daemons/squid/files/Skip-AC_RUN_IFELSE-tests.patch
+++ b/meta-networking/recipes-daemons/squid/files/Skip-AC_RUN_IFELSE-tests.patch
@@ -16,8 +16,6 @@ Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
16 acinclude/lib-checks.m4 | 8 ++++++-- 16 acinclude/lib-checks.m4 | 8 ++++++--
17 2 files changed, 15 insertions(+), 3 deletions(-) 17 2 files changed, 15 insertions(+), 3 deletions(-)
18 18
19diff --git a/acinclude/krb5.m4 b/acinclude/krb5.m4
20index 2c4e340..64648e3 100644
21--- a/acinclude/krb5.m4 19--- a/acinclude/krb5.m4
22+++ b/acinclude/krb5.m4 20+++ b/acinclude/krb5.m4
23@@ -57,7 +57,15 @@ main(void) 21@@ -57,7 +57,15 @@ main(void)
@@ -37,11 +35,9 @@ index 2c4e340..64648e3 100644
37 ]) 35 ])
38 SQUID_STATE_ROLLBACK(squid_krb5_heimdal_test) 36 SQUID_STATE_ROLLBACK(squid_krb5_heimdal_test)
39 ]) 37 ])
40diff --git a/acinclude/lib-checks.m4 b/acinclude/lib-checks.m4
41index 53847a8..850322a 100644
42--- a/acinclude/lib-checks.m4 38--- a/acinclude/lib-checks.m4
43+++ b/acinclude/lib-checks.m4 39+++ b/acinclude/lib-checks.m4
44@@ -205,7 +205,9 @@ AC_DEFUN([SQUID_CHECK_OPENSSL_CONST_SSL_METHOD],[ 40@@ -205,7 +205,9 @@ AC_DEFUN([SQUID_CHECK_OPENSSL_CONST_SSL_
45 [ 41 [
46 AC_MSG_RESULT([no]) 42 AC_MSG_RESULT([no])
47 ], 43 ],
diff --git a/meta-networking/recipes-daemons/squid/files/squid-use-serial-tests-config-needed-by-ptest.patch b/meta-networking/recipes-daemons/squid/files/squid-use-serial-tests-config-needed-by-ptest.patch
index 732cf17f7..5df006038 100644
--- a/meta-networking/recipes-daemons/squid/files/squid-use-serial-tests-config-needed-by-ptest.patch
+++ b/meta-networking/recipes-daemons/squid/files/squid-use-serial-tests-config-needed-by-ptest.patch
@@ -14,8 +14,6 @@ Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
14 configure.ac | 2 +- 14 configure.ac | 2 +-
15 1 file changed, 1 insertion(+), 1 deletion(-) 15 1 file changed, 1 insertion(+), 1 deletion(-)
16 16
17diff --git a/configure.ac b/configure.ac
18index c7ae568..5e1454e 100644
19--- a/configure.ac 17--- a/configure.ac
20+++ b/configure.ac 18+++ b/configure.ac
21@@ -10,7 +10,7 @@ AC_PREREQ(2.61) 19@@ -10,7 +10,7 @@ AC_PREREQ(2.61)
diff --git a/meta-networking/recipes-daemons/squid/squid_6.7.bb b/meta-networking/recipes-daemons/squid/squid_6.8.bb
index a4932cd36..c8370eaba 100644
--- a/meta-networking/recipes-daemons/squid/squid_6.7.bb
+++ b/meta-networking/recipes-daemons/squid/squid_6.8.bb
@@ -12,20 +12,17 @@ LICENSE = "GPL-2.0-or-later"
12MAJ_VER = "${@oe.utils.trim_version("${PV}", 1)}" 12MAJ_VER = "${@oe.utils.trim_version("${PV}", 1)}"
13MIN_VER = "${@oe.utils.trim_version("${PV}", 2)}" 13MIN_VER = "${@oe.utils.trim_version("${PV}", 2)}"
14 14
15SRC_URI = "http://www.squid-cache.org/Versions/v${MAJ_VER}/${BPN}-${PV}.tar.bz2 \ 15SRC_URI = "http://www.squid-cache.org/Versions/v${MAJ_VER}/${BPN}-${PV}.tar.xz \
16 file://Set-up-for-cross-compilation.patch \ 16 file://Set-up-for-cross-compilation.patch \
17 file://Skip-AC_RUN_IFELSE-tests.patch \ 17 file://Skip-AC_RUN_IFELSE-tests.patch \
18 file://squid-use-serial-tests-config-needed-by-ptest.patch \ 18 file://squid-use-serial-tests-config-needed-by-ptest.patch \
19 file://run-ptest \ 19 file://run-ptest \
20 file://volatiles.03_squid \ 20 file://volatiles.03_squid \
21 file://0001-configure-Check-for-Wno-error-format-truncation-comp.patch \
22 file://0002-squid-make-squid-conf-tests-run-on-target-device.patch \ 21 file://0002-squid-make-squid-conf-tests-run-on-target-device.patch \
23 file://squid.nm \ 22 file://squid.nm \
24 " 23 "
25 24
26SRC_URI:remove:toolchain-clang = "file://0001-configure-Check-for-Wno-error-format-truncation-comp.patch" 25SRC_URI[sha256sum] = "11cc5650b51809d99483ccfae24744a2e51cd16199f5ff0c917e84fce695870f"
27
28SRC_URI[sha256sum] = "7a09a0232026824c300b72c42cc5c0c431cbb65498f41d5dea48ef447ab8037e"
29 26
30LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ 27LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
31 file://errors/COPYRIGHT;md5=d324bc1f9447d1d1588d75b22a678dc4 \ 28 file://errors/COPYRIGHT;md5=d324bc1f9447d1d1588d75b22a678dc4 \