summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2024-05-02 10:48:00 -0400
committerKhem Raj <raj.khem@gmail.com>2024-05-02 07:32:47 -0700
commita733b0c75c8111a79cd35a1e78651c78b9bbd2ef (patch)
tree02d77ffdd66ea5cb4a3a2f0e1a146973d2b6bf66 /meta-networking
parent3fd6f0feec002c85df23b37c04d745a43674ee66 (diff)
downloadmeta-openembedded-a733b0c75c8111a79cd35a1e78651c78b9bbd2ef.tar.gz
fping: upgrade 5.1 -> 5.2
0001-fping-Initialize-msghdr-struct-in-a-portable-way.patch removed since it's included in 5.2 Changelog: ============ -New option -X / --fast-reachable to exit immediately once N hosts have been found -New option -k / -fwmark to set Linux fwmark mask -Always output fatal error messages -Fallback to SO_TIMESTAMP if SO_TIMESTAMPNS is not available -Fix "not enough sequence numbers available" error on BSD-like systems -Fix running in unprivileged mode -Fix build issue for NetBSD/alpha -Fix build issue for OpenBSD/alpha -Fix build warning for long int usage -Fix build error with musl libc -Fix to guard against division by zero -Decouple -a/-u effects from -c -Added contrib/Dockerfile -Remove host from Netdata chart titles -Add additional tests -Update github action os images -Fix Azure pipeline tests -Various autoconf fixes -Extended configure script with --enable-debug and output cpu usage -Documentation: Update Netdata website link -Documentation: fix description of --file option -Documentation: improve exit status description -Documentation: move description of -i MSEC -Documentation: improve help output for options -c and -C Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-support/fping/fping/0001-fping-Initialize-msghdr-struct-in-a-portable-way.patch42
-rw-r--r--meta-networking/recipes-support/fping/fping_5.2.bb (renamed from meta-networking/recipes-support/fping/fping_5.1.bb)6
2 files changed, 2 insertions, 46 deletions
diff --git a/meta-networking/recipes-support/fping/fping/0001-fping-Initialize-msghdr-struct-in-a-portable-way.patch b/meta-networking/recipes-support/fping/fping/0001-fping-Initialize-msghdr-struct-in-a-portable-way.patch
deleted file mode 100644
index 9965d2ec5..000000000
--- a/meta-networking/recipes-support/fping/fping/0001-fping-Initialize-msghdr-struct-in-a-portable-way.patch
+++ /dev/null
@@ -1,42 +0,0 @@
1From c3f476a763412be51b4df0e748af04d4150a2c71 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 29 Aug 2022 15:41:51 -0700
4Subject: [PATCH] fping: Initialize msghdr struct in a portable way
5
6Initializing the structure assuming glibc layout results in
7compile errors on musl, therefore do partial intialization and then
8assigning the members individually.
9
10Upstream-Status: Submitted [https://github.com/schweikert/fping/pull/263]
11Signed-off-by: Khem Raj <raj.khem@gmail.com>
12---
13 src/fping.c | 16 +++++++---------
14 1 file changed, 7 insertions(+), 9 deletions(-)
15
16diff --git a/src/fping.c b/src/fping.c
17index e26b216..81a61d9 100644
18--- a/src/fping.c
19+++ b/src/fping.c
20@@ -1951,15 +1951,13 @@ int receive_packet(int64_t wait_time,
21 reply_buf,
22 reply_buf_len
23 };
24- struct msghdr recv_msghdr = {
25- reply_src_addr,
26- reply_src_addr_len,
27- &msg_iov,
28- 1,
29- &msg_control,
30- sizeof(msg_control),
31- 0
32- };
33+ struct msghdr recv_msghdr = {0};
34+ recv_msghdr.msg_name = reply_src_addr;
35+ recv_msghdr.msg_namelen = reply_src_addr_len;
36+ recv_msghdr.msg_iov = &msg_iov;
37+ recv_msghdr.msg_iovlen = 1;
38+ recv_msghdr.msg_control = &msg_control;
39+ recv_msghdr.msg_controllen = sizeof(msg_control);
40 #if HAVE_SO_TIMESTAMPNS
41 struct cmsghdr* cmsg;
42 #endif
diff --git a/meta-networking/recipes-support/fping/fping_5.1.bb b/meta-networking/recipes-support/fping/fping_5.2.bb
index 0682eafa0..f75b6441b 100644
--- a/meta-networking/recipes-support/fping/fping_5.1.bb
+++ b/meta-networking/recipes-support/fping/fping_5.2.bb
@@ -14,10 +14,8 @@ LICENSE = "fping"
14NO_GENERIC_LICENSE[fping] = "COPYING" 14NO_GENERIC_LICENSE[fping] = "COPYING"
15LIC_FILES_CHKSUM = "file://COPYING;md5=c6170fbadddfcd74f011515291d96901" 15LIC_FILES_CHKSUM = "file://COPYING;md5=c6170fbadddfcd74f011515291d96901"
16 16
17SRC_URI = "http://www.fping.org/dist/fping-${PV}.tar.gz \ 17SRC_URI = "http://www.fping.org/dist/fping-${PV}.tar.gz"
18 file://0001-fping-Initialize-msghdr-struct-in-a-portable-way.patch \ 18SRC_URI[sha256sum] = "a7692d10d73fb0bb76e1f7459aa7f19bbcdbfc5adbedef02f468974b18b0e42f"
19 "
20SRC_URI[sha256sum] = "1ee5268c063d76646af2b4426052e7d81a42b657e6a77d8e7d3d2e60fd7409fe"
21 19
22S = "${WORKDIR}/fping-${PV}" 20S = "${WORKDIR}/fping-${PV}"
23 21