diff options
author | Hongxu Jia <hongxu.jia@windriver.com> | 2014-03-18 16:21:06 +0800 |
---|---|---|
committer | Joe MacDonald <joe.macdonald@windriver.com> | 2014-03-27 15:41:13 -0400 |
commit | a600fe808a71ad569697eb4921b3d101f1c032d7 (patch) | |
tree | 7b53bd0cd41e9b936c043ce274566a1654170e3a /meta-networking | |
parent | d9f21ab787c8eef2cfdc1f5408f973ebbcc196e2 (diff) | |
download | meta-openembedded-a600fe808a71ad569697eb4921b3d101f1c032d7.tar.gz |
netcf: fix gnulib not found in sysroots while using a shared sstate cache
...
./bootstrap: Bootstrapping from checked-out netcf sources...
./bootstrap: consider installing git-merge-changelog from gnulib
./bootstrap: line 641:
tmp/sysroots/qemux86/usr/share/gnulib/gnulib-tool: No such file or
directory
...
The gnulib source was incorrectly populated to ${STAGING_DATADIR}.
While the build shared an existed sstate cache, the gnulib's
${SYSROOT_DESTDIR} was empty, the gnulib source code was not
found in sysroots.
We should use do_install task to install them to ${D}, and the
default do_populate_sysroot task will populate them to
${STAGING_DATADIR}.
Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
Signed-off-by: Joe MacDonald <joe.macdonald@windriver.com>
Diffstat (limited to 'meta-networking')
-rw-r--r-- | meta-networking/recipes-support/netcf/gnulib_git.bb | 7 |
1 files changed, 2 insertions, 5 deletions
diff --git a/meta-networking/recipes-support/netcf/gnulib_git.bb b/meta-networking/recipes-support/netcf/gnulib_git.bb index 730f5cd78..1da6c83ed 100644 --- a/meta-networking/recipes-support/netcf/gnulib_git.bb +++ b/meta-networking/recipes-support/netcf/gnulib_git.bb | |||
@@ -16,18 +16,15 @@ SRC_URI = "git://git.sv.gnu.org/gnulib;protocol=git \ | |||
16 | " | 16 | " |
17 | S = "${WORKDIR}/git" | 17 | S = "${WORKDIR}/git" |
18 | 18 | ||
19 | # Git clone a copy of gnulib source to the staging data dir | 19 | do_install () { |
20 | sysroot_stage_all () { | ||
21 | [ -d ${STAGING_DATADIR}/gnulib/ ] && rm -rf ${STAGING_DATADIR}/gnulib/ | ||
22 | cd ${S} | 20 | cd ${S} |
23 | git checkout master | 21 | git checkout master |
24 | git clone ${S} ${STAGING_DATADIR}/gnulib | 22 | git clone ${S} ${D}/${datadir}/gnulib |
25 | } | 23 | } |
26 | 24 | ||
27 | do_patch[noexec] = "1" | 25 | do_patch[noexec] = "1" |
28 | do_configure[noexec] = "1" | 26 | do_configure[noexec] = "1" |
29 | do_compile[noexec] = "1" | 27 | do_compile[noexec] = "1" |
30 | do_install[noexec] = "1" | ||
31 | do_package[noexec] = "1" | 28 | do_package[noexec] = "1" |
32 | do_packagedata[noexec] = "1" | 29 | do_packagedata[noexec] = "1" |
33 | do_package_write_ipk[noexec] = "1" | 30 | do_package_write_ipk[noexec] = "1" |