diff options
author | Dmitry Baryshkov <dmitry.baryshkov@linaro.org> | 2024-06-05 10:52:27 +0300 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-06-06 21:45:26 -0700 |
commit | 95fbda562580781c740de786b538070efd079ae7 (patch) | |
tree | 96130c04c3fa26044065f1ce59328d77cc9c32cc /meta-networking | |
parent | 6a8650ac4b22e69853066e474596c2a1cf40bd25 (diff) | |
download | meta-openembedded-95fbda562580781c740de786b538070efd079ae7.tar.gz |
ntopng: fix building with GCC 14
GCC 14 is more strict regarding const pointers conversion. Fix
conversion to let ntpong build with GCC 14 and updated rrdtool. The
patch is not submitted upstream yet, the project requires singing of
CLA.
Signed-off-by: Dmitry Baryshkov <dmitry.baryshkov@linaro.org>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r-- | meta-networking/recipes-support/ntopng/files/0001-Follow-rrd-post-1.8-change.patch | 32 | ||||
-rw-r--r-- | meta-networking/recipes-support/ntopng/ntopng_5.2.1.bb | 1 |
2 files changed, 33 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/ntopng/files/0001-Follow-rrd-post-1.8-change.patch b/meta-networking/recipes-support/ntopng/files/0001-Follow-rrd-post-1.8-change.patch new file mode 100644 index 000000000..eefd4e1ab --- /dev/null +++ b/meta-networking/recipes-support/ntopng/files/0001-Follow-rrd-post-1.8-change.patch | |||
@@ -0,0 +1,32 @@ | |||
1 | From a3bd9efe78f9c381f19b99c8ceb7f52b4c2a52b8 Mon Sep 17 00:00:00 2001 | ||
2 | From: Dmitry Baryshkov <dmitry.baryshkov@linaro.org> | ||
3 | Date: Wed, 5 Jun 2024 09:40:17 +0300 | ||
4 | Subject: [PATCH] Follow rrd post-1.8 change | ||
5 | |||
6 | Git version of rrdtool has changed rrd_tune argument from char pointer | ||
7 | to const char pointer. GCC 14 is more strict regarding the pointer | ||
8 | constantness checks and errors out in such a case. Update rrd_tune | ||
9 | invokation. | ||
10 | |||
11 | Signed-off-by: Dmitry Baryshkov <dmitry.baryshkov@linaro.org> | ||
12 | Upstream-Status: Pending [CLA is not signed on our side] | ||
13 | --- | ||
14 | src/LuaEngineNtop.cpp | 2 +- | ||
15 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
16 | |||
17 | diff --git a/src/LuaEngineNtop.cpp b/src/LuaEngineNtop.cpp | ||
18 | index bd2de79e3021..dd00f1608f78 100644 | ||
19 | --- a/src/LuaEngineNtop.cpp | ||
20 | +++ b/src/LuaEngineNtop.cpp | ||
21 | @@ -5427,7 +5427,7 @@ static int ntop_rrd_tune(lua_State* vm) { | ||
22 | filename = argv[1]; | ||
23 | |||
24 | reset_rrd_state(); | ||
25 | - status = rrd_tune(argc, (char**)argv); | ||
26 | + status = rrd_tune(argc, (const char**)argv); | ||
27 | |||
28 | if(status != 0) { | ||
29 | char *err = rrd_get_error(); | ||
30 | -- | ||
31 | 2.39.2 | ||
32 | |||
diff --git a/meta-networking/recipes-support/ntopng/ntopng_5.2.1.bb b/meta-networking/recipes-support/ntopng/ntopng_5.2.1.bb index a9ace9b41..9bb93910f 100644 --- a/meta-networking/recipes-support/ntopng/ntopng_5.2.1.bb +++ b/meta-networking/recipes-support/ntopng/ntopng_5.2.1.bb | |||
@@ -19,6 +19,7 @@ SRC_URI = "git://github.com/ntop/ntopng.git;protocol=https;branch=5.2-stable \ | |||
19 | file://0001-autogen.sh-generate-configure.ac-only.patch \ | 19 | file://0001-autogen.sh-generate-configure.ac-only.patch \ |
20 | file://0001-configure.ac.in-not-check-clang-on-host.patch \ | 20 | file://0001-configure.ac.in-not-check-clang-on-host.patch \ |
21 | file://0001-configure.ac.in-Allow-dynamic-linking-against-ndpi-3.patch \ | 21 | file://0001-configure.ac.in-Allow-dynamic-linking-against-ndpi-3.patch \ |
22 | file://0001-Follow-rrd-post-1.8-change.patch \ | ||
22 | file://ntopng.service \ | 23 | file://ntopng.service \ |
23 | " | 24 | " |
24 | 25 | ||