summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2021-07-06 11:13:19 +0200
committerKhem Raj <raj.khem@gmail.com>2021-07-08 09:21:40 -0700
commit9569d222eb8ded7a8a5d9ed279b92605c46cd111 (patch)
treee7b4df2f4b25ba961d65edd198f64e1a3692a39f /meta-networking
parent287ffdf1d03731fadd6a90b224d08cf9a3b50de5 (diff)
downloadmeta-openembedded-9569d222eb8ded7a8a5d9ed279b92605c46cd111.tar.gz
blueman: upgrade 2.1.4 -> 2.2.1
Manually refresh 0002-fix-fail-to-enable-bluetooth.patch - it did not apply 2.2.1 Bugs fixed Hard dependency of DBusService on NetworkManager 2.2 New features Disconnect items in applet menu (plugin) Desktop notifications on connect / disconnect (plugin) Notifications with battery level for connecting devices (applet plugin) Stop discovery and retry connection for broken adapter drivers Auto-connect settings for supported services Changes Drop blueman-report Drop blueman-assistant Raise minimum Python version to 3.6 Raise GTK+ 3 version to 3.22 Raise minimum BlueZ version to 5.48 Allow opening device menus via keyboard (Shift+F10 or menu key) Add Ctrl+Q and Ctrl+W accelerators for closing blueman-manager Allow cancelling device connection attempts Improved passkey handling (fixed padding, highlighting, single notifitication) Hide devices with no name Bugs fixed Fix disconnecting NMDevice Exceptions from asynchronous DBus calls (getting picked up by tools like Apport or ABRT) DiscvManager plugin showed its icon unreliably Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-connectivity/blueman/blueman/0002-fix-fail-to-enable-bluetooth.patch20
-rw-r--r--meta-networking/recipes-connectivity/blueman/blueman_2.2.1.bb (renamed from meta-networking/recipes-connectivity/blueman/blueman_2.1.4.bb)16
2 files changed, 17 insertions, 19 deletions
diff --git a/meta-networking/recipes-connectivity/blueman/blueman/0002-fix-fail-to-enable-bluetooth.patch b/meta-networking/recipes-connectivity/blueman/blueman/0002-fix-fail-to-enable-bluetooth.patch
index 55d1ac94c..282d82137 100644
--- a/meta-networking/recipes-connectivity/blueman/blueman/0002-fix-fail-to-enable-bluetooth.patch
+++ b/meta-networking/recipes-connectivity/blueman/blueman/0002-fix-fail-to-enable-bluetooth.patch
@@ -22,13 +22,13 @@ Signed-off-by: Kai Kang <kai.kang@windriver.com>
22--- 22---
23 blueman/Functions.py | 10 ++++++++++ 23 blueman/Functions.py | 10 ++++++++++
24 blueman/plugins/applet/PowerManager.py | 4 ++++ 24 blueman/plugins/applet/PowerManager.py | 4 ++++
25 2 files changed, 15 insertions(+), 1 deletion(-) 25 2 files changed, 14 insertions(+)
26 26
27diff --git a/blueman/Functions.py b/blueman/Functions.py 27diff --git a/blueman/Functions.py b/blueman/Functions.py
28index 3b76271..c5eeb27 100644 28index 3917f42..b4d5eae 100644
29--- a/blueman/Functions.py 29--- a/blueman/Functions.py
30+++ b/blueman/Functions.py 30+++ b/blueman/Functions.py
31@@ -86,6 +86,16 @@ def check_bluetooth_status(message, exitfunc): 31@@ -80,6 +80,16 @@ def check_bluetooth_status(message: str, exitfunc: Callable[[], Any]) -> None:
32 return 32 return
33 33
34 applet.SetBluetoothStatus('(b)', True) 34 applet.SetBluetoothStatus('(b)', True)
@@ -46,27 +46,27 @@ index 3b76271..c5eeb27 100644
46 print('Failed to enable bluetooth') 46 print('Failed to enable bluetooth')
47 exitfunc() 47 exitfunc()
48diff --git a/blueman/plugins/applet/PowerManager.py b/blueman/plugins/applet/PowerManager.py 48diff --git a/blueman/plugins/applet/PowerManager.py b/blueman/plugins/applet/PowerManager.py
49index 8ec9fc4..29a0fb0 100644 49index c2f7bc3..bf6c99f 100644
50--- a/blueman/plugins/applet/PowerManager.py 50--- a/blueman/plugins/applet/PowerManager.py
51+++ b/blueman/plugins/applet/PowerManager.py 51+++ b/blueman/plugins/applet/PowerManager.py
52@@ -48,6 +48,7 @@ class PowerManager(AppletPlugin): 52@@ -63,6 +63,7 @@ class PowerManager(AppletPlugin, StatusIconProvider):
53 self._add_dbus_signal("BluetoothStatusChanged", "b") 53 self._add_dbus_signal("BluetoothStatusChanged", "b")
54 self._add_dbus_method("SetBluetoothStatus", ("b",), "", self.request_power_state) 54 self._add_dbus_method("SetBluetoothStatus", ("b",), "", self.request_power_state)
55 self._add_dbus_method("GetBluetoothStatus", (), "b", self.get_bluetooth_status) 55 self._add_dbus_method("GetBluetoothStatus", (), "b", self.get_bluetooth_status)
56+ self._add_dbus_method("GetRequestStatus", (), "b", self.get_request_status) 56+ self._add_dbus_method("GetRequestStatus", (), "b", self.get_request_status)
57 57
58 def on_unload(self): 58 def on_unload(self) -> None:
59 self.parent.Plugins.Menu.unregister(self) 59 self.parent.Plugins.Menu.unregister(self)
60@@ -182,6 +183,9 @@ class PowerManager(AppletPlugin): 60@@ -196,6 +197,9 @@ class PowerManager(AppletPlugin, StatusIconProvider):
61 def get_bluetooth_status(self): 61 def get_bluetooth_status(self) -> bool:
62 return self.current_state 62 return self.current_state
63 63
64+ def get_request_status(self): 64+ def get_request_status(self):
65+ return self.request_in_progress 65+ return self.request_in_progress
66+ 66+
67 def on_adapter_property_changed(self, _path, key, value): 67 def on_adapter_property_changed(self, _path: str, key: str, value: Any) -> None:
68 if key == "Powered": 68 if key == "Powered":
69 if value and not self.current_state: 69 if value and not self.current_state:
70-- 70--
712.20.1 712.31.1
72 72
diff --git a/meta-networking/recipes-connectivity/blueman/blueman_2.1.4.bb b/meta-networking/recipes-connectivity/blueman/blueman_2.2.1.bb
index 29bef230e..3cb01ff71 100644
--- a/meta-networking/recipes-connectivity/blueman/blueman_2.1.4.bb
+++ b/meta-networking/recipes-connectivity/blueman/blueman_2.2.1.bb
@@ -4,14 +4,14 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
4 4
5DEPENDS = "bluez5 python3-pygobject python3-cython-native python3-setuptools-native intltool-native" 5DEPENDS = "bluez5 python3-pygobject python3-cython-native python3-setuptools-native intltool-native"
6 6
7inherit autotools systemd gsettings python3native gtk-icon-cache 7inherit autotools gettext systemd gsettings python3native gtk-icon-cache
8 8
9SRC_URI = " \ 9SRC_URI = " \
10 https://github.com/blueman-project/blueman/releases/download/${PV}/blueman-${PV}.tar.xz \ 10 https://github.com/blueman-project/blueman/releases/download/${PV}/blueman-${PV}.tar.xz \
11 file://0001-Search-for-cython3.patch \ 11 file://0001-Search-for-cython3.patch \
12 file://0002-fix-fail-to-enable-bluetooth.patch \ 12 file://0002-fix-fail-to-enable-bluetooth.patch \
13" 13"
14SRC_URI[sha256sum] = "1d9c3d39a564d88851aa8de509f16bfa586b0b50f4307dc6c6347ba4833664da" 14SRC_URI[sha256sum] = "fcc10a2259bef2c5ac63f577010d76caed460d68810b7f70fecf056bf10a1a72"
15 15
16EXTRA_OECONF = " \ 16EXTRA_OECONF = " \
17 --disable-appindicator \ 17 --disable-appindicator \
@@ -48,12 +48,10 @@ FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/_blueman.a"
48do_install_append() { 48do_install_append() {
49 sed -i "1s/.*/#!\/usr\/bin\/env python3/" ${D}${prefix}/libexec/blueman-rfcomm-watcher \ 49 sed -i "1s/.*/#!\/usr\/bin\/env python3/" ${D}${prefix}/libexec/blueman-rfcomm-watcher \
50 ${D}${prefix}/libexec/blueman-mechanism \ 50 ${D}${prefix}/libexec/blueman-mechanism \
51 ${D}${bindir}/blueman-tray \ 51 ${D}${bindir}/blueman-adapters \
52 ${D}${bindir}/blueman-services \
53 ${D}${bindir}/blueman-sendto \
54 ${D}${bindir}/blueman-report \
55 ${D}${bindir}/blueman-manager \
56 ${D}${bindir}/blueman-assistant \
57 ${D}${bindir}/blueman-applet \ 52 ${D}${bindir}/blueman-applet \
58 ${D}${bindir}/blueman-adapters 53 ${D}${bindir}/blueman-manager \
54 ${D}${bindir}/blueman-sendto \
55 ${D}${bindir}/blueman-services \
56 ${D}${bindir}/blueman-tray
59} 57}