summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorEnguerrand de Ribaucourt <enguerrand.de-ribaucourt@savoirfairelinux.com>2024-06-05 13:27:26 +0200
committerKhem Raj <raj.khem@gmail.com>2024-06-10 23:08:41 -0700
commit8b013028356b80dc39fd687f9aa995f9ca9ee55e (patch)
tree4fdaf38e1e269a4b05f3f22c262190dd66075fb7 /meta-networking
parentf22451b51bf668fbbf27b50744786c64316ef700 (diff)
downloadmeta-openembedded-8b013028356b80dc39fd687f9aa995f9ca9ee55e.tar.gz
udpcast: add recipe
udpcast is a file transfer tool that can send data simultaneously to many destinations on a LAN. It is an alternative to uftp which is already in meta-networking. On a lossy network, udpcast provided 10x faster transfer rates with error correction enabled while using a half as much CPU thanks to a simpler algorithm. Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-core/packagegroups/packagegroup-meta-networking.bb1
-rw-r--r--meta-networking/recipes-support/udpcast/udpcast/0001-include-stddef.h-for-ptrdiff_t.patch27
-rw-r--r--meta-networking/recipes-support/udpcast/udpcast_20230924.bb22
3 files changed, 50 insertions, 0 deletions
diff --git a/meta-networking/recipes-core/packagegroups/packagegroup-meta-networking.bb b/meta-networking/recipes-core/packagegroups/packagegroup-meta-networking.bb
index 2e3aa5441..1fa95dcc8 100644
--- a/meta-networking/recipes-core/packagegroups/packagegroup-meta-networking.bb
+++ b/meta-networking/recipes-core/packagegroups/packagegroup-meta-networking.bb
@@ -236,6 +236,7 @@ RDEPENDS:packagegroup-meta-networking-support = "\
236 rdma-core \ 236 rdma-core \
237 tcpreplay \ 237 tcpreplay \
238 tinyproxy \ 238 tinyproxy \
239 udpcast \
239 uftp \ 240 uftp \
240 unbound \ 241 unbound \
241 vnstat \ 242 vnstat \
diff --git a/meta-networking/recipes-support/udpcast/udpcast/0001-include-stddef.h-for-ptrdiff_t.patch b/meta-networking/recipes-support/udpcast/udpcast/0001-include-stddef.h-for-ptrdiff_t.patch
new file mode 100644
index 000000000..e3d65db73
--- /dev/null
+++ b/meta-networking/recipes-support/udpcast/udpcast/0001-include-stddef.h-for-ptrdiff_t.patch
@@ -0,0 +1,27 @@
1From 5203821a936b1927c401034fe323686ad9eafb04 Mon Sep 17 00:00:00 2001
2From: Enguerrand de Ribaucourt <enguerrand.de-ribaucourt@savoirfairelinux.com>
3Date: Thu, 6 Jun 2024 15:57:12 +0200
4Subject: [PATCH 1/1] include stddef.h for ptrdiff_t
5
6This fixes compilation with musl.
7
8Upstream-Status: Pending
9
10Signed-off-by: Enguerrand de Ribaucourt <enguerrand.de-ribaucourt@savoirfairelinux.com>
11---
12 receivedata.c | 1 +
13 1 file changed, 1 insertion(+)
14
15diff --git a/receivedata.c b/receivedata.c
16index 9a68f67..0aa797f 100644
17--- a/receivedata.c
18+++ b/receivedata.c
19@@ -1,4 +1,5 @@
20 #include <assert.h>
21+#include <stddef.h>
22 #include <sys/types.h>
23 #include <unistd.h>
24 #include <stdlib.h>
25--
262.34.1
27
diff --git a/meta-networking/recipes-support/udpcast/udpcast_20230924.bb b/meta-networking/recipes-support/udpcast/udpcast_20230924.bb
new file mode 100644
index 000000000..f93f9850a
--- /dev/null
+++ b/meta-networking/recipes-support/udpcast/udpcast_20230924.bb
@@ -0,0 +1,22 @@
1SUMMARY = "UDP broadcast file distribution and installation"
2DESCRIPTION = "UDPcast is a file transfer tool that can send data \
3simultaneously to many destinations on a LAN. This can for instance be \
4used to install entire classrooms of PC's at once. The advantage of UDPcast \
5over using other methods (nfs, ftp, whatever) is that UDPcast uses UDP's \
6multicast abilities: it won't take longer to install 15 machines than it would \
7to install just 2."
8HOMEPAGE = "http://www.udpcast.linux.lu/"
9SECTION = "console/network"
10LICENSE = "GPL-2.0-or-later & BSD-2-Clause"
11LIC_FILES_CHKSUM = "file://COPYING;md5=e3cf524a29c8476be354bb329d36ff80"
12
13SRC_URI = "http://www.udpcast.linux.lu/download/${BP}.tar.gz \
14 file://0001-include-stddef.h-for-ptrdiff_t.patch \
15 "
16SRC_URI[sha256sum] = "17b5cd8b1e54f7e2e53357ac02ee86e4198bf704096987a03a3b5c402a0ecea1"
17
18# Installation of rateGovernor.h fails without brokensep
19inherit autotools-brokensep manpages
20
21# pod2man required to build manpages
22DEPENDS += "perl-native"