summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2024-02-24 09:42:39 +0100
committerKhem Raj <raj.khem@gmail.com>2024-02-26 08:13:22 -0800
commit7e420c584ffae8f6430094106d6003954c955435 (patch)
tree835e54b9d780d634046bd42fe09b2dccad992bd2 /meta-networking
parentd731e6a370e6d6126761e5e1e89def607fb97e11 (diff)
downloadmeta-openembedded-7e420c584ffae8f6430094106d6003954c955435.tar.gz
snort3: fix snort.pc
* fixes: ERROR: lib32-snort3-3+git-r0 do_populate_sysroot: QA Issue: snort.pc failed sanity test (tmpdir) in path lib32-snort3/3+git/sysroot-destdir/usr/lib/pkg * it's broken for non-multilib builds as well, the issue is that FLEX_CPPFLAGS points to native include dir, e.g. FLEX_CPPFLAGS=-I/OE/../lib32-snort3/3+git/recipe-sysroot-native/usr/include and the work around from: https://github.com/openembedded/meta-openembedded/commit/973647848049abda6f2adbee0189720109863731 sed -i "s#${RECIPE_SYSROOT}##g" ${D}${libdir}/pkgconfig/snort.pc strips the "/OE/../lib32-snort3/3+git/recipe-sysroot" part in non-multilib case, but leaves: FLEX_CPPFLAGS=-I-native/usr/include which is still wrong, but not detected by buildpaths QA check anymore and in multilib case, this didn't strip the first part because the target sysroot is: "/OE/../lib32-snort3/3+git/lib32-recipe-sysroot" so it didn't strip anything from native sysroot: "/OE/../lib32-snort3/3+git/recipe-sysroot-native" Signed-off-by: Martin Jansa <martin.jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-connectivity/snort/snort3_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-networking/recipes-connectivity/snort/snort3_git.bb b/meta-networking/recipes-connectivity/snort/snort3_git.bb
index e9c37c834..b8826b068 100644
--- a/meta-networking/recipes-connectivity/snort/snort3_git.bb
+++ b/meta-networking/recipes-connectivity/snort/snort3_git.bb
@@ -21,7 +21,7 @@ PACKAGES =+ "${PN}-scripts"
21inherit cmake pkgconfig 21inherit cmake pkgconfig
22 22
23do_install:append() { 23do_install:append() {
24 sed -i "s#${RECIPE_SYSROOT}##g" ${D}${libdir}/pkgconfig/snort.pc 24 sed -i "s#${RECIPE_SYSROOT_NATIVE}##g; s#${RECIPE_SYSROOT}##g" ${D}${libdir}/pkgconfig/snort.pc
25} 25}
26 26
27FILES:${PN} += "${libdir}/snort/daq/*.so" 27FILES:${PN} += "${libdir}/snort/daq/*.so"