summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@cn.fujitsu.com>2020-03-17 00:19:55 -0700
committerKhem Raj <raj.khem@gmail.com>2020-03-17 19:46:35 -0700
commit71245876085477834f0dc7ba9c993e7a5961fb25 (patch)
treead589bb1d77703afbb144f77608b52ffcc49ed04 /meta-networking
parent7f8f1ac31c34d23a03cc1b29b0bbcf309a767491 (diff)
downloadmeta-openembedded-71245876085477834f0dc7ba9c993e7a5961fb25.tar.gz
arptables: upgrade 0.0.4 -> 0.0.5
arptables-init-busybox.patch arptables-remove-bashism.patch removed since they are not available in 0.0.5 refresh 0001-Use-ARPCFLAGS-for-package-specific-compiler-flags.patch Signed-off-by: Wang Mingyu <wangmy@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-support/arptables/arptables/0001-Use-ARPCFLAGS-for-package-specific-compiler-flags.patch42
-rw-r--r--meta-networking/recipes-support/arptables/arptables/arptables-init-busybox.patch77
-rw-r--r--meta-networking/recipes-support/arptables/arptables/arptables-remove-bashism.patch37
-rw-r--r--meta-networking/recipes-support/arptables/arptables_git.bb6
4 files changed, 14 insertions, 148 deletions
diff --git a/meta-networking/recipes-support/arptables/arptables/0001-Use-ARPCFLAGS-for-package-specific-compiler-flags.patch b/meta-networking/recipes-support/arptables/arptables/0001-Use-ARPCFLAGS-for-package-specific-compiler-flags.patch
index e8be45e6b..eb58389c3 100644
--- a/meta-networking/recipes-support/arptables/arptables/0001-Use-ARPCFLAGS-for-package-specific-compiler-flags.patch
+++ b/meta-networking/recipes-support/arptables/arptables/0001-Use-ARPCFLAGS-for-package-specific-compiler-flags.patch
@@ -8,24 +8,17 @@ which OE uses to pass tweaks
8 8
9Signed-off-by: Khem Raj <raj.khem@gmail.com> 9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10--- 10---
11 Makefile | 15 +++++++-------- 11 Makefile | 10 ++++------
12 extensions/Makefile | 5 ++++- 12 extensions/Makefile | 4 ++++
13 2 files changed, 11 insertions(+), 9 deletions(-) 13 2 files changed, 8 insertions(+), 6 deletions(-)
14 14
15diff --git a/Makefile b/Makefile 15diff --git a/Makefile b/Makefile
16index 7bead0d..336db6b 100644 16index 62ebdf2..cd06813 100644
17--- a/Makefile 17--- a/Makefile
18+++ b/Makefile 18+++ b/Makefile
19@@ -7,15 +7,13 @@ LIBDIR:=$(PREFIX)/lib 19@@ -12,9 +12,7 @@ DESTDIR:=
20 BINDIR:=$(PREFIX)/sbin
21 MANDIR:=$(PREFIX)/man
22 man8dir=$(MANDIR)/man8
23-INITDIR:=/etc/rc.d/init.d
24+INITDIR:=/etc/init.d
25 SYSCONFIGDIR:=/etc/sysconfig
26 DESTDIR:=
27 20
28 MANS = arptables.8 arptables-save.8 arptables-restore.8 21 MANS = arptables-legacy.8 arptables-save.8 arptables-restore.8
29 22
30-COPT_FLAGS:=-O2 23-COPT_FLAGS:=-O2
31-CFLAGS:=$(COPT_FLAGS) -Wall -Wunused -I$(KERNEL_DIR)/include/ -Iinclude/ -DARPTABLES_VERSION=\"$(ARPTABLES_VERSION)\" #-g -DDEBUG #-pg # -DARPTC_DEBUG 24-CFLAGS:=$(COPT_FLAGS) -Wall -Wunused -I$(KERNEL_DIR)/include/ -Iinclude/ -DARPTABLES_VERSION=\"$(ARPTABLES_VERSION)\" #-g -DDEBUG #-pg # -DARPTC_DEBUG
@@ -34,8 +27,8 @@ index 7bead0d..336db6b 100644
34 ifndef ARPT_LIBDIR 27 ifndef ARPT_LIBDIR
35 ARPT_LIBDIR:=$(LIBDIR)/arptables 28 ARPT_LIBDIR:=$(LIBDIR)/arptables
36 endif 29 endif
37@@ -25,13 +23,13 @@ include extensions/Makefile 30@@ -24,13 +22,13 @@ include extensions/Makefile
38 all: arptables libarptc/libarptc.a 31 all: arptables-legacy libarptc/libarptc.a
39 32
40 arptables.o: arptables.c 33 arptables.o: arptables.c
41- $(CC) $(CFLAGS) -c -o $@ $< 34- $(CC) $(CFLAGS) -c -o $@ $<
@@ -51,29 +44,18 @@ index 7bead0d..336db6b 100644
51 44
52 libarptc/libarptc.a: libarptc/libarptc.o 45 libarptc/libarptc.a: libarptc/libarptc.o
53 $(AR) rcs $@ $< 46 $(AR) rcs $@ $<
54@@ -53,7 +51,8 @@ scripts: arptables-save arptables-restore arptables.sysv
55 install -m 0755 arptables-restore_ $(DESTDIR)$(BINDIR)/arptables-restore
56 cat arptables.sysv | sed 's/__EXEC_PATH__/$(tmp1)/g' | sed 's/__SYSCONFIG__/$(tmp2)/g' > arptables.sysv_
57 if [ "$(DESTDIR)" != "" ]; then mkdir -p $(DESTDIR)$(INITDIR); fi
58- if test -d $(DESTDIR)$(INITDIR); then install -m 0755 arptables.sysv_ $(DESTDIR)$(INITDIR)/arptables; fi
59+ install -d $(DESTDIR)$(INITDIR)
60+ install -m 0755 arptables.sysv_ $(DESTDIR)$(INITDIR)/arptables
61 rm -f arptables-save_ arptables-restore_ arptables.sysv_
62
63 .PHONY: install-man
64diff --git a/extensions/Makefile b/extensions/Makefile 47diff --git a/extensions/Makefile b/extensions/Makefile
65index 0189cc9..b046425 100644 48index 0189cc9..e8af782 100644
66--- a/extensions/Makefile 49--- a/extensions/Makefile
67+++ b/extensions/Makefile 50+++ b/extensions/Makefile
68@@ -4,4 +4,7 @@ EXT_FUNC+=standard mangle CLASSIFY MARK 51@@ -5,3 +5,7 @@ EXT_OBJS+=$(foreach T,$(EXT_FUNC), extensions/arpt_$(T).o)
69 EXT_OBJS+=$(foreach T,$(EXT_FUNC), extensions/arpt_$(T).o)
70 52
71 extensions/ebt_%.o: extensions/arpt_%.c include/arptables.h include/arptables_common.h 53 extensions/ebt_%.o: extensions/arpt_%.c include/arptables.h include/arptables_common.h
72- $(CC) $(CFLAGS) $(PROGSPECS) -c -o $@ $< 54 $(CC) $(CFLAGS) $(PROGSPECS) -c -o $@ $<
73+ $(CC) $(CFLAGS) $(ARPCFLAGS) $(PROGSPECS) -c -o $@ $< 55+ $(CC) $(CFLAGS) $(ARPCFLAGS) $(PROGSPECS) -c -o $@ $<
74+ 56+
75+extensions/arpt_%.o: extensions/arpt_%.c include/arptables.h include/arptables_common.h 57+extensions/arpt_%.o: extensions/arpt_%.c include/arptables.h include/arptables_common.h
76+ $(CC) $(CFLAGS) $(ARPCFLAGS) $(PROGSPECS) -c -o $@ $< 58+ $(CC) $(CFLAGS) $(ARPCFLAGS) $(PROGSPECS) -c -o $@ $<
77-- 59--
782.12.1 602.17.1
79 61
diff --git a/meta-networking/recipes-support/arptables/arptables/arptables-init-busybox.patch b/meta-networking/recipes-support/arptables/arptables/arptables-init-busybox.patch
deleted file mode 100644
index 24956c4ca..000000000
--- a/meta-networking/recipes-support/arptables/arptables/arptables-init-busybox.patch
+++ /dev/null
@@ -1,77 +0,0 @@
1Index: arptables-v0.0.3-4/arptables.sysv
2===================================================================
3--- arptables-v0.0.3-4.orig/arptables.sysv 2010-03-22 16:28:03.000000000 +0300
4+++ arptables-v0.0.3-4/arptables.sysv 2010-03-22 16:27:51.000000000 +0300
5@@ -12,10 +12,10 @@
6 # config: __SYSCONFIG__/arptables
7
8 source /etc/init.d/functions
9-source /etc/sysconfig/network
10+# source /etc/sysconfig/network
11
12 # Check that networking is up.
13-[ ${NETWORKING} = "no" ] && exit 0
14+# [ ${NETWORKING} = "no" ] && exit 0
15
16 [ -x __EXEC_PATH__/arptables ] || exit 1
17 [ -x __EXEC_PATH__/arptables-save ] || exit 1
18@@ -28,32 +28,30 @@
19 desc="Arp filtering"
20
21 start() {
22- echo -n $"Starting $desc ($prog): "
23+ echo -n "Starting $desc ($prog): "
24 __EXEC_PATH__/arptables-restore < __SYSCONFIG__/arptables || RETVAL=1
25
26 if [ $RETVAL -eq 0 ]; then
27- success "$prog startup"
28- rm -f /var/lock/subsys/$prog
29+ echo "$prog ok"
30+ touch /var/lock/subsys/$prog
31 else
32- failure "$prog startup"
33+ echo "$prog failed"
34 fi
35
36- echo
37 return $RETVAL
38 }
39
40 stop() {
41- echo -n $"Stopping $desc ($prog): "
42+ echo -n "Stopping $desc ($prog): "
43 __EXEC_PATH__/arptables-restore < /dev/null || RETVAL=1
44
45 if [ $RETVAL -eq 0 ]; then
46- success "$prog shutdown"
47- rm -f %{_localstatedir}/lock/subsys/$prog
48+ echo "$prog stopped"
49+ rm -f /var/lock/subsys/$prog
50 else
51- failure "$prog shutdown"
52+ echo "$prog failed to stop"
53 fi
54
55- echo
56 return $RETVAL
57 }
58
59@@ -63,15 +61,14 @@
60 }
61
62 save() {
63- echo -n $"Saving $desc ($prog): "
64+ echo -n "Saving $desc ($prog): "
65 __EXEC_PATH__/arptables-save > __SYSCONFIG__/arptables || RETVAL=1
66
67 if [ $RETVAL -eq 0 ]; then
68- success "$prog saved"
69+ echo "$prog saved"
70 else
71- failure "$prog saved"
72+ echo "$prog is not saved"
73 fi
74- echo
75 }
76
77 case "$1" in
diff --git a/meta-networking/recipes-support/arptables/arptables/arptables-remove-bashism.patch b/meta-networking/recipes-support/arptables/arptables/arptables-remove-bashism.patch
deleted file mode 100644
index f332658bc..000000000
--- a/meta-networking/recipes-support/arptables/arptables/arptables-remove-bashism.patch
+++ /dev/null
@@ -1,37 +0,0 @@
1From cd312bc0e3686404428878d23b8888cba09a20e1 Mon Sep 17 00:00:00 2001
2From: Robert Yang <liezhi.yang@windriver.com>
3Date: Thu, 18 Sep 2014 19:46:58 -0700
4Subject: [PATCH] arptables.sysv: remove bashism
5
6Use "." to replace of "source", and change /bin/bash to /bin/sh, the
7echo $"foo" works well in busybox.
8
9Upstream-Status: Pending
10
11Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
12---
13 arptables.sysv | 4 ++--
14 1 file changed, 2 insertions(+), 2 deletions(-)
15
16diff --git a/arptables.sysv b/arptables.sysv
17index 7a90bd2..7710376 100644
18--- a/arptables.sysv
19+++ b/arptables.sysv
20@@ -1,4 +1,4 @@
21-#!/bin/bash
22+#!/bin/sh
23 #
24 # init script for arptables
25 #
26@@ -11,7 +11,7 @@
27 #
28 # config: __SYSCONFIG__/arptables
29
30-source /etc/init.d/functions
31+. /etc/init.d/functions
32 # source /etc/sysconfig/network
33
34 # Check that networking is up.
35--
361.7.9.5
37
diff --git a/meta-networking/recipes-support/arptables/arptables_git.bb b/meta-networking/recipes-support/arptables/arptables_git.bb
index cec1d1f77..c02a19944 100644
--- a/meta-networking/recipes-support/arptables/arptables_git.bb
+++ b/meta-networking/recipes-support/arptables/arptables_git.bb
@@ -2,15 +2,13 @@ SUMMARY = "Administration tool for arp packet filtering"
2SECTION = "net" 2SECTION = "net"
3LICENSE = "GPL-2.0" 3LICENSE = "GPL-2.0"
4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6" 4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
5SRCREV = "f4ab8f63f11a72f14687a6646d04ae1bae3fa45f" 5SRCREV = "efae8949e31f8b2eb6290f377a28384cecaf105a"
6PV = "0.0.4+git${SRCPV}" 6PV = "0.0.5+git${SRCPV}"
7 7
8SRC_URI = " \ 8SRC_URI = " \
9 git://git.netfilter.org/arptables \ 9 git://git.netfilter.org/arptables \
10 file://0001-Use-ARPCFLAGS-for-package-specific-compiler-flags.patch \ 10 file://0001-Use-ARPCFLAGS-for-package-specific-compiler-flags.patch \
11 file://arptables-init-busybox.patch \
12 file://arptables-arpt-get-target-fix.patch \ 11 file://arptables-arpt-get-target-fix.patch \
13 file://arptables-remove-bashism.patch \
14 file://arptables.service \ 12 file://arptables.service \
15" 13"
16SRC_URI[arptables.md5sum] = "1d4ab05761f063b0751645d8f2b8f8e5" 14SRC_URI[arptables.md5sum] = "1d4ab05761f063b0751645d8f2b8f8e5"