summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorHao Jiang <jianghao@google.com>2022-05-19 14:21:30 -0700
committerKhem Raj <raj.khem@gmail.com>2022-10-12 19:19:27 -0700
commit6e2cfa4113766f703e55d711bf59ed3c8f17d5a2 (patch)
tree78c40706e7f22defb0a733e5c13b6b3f7a47d48c /meta-networking
parent2467e6c82d146d0f257f7f0f92a5a958ff1b3cb7 (diff)
downloadmeta-openembedded-6e2cfa4113766f703e55d711bf59ed3c8f17d5a2.tar.gz
mctp: install the .target files
Need the targets file to enable the mctpd.service on systemd. Signed-off-by: Hao Jiang <jianghao@google.com> Change-Id: I8d48d3767760dc1f34ae7e1266600d350ac93281
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-support/mctp/mctp_git.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta-networking/recipes-support/mctp/mctp_git.bb b/meta-networking/recipes-support/mctp/mctp_git.bb
index 516f3e2d9..9e97a6a60 100644
--- a/meta-networking/recipes-support/mctp/mctp_git.bb
+++ b/meta-networking/recipes-support/mctp/mctp_git.bb
@@ -22,13 +22,16 @@ PACKAGECONFIG ??= " \
22# mctpd will only be built if pkg-config detects libsystemd; in which case 22# mctpd will only be built if pkg-config detects libsystemd; in which case
23# we'll want to declare the dep and install the service. 23# we'll want to declare the dep and install the service.
24PACKAGECONFIG[systemd] = ",,systemd,libsystemd" 24PACKAGECONFIG[systemd] = ",,systemd,libsystemd"
25SYSTEMD_SERVICE:${PN} = "mctpd.service" 25SYSTEMD_SERVICE:${PN} = "mctpd.service mctp.target mctp-local.target"
26SYSTEMD_AUTO_ENABLE_${PN} = "enable"
26 27
27do_install:append () { 28do_install:append () {
28 if ${@bb.utils.contains('PACKAGECONFIG', 'systemd', 'true', 'false', d)}; then 29 if ${@bb.utils.contains('PACKAGECONFIG', 'systemd', 'true', 'false', d)}; then
29 install -d ${D}${systemd_system_unitdir} 30 install -d ${D}${systemd_system_unitdir}
30 install -m 0644 ${S}/conf/mctpd.service \ 31 install -m 0644 ${S}/conf/mctpd.service \
31 ${D}${systemd_system_unitdir}/mctpd.service 32 ${D}${systemd_system_unitdir}/mctpd.service
33 install -m 0644 ${S}/conf/*.target \
34 ${D}${systemd_system_unitdir}/
32 install -d ${D}${datadir}/dbus-1/system.d 35 install -d ${D}${datadir}/dbus-1/system.d
33 install -m 0644 ${S}/conf/mctpd-dbus.conf \ 36 install -m 0644 ${S}/conf/mctpd-dbus.conf \
34 ${D}${datadir}/dbus-1/system.d/mctpd.conf 37 ${D}${datadir}/dbus-1/system.d/mctpd.conf