summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-03-06 18:07:17 -0800
committerKhem Raj <raj.khem@gmail.com>2020-03-08 08:15:34 -0700
commit5c051f8402e790386c69b163d7276d913591075e (patch)
treeb3e516a89129da7cf641e512504dae31b3a71b0f /meta-networking
parenta367e54deb7c388a60cfddc356a695180bb67954 (diff)
downloadmeta-openembedded-5c051f8402e790386c69b163d7276d913591075e.tar.gz
corosync: Update to 3.0.3
- Add dependency on kronosnet - Remove obsolete options and packageconfigs - Drop upstreamed patch Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-extended/corosync/corosync/0001-configure.ac-fix-pkgconfig-issue-of-rdma.patch32
-rw-r--r--meta-networking/recipes-extended/corosync/corosync_3.0.3.bb (renamed from meta-networking/recipes-extended/corosync/corosync_2.4.5.bb)23
2 files changed, 8 insertions, 47 deletions
diff --git a/meta-networking/recipes-extended/corosync/corosync/0001-configure.ac-fix-pkgconfig-issue-of-rdma.patch b/meta-networking/recipes-extended/corosync/corosync/0001-configure.ac-fix-pkgconfig-issue-of-rdma.patch
deleted file mode 100644
index bdc7645ce..000000000
--- a/meta-networking/recipes-extended/corosync/corosync/0001-configure.ac-fix-pkgconfig-issue-of-rdma.patch
+++ /dev/null
@@ -1,32 +0,0 @@
1Subject: [PATCH] configure.ac: fix pkgconfig issue of rdma
2
3pkgconfig files from rdma-core(https://github.com/linux-rdma/rdma-core)
4are named start with lib, such as librdmacm.pc and libibverbs.pc. When
5rdma support is enabled, it fails to find rdma related libraries. Update
6configure.ac to the issue.
7
8Upstream-Status: Submitted [https://github.com/corosync/corosync/pull/515]
9
10Signed-off-by: Kai Kang <kai.kang@windriver.com>
11---
12 configure.ac | 4 ++--
13 1 file changed, 2 insertions(+), 2 deletions(-)
14
15diff --git a/configure.ac b/configure.ac
16index ac513e93..240cfed4 100644
17--- a/configure.ac
18+++ b/configure.ac
19@@ -459,8 +459,8 @@ if test "x${enable_testagents}" = xyes; then
20 fi
21
22 if test "x${enable_rdma}" = xyes; then
23- PKG_CHECK_MODULES([rdmacm],[rdmacm])
24- PKG_CHECK_MODULES([ibverbs],[ibverbs])
25+ PKG_CHECK_MODULES([rdmacm],[librdmacm])
26+ PKG_CHECK_MODULES([ibverbs],[libibverbs])
27 AC_DEFINE_UNQUOTED([HAVE_RDMA], 1, [have rdmacm])
28 PACKAGE_FEATURES="$PACKAGE_FEATURES rdma"
29 WITH_LIST="$WITH_LIST --with rdma"
30--
312.20.1
32
diff --git a/meta-networking/recipes-extended/corosync/corosync_2.4.5.bb b/meta-networking/recipes-extended/corosync/corosync_3.0.3.bb
index eefbcca8a..c0531d386 100644
--- a/meta-networking/recipes-extended/corosync/corosync_2.4.5.bb
+++ b/meta-networking/recipes-extended/corosync/corosync_3.0.3.bb
@@ -7,20 +7,16 @@ SECTION = "base"
7 7
8inherit autotools pkgconfig systemd useradd 8inherit autotools pkgconfig systemd useradd
9 9
10SRC_URI = "http://build.clusterlabs.org/corosync/releases/${BP}.tar.gz \ 10SRC_URI = "https://github.com/${BPN}/${BPN}/releases/download/v${PV}/${BP}.tar.gz \
11 file://corosync.conf \ 11 file://corosync.conf \
12 file://0001-configure.ac-fix-pkgconfig-issue-of-rdma.patch \
13 " 12 "
14 13SRC_URI[sha256sum] = "20eb903eb984f6a728282c199825e442e8bba869acefd22390076ef3a33a4ded"
15SRC_URI[md5sum] = "e36a056b893c313c4ec1fe0d7e6cdebd"
16SRC_URI[sha256sum] = "ab6eafdb8f43a23794fc15d4c5198bbd6759060cb13c8d2d1e78a6c8360aba5f"
17
18UPSTREAM_CHECK_REGEX = "(?P<pver>\d+\.(?!99)\d+(\.\d+)+)" 14UPSTREAM_CHECK_REGEX = "(?P<pver>\d+\.(?!99)\d+(\.\d+)+)"
19 15
20LICENSE = "BSD-3-Clause" 16LICENSE = "BSD-3-Clause"
21LIC_FILES_CHKSUM = "file://LICENSE;md5=a85eb4ce24033adb6088dd1d6ffc5e5d" 17LIC_FILES_CHKSUM = "file://LICENSE;md5=a85eb4ce24033adb6088dd1d6ffc5e5d"
22 18
23DEPENDS = "groff-native nss libqb" 19DEPENDS = "groff-native nss libqb kronosnet"
24 20
25SYSTEMD_SERVICE_${PN} = "corosync.service corosync-notifyd.service \ 21SYSTEMD_SERVICE_${PN} = "corosync.service corosync-notifyd.service \
26 ${@bb.utils.contains('PACKAGECONFIG', 'qdevice', 'corosync-qdevice.service', '', d)} \ 22 ${@bb.utils.contains('PACKAGECONFIG', 'qdevice', 'corosync-qdevice.service', '', d)} \
@@ -31,23 +27,20 @@ SYSTEMD_AUTO_ENABLE = "disable"
31INITSCRIPT_NAME = "corosync-daemon" 27INITSCRIPT_NAME = "corosync-daemon"
32 28
33PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \ 29PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
34 dbus qdevice qnetd snmp \ 30 dbus snmp \
35" 31"
36 32
37PACKAGECONFIG[dbus] = "--enable-dbus,--disable-dbus,dbus" 33PACKAGECONFIG[dbus] = "--enable-dbus,--disable-dbus,dbus"
38PACKAGECONFIG[qdevice] = "--enable-qdevices,--disable-qdevices"
39PACKAGECONFIG[qnetd] = "--enable-qnetd,--disable-qnetd"
40PACKAGECONFIG[rdma] = "--enable-rdma,--disable-rdma,rdma-core"
41PACKAGECONFIG[snmp] = "--enable-snmp,--disable-snmp,net-snmp" 34PACKAGECONFIG[snmp] = "--enable-snmp,--disable-snmp,net-snmp"
42PACKAGECONFIG[systemd] = "--enable-systemd --with-systemddir=${systemd_system_unitdir},--disable-systemd --without-systemddir,systemd" 35PACKAGECONFIG[systemd] = "--enable-systemd --with-systemddir=${systemd_system_unitdir},--disable-systemd --without-systemddir,systemd"
43 36
44EXTRA_OECONF = "ac_cv_path_BASHPATH=${base_bindir}/bash ap_cv_cc_pie=no" 37EXTRA_OECONF = "ac_cv_path_BASHPATH=${base_bindir}/bash ap_cv_cc_pie=no"
45EXTRA_OEMAKE = "tmpfilesdir_DATA=" 38EXTRA_OEMAKE = "tmpfilesdir_DATA="
46 39
47do_configure_prepend() { 40#do_configure_prepend() {
48 ( cd ${S} 41# ( cd ${S}
49 ${S}/autogen.sh ) 42# ${S}/autogen.sh )
50} 43#}
51 44
52do_install_append() { 45do_install_append() {
53 install -D -m 0644 ${WORKDIR}/corosync.conf ${D}/${sysconfdir}/corosync/corosync.conf.example 46 install -D -m 0644 ${WORKDIR}/corosync.conf ${D}/${sysconfdir}/corosync/corosync.conf.example