summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorPierre-Jean Texier <pjtexier@koncepto.io>2020-03-02 11:11:25 +0000
committerKhem Raj <raj.khem@gmail.com>2020-03-02 10:12:22 -0800
commit59f47567c00a3f2b0a6fd83db3770f7c3d94ef67 (patch)
tree57b930022992dd4854cf4558935de0a30833f68c /meta-networking
parent349dc7483d2ee91532a31a9854f4a74b8b7a1ace (diff)
downloadmeta-openembedded-59f47567c00a3f2b0a6fd83db3770f7c3d94ef67.tar.gz
mosquitto: upgrade 1.6.8 -> 1.6.9
Bugfix release. For details, see: https://mosquitto.org/blog/2020/02/version-1-6-9-released/ Also remove patches applied upstream. Signed-off-by: Pierre-Jean Texier <pjtexier@koncepto.io>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-connectivity/mosquitto/files/1568.patch67
-rw-r--r--meta-networking/recipes-connectivity/mosquitto/files/1569.patch25
-rw-r--r--meta-networking/recipes-connectivity/mosquitto/files/1570.patch39
-rw-r--r--meta-networking/recipes-connectivity/mosquitto/mosquitto_1.6.9.bb (renamed from meta-networking/recipes-connectivity/mosquitto/mosquitto_1.6.8.bb)7
4 files changed, 2 insertions, 136 deletions
diff --git a/meta-networking/recipes-connectivity/mosquitto/files/1568.patch b/meta-networking/recipes-connectivity/mosquitto/files/1568.patch
deleted file mode 100644
index 15f7a9105..000000000
--- a/meta-networking/recipes-connectivity/mosquitto/files/1568.patch
+++ /dev/null
@@ -1,67 +0,0 @@
1Upstream-Status: Submitted [https://github.com/eclipse/mosquitto/pull/1568]
2From 50bfc79cae5764a6e513b684a5eb5bef2b35c856 Mon Sep 17 00:00:00 2001
3From: Gianfranco Costamagna <costamagnagianfranco@yahoo.it>
4Date: Wed, 22 Jan 2020 12:30:25 +0100
5Subject: [PATCH] Bugfix: include "deps" directory only if BUNDLED_DEPS has
6 been provided and set to true
7
8Signed-off-by: Gianfranco Costamagna <costamagnagianfranco@yahoo.it>
9---
10 config.mk | 5 ++++-
11 lib/CMakeLists.txt | 5 ++++-
12 test/unit/Makefile | 6 +++++-
13 3 files changed, 13 insertions(+), 3 deletions(-)
14
15diff --git a/config.mk b/config.mk
16index 51e36e0d0..0ac24b3d4 100644
17--- a/config.mk
18+++ b/config.mk
19@@ -135,7 +135,10 @@ endif
20
21 STATIC_LIB_DEPS:=
22
23-LIB_CPPFLAGS=$(CPPFLAGS) -I. -I.. -I../lib -I../src/deps
24+LIB_CPPFLAGS=$(CPPFLAGS) -I. -I.. -I../lib
25+ifeq ($(WITH_BUNDLED_DEPS),yes)
26+ LIB_CPPFLAGS:=$(LIB_CPPFLAGS) -I../src/deps
27+endif
28 LIB_CFLAGS:=$(CFLAGS)
29 LIB_CXXFLAGS:=$(CXXFLAGS)
30 LIB_LDFLAGS:=$(LDFLAGS)
31diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
32index e1521f12a..891046a81 100644
33--- a/lib/CMakeLists.txt
34+++ b/lib/CMakeLists.txt
35@@ -1,11 +1,14 @@
36 add_subdirectory(cpp)
37
38 include_directories(${mosquitto_SOURCE_DIR} ${mosquitto_SOURCE_DIR}/lib
39- ${mosquitto_SOURCE_DIR}/src/deps
40 ${STDBOOL_H_PATH} ${STDINT_H_PATH}
41 ${OPENSSL_INCLUDE_DIR} ${PTHREAD_INCLUDE_DIR})
42 link_directories(${mosquitto_SOURCE_DIR}/lib)
43
44+if (WITH_BUNDLED_DEPS)
45+ include_directories(${mosquitto_SOURCE_DIR} ${mosquitto_SOURCE_DIR}/src/deps)
46+endif (WITH_BUNDLED_DEPS)
47+
48 set(C_SRC
49 actions.c
50 callbacks.c
51diff --git a/test/unit/Makefile b/test/unit/Makefile
52index 9d422428d..928579492 100644
53--- a/test/unit/Makefile
54+++ b/test/unit/Makefile
55@@ -2,7 +2,11 @@ include ../../config.mk
56
57 .PHONY: all check test test-broker test-lib clean coverage
58
59-CPPFLAGS:=$(CPPFLAGS) -I../.. -I../../lib -I../../src -I../../src/deps
60+CPPFLAGS:=$(CPPFLAGS) -I../.. -I../../lib -I../../src
61+ifeq ($(WITH_BUNDLED_DEPS),yes)
62+ CPPFLAGS:=$(CPPFLAGS) -I../../src/deps
63+endif
64+
65 CFLAGS:=$(CFLAGS) -coverage -Wall -ggdb
66 LDFLAGS:=$(LDFLAGS) -coverage
67 LDADD:=$(LDADD) -lcunit
diff --git a/meta-networking/recipes-connectivity/mosquitto/files/1569.patch b/meta-networking/recipes-connectivity/mosquitto/files/1569.patch
deleted file mode 100644
index 9718b98c8..000000000
--- a/meta-networking/recipes-connectivity/mosquitto/files/1569.patch
+++ /dev/null
@@ -1,25 +0,0 @@
1Upstream-Status: Submitted [https://github.com/eclipse/mosquitto/pull/1569]
2From fda932612afce2cead2fd2ca1c8ea543b2892177 Mon Sep 17 00:00:00 2001
3From: Gianfranco Costamagna <costamagnagianfranco@yahoo.it>
4Date: Wed, 22 Jan 2020 12:31:01 +0100
5Subject: [PATCH] Bugfix: enabling DLT was overriding everything else on linker
6 flags because of error in cmake set keyword
7
8Signed-off-by: Gianfranco Costamagna <costamagnagianfranco@yahoo.it>
9---
10 src/CMakeLists.txt | 2 +-
11 1 file changed, 1 insertion(+), 1 deletion(-)
12
13diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
14index 7898ff5b1..6dfbba5e6 100644
15--- a/src/CMakeLists.txt
16+++ b/src/CMakeLists.txt
17@@ -130,7 +130,7 @@ add_definitions (-DWITH_BROKER)
18 if (WITH_DLT)
19 message(STATUS "DLT_LIBDIR = ${DLT_LIBDIR}")
20 link_directories(${DLT_LIBDIR})
21- set (MOSQ_LIBS ${DLT_LIBRARIES})
22+ set (MOSQ_LIBS ${MOSQ_LIBS} ${DLT_LIBRARIES})
23 endif (WITH_DLT)
24
25 set (MOSQ_LIBS ${MOSQ_LIBS} ${OPENSSL_LIBRARIES})
diff --git a/meta-networking/recipes-connectivity/mosquitto/files/1570.patch b/meta-networking/recipes-connectivity/mosquitto/files/1570.patch
deleted file mode 100644
index f11fc4815..000000000
--- a/meta-networking/recipes-connectivity/mosquitto/files/1570.patch
+++ /dev/null
@@ -1,39 +0,0 @@
1Upstream-Status: Submitted [https://github.com/eclipse/mosquitto/pull/1570]
2From 775677b05190380c3736bf0dbef002ee7b9bff33 Mon Sep 17 00:00:00 2001
3From: Gianfranco Costamagna <costamagnagianfranco@yahoo.it>
4Date: Wed, 22 Jan 2020 12:29:41 +0100
5Subject: [PATCH] cmake: add ADNS enable/disable dynamic support
6
7Signed-off-by: Gianfranco Costamagna <costamagnagianfranco@yahoo.it>
8---
9 src/CMakeLists.txt | 8 ++++++--
10 1 file changed, 6 insertions(+), 2 deletions(-)
11
12diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
13index 7898ff5b1..edae76f32 100644
14--- a/src/CMakeLists.txt
15+++ b/src/CMakeLists.txt
16@@ -105,6 +105,9 @@ if (WITH_SYS_TREE)
17 add_definitions("-DWITH_SYS_TREE")
18 endif (WITH_SYS_TREE)
19
20+option(WITH_ADNS
21+ "Include ADNS support?" OFF)
22+
23 if (CMAKE_SYSTEM_NAME STREQUAL Linux)
24 option(WITH_SYSTEMD
25 "Include systemd support?" OFF)
26@@ -137,10 +140,11 @@ set (MOSQ_LIBS ${MOSQ_LIBS} ${OPENSSL_LIBRARIES})
27 # Check for getaddrinfo_a
28 include(CheckLibraryExists)
29 check_library_exists(anl getaddrinfo_a "" HAVE_GETADDRINFO_A)
30-if (HAVE_GETADDRINFO_A)
31+if (HAVE_GETADDRINFO_A AND WITH_ADNS)
32+ add_definitions("-DWITH_ADNS")
33 add_definitions(-DHAVE_GETADDRINFO_A)
34 set (MOSQ_LIBS ${MOSQ_LIBS} anl)
35-endif (HAVE_GETADDRINFO_A)
36+endif (HAVE_GETADDRINFO_A AND WITH_ADNS)
37
38
39 if (UNIX)
diff --git a/meta-networking/recipes-connectivity/mosquitto/mosquitto_1.6.8.bb b/meta-networking/recipes-connectivity/mosquitto/mosquitto_1.6.9.bb
index 6079555a0..0d840e938 100644
--- a/meta-networking/recipes-connectivity/mosquitto/mosquitto_1.6.8.bb
+++ b/meta-networking/recipes-connectivity/mosquitto/mosquitto_1.6.9.bb
@@ -16,14 +16,11 @@ DEPENDS = "uthash"
16 16
17SRC_URI = "http://mosquitto.org/files/source/mosquitto-${PV}.tar.gz \ 17SRC_URI = "http://mosquitto.org/files/source/mosquitto-${PV}.tar.gz \
18 file://mosquitto.init \ 18 file://mosquitto.init \
19 file://1568.patch \
20 file://1569.patch \
21 file://1570.patch \
22 file://1571.patch \ 19 file://1571.patch \
23" 20"
24 21
25SRC_URI[md5sum] = "24a0e567c845b3e41b75e237d200edf8" 22SRC_URI[md5sum] = "52f5078ec18aaf623b14dfb121fd534b"
26SRC_URI[sha256sum] = "7df23c81ca37f0e070574fe74414403cf25183016433d07add6134366fb45df6" 23SRC_URI[sha256sum] = "412979b2db0a0020bd02fa64f0a0de9e7000b84462586e32b67f29bb1f6c1685"
27 24
28inherit systemd update-rc.d useradd cmake 25inherit systemd update-rc.d useradd cmake
29 26