summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorRicardo Simoes <ricardo.simoes@pt.bosch.com>2024-05-02 14:17:58 +0200
committerKhem Raj <raj.khem@gmail.com>2024-05-02 07:32:55 -0700
commit577a55f7a522c1df519dd04cacc42a6f57cee177 (patch)
tree75e643d8c631b43b8533f4ac0e70a660235a0c0e /meta-networking
parent492b1b1adc1c546efd10b659d220a810736cc04a (diff)
downloadmeta-openembedded-577a55f7a522c1df519dd04cacc42a6f57cee177.tar.gz
mbedtls: Fix warning for missing program
When PACKAGECONFIG does not contains 'programs', the hello binary will not be generated, but the ALTERNATIVE 'hello' is still set, causing the update-alternatives bbclass to generate warnings for the missing 'hello' binary. This commit fixes that by only populating ALTERNATIVES when 'programs' is enabled. Signed-off-by: Ricardo Simoes <ricardo.simoes@pt.bosch.com> Signed-off-by: Mark Jonas <mark.jonas@de.bosch.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-connectivity/mbedtls/mbedtls_2.28.8.bb2
-rw-r--r--meta-networking/recipes-connectivity/mbedtls/mbedtls_3.6.0.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/meta-networking/recipes-connectivity/mbedtls/mbedtls_2.28.8.bb b/meta-networking/recipes-connectivity/mbedtls/mbedtls_2.28.8.bb
index 301e65598..db79241f2 100644
--- a/meta-networking/recipes-connectivity/mbedtls/mbedtls_2.28.8.bb
+++ b/meta-networking/recipes-connectivity/mbedtls/mbedtls_2.28.8.bb
@@ -50,7 +50,7 @@ RPROVIDES:${PN} = "polarssl"
50PACKAGES =+ "${PN}-programs" 50PACKAGES =+ "${PN}-programs"
51FILES:${PN}-programs = "${bindir}/" 51FILES:${PN}-programs = "${bindir}/"
52 52
53ALTERNATIVE:${PN}-programs = "hello" 53ALTERNATIVE:${PN}-programs = "${@bb.utils.contains('PACKAGECONFIG', 'programs', 'hello', '', d)}"
54ALTERNATIVE_LINK_NAME[hello] = "${bindir}/hello" 54ALTERNATIVE_LINK_NAME[hello] = "${bindir}/hello"
55 55
56BBCLASSEXTEND = "native nativesdk" 56BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-networking/recipes-connectivity/mbedtls/mbedtls_3.6.0.bb b/meta-networking/recipes-connectivity/mbedtls/mbedtls_3.6.0.bb
index 92a2de82a..a10fce0ff 100644
--- a/meta-networking/recipes-connectivity/mbedtls/mbedtls_3.6.0.bb
+++ b/meta-networking/recipes-connectivity/mbedtls/mbedtls_3.6.0.bb
@@ -55,7 +55,7 @@ RPROVIDES:${PN} = "polarssl"
55PACKAGES =+ "${PN}-programs" 55PACKAGES =+ "${PN}-programs"
56FILES:${PN}-programs = "${bindir}/" 56FILES:${PN}-programs = "${bindir}/"
57 57
58ALTERNATIVE:${PN}-programs = "hello" 58ALTERNATIVE:${PN}-programs = "${@bb.utils.contains('PACKAGECONFIG', 'programs', 'hello', '', d)}"
59ALTERNATIVE_LINK_NAME[hello] = "${bindir}/hello" 59ALTERNATIVE_LINK_NAME[hello] = "${bindir}/hello"
60 60
61BBCLASSEXTEND = "native nativesdk" 61BBCLASSEXTEND = "native nativesdk"