summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-03-05 11:00:50 -0800
committerKhem Raj <raj.khem@gmail.com>2024-03-05 11:02:05 -0800
commit455409badd5a8f170e7ed07c1df6b19f7fd2d77b (patch)
tree310dc5b6cd887e50d3ab0cb437e45748475e163a /meta-networking
parent39b25351230e3b2dea09845de4c4ffbd15a3a457 (diff)
downloadmeta-openembedded-455409badd5a8f170e7ed07c1df6b19f7fd2d77b.tar.gz
pgpool2: Fix build with postgresql 16+
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-support/pgpool2/pgpool2/define_SIGNAL_ARGS.patch25
-rw-r--r--meta-networking/recipes-support/pgpool2/pgpool2_4.5.1.bb1
2 files changed, 26 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/pgpool2/pgpool2/define_SIGNAL_ARGS.patch b/meta-networking/recipes-support/pgpool2/pgpool2/define_SIGNAL_ARGS.patch
new file mode 100644
index 000000000..3ae9b1bd9
--- /dev/null
+++ b/meta-networking/recipes-support/pgpool2/pgpool2/define_SIGNAL_ARGS.patch
@@ -0,0 +1,25 @@
1Define SIGNAL_ARGS if its not defined, this is flagged with
2newer C compilers e.g. clang18, where if it is not defined
3then it ends up with compiler errors
4
5/usr/include/postgresql/server/port.h:488:28: error: a parameter l
6ist without types is only allowed in a function definition
7| 488 | typedef void (*pqsigfunc) (SIGNAL_ARGS);
8| | ^
9
10Upstream-Status: Pending
11Signed-off-by: Khem Raj <raj.khem@gmail.com>
12
13--- a/src/include/pool_type.h
14+++ b/src/include/pool_type.h
15@@ -125,7 +125,9 @@ extern void ExceptionalCondition(const c
16 #define LONGALIGN(LEN) TYPEALIGN(ALIGNOF_LONG, (LEN))
17 #define DOUBLEALIGN(LEN) TYPEALIGN(ALIGNOF_DOUBLE, (LEN))
18 #define MAXALIGN(LEN) TYPEALIGN(MAXIMUM_ALIGNOF, (LEN))
19-
20+#ifndef SIGNAL_ARGS
21+#define SIGNAL_ARGS int postgres_signal_arg
22+#endif
23 /*
24 * It seems that sockaddr_storage is now commonly used in place of sockaddr.
25 * So, define it if it is not define yet, and create new SockAddr structure
diff --git a/meta-networking/recipes-support/pgpool2/pgpool2_4.5.1.bb b/meta-networking/recipes-support/pgpool2/pgpool2_4.5.1.bb
index b127d6962..ffb879952 100644
--- a/meta-networking/recipes-support/pgpool2/pgpool2_4.5.1.bb
+++ b/meta-networking/recipes-support/pgpool2/pgpool2_4.5.1.bb
@@ -12,6 +12,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=e4b38de086d73e0521de0bbdbaa4a1a9"
12 12
13SRC_URI = "http://www.pgpool.net/mediawiki/images/pgpool-II-${PV}.tar.gz \ 13SRC_URI = "http://www.pgpool.net/mediawiki/images/pgpool-II-${PV}.tar.gz \
14 file://0001-Fix-build-error-when-build-this-file.patch \ 14 file://0001-Fix-build-error-when-build-this-file.patch \
15 file://define_SIGNAL_ARGS.patch \
15 file://pgpool.sysconfig \ 16 file://pgpool.sysconfig \
16 file://pgpool.service \ 17 file://pgpool.service \
17 " 18 "