summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2024-02-28 15:33:45 +0800
committerKhem Raj <raj.khem@gmail.com>2024-02-28 00:38:46 -0800
commit2c4ab4a6c2a75536aff2d061d5a70ace083d3b7d (patch)
tree32a8beda95dc6b92a766ffd85def1b771c079f68 /meta-networking
parent9f0e5132110cd31112360d754e1203c32cb25ecc (diff)
downloadmeta-openembedded-2c4ab4a6c2a75536aff2d061d5a70ace083d3b7d.tar.gz
openipmi: fix do_configure error when using dash
We encountered a do_configure error when using dash on Ubuntu 20.04: conftest.c:31:26: fatal error: Python.h: No such file or directory 31 | #include <Python.h> | ^~~~~~~~~~ It seems that PYTHON_CPPFLAGS is not passed to configure command correctly. Use configuration option --with-pythoncflags instead of passing it in cmdline. Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-support/openipmi/openipmi_2.0.34.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/meta-networking/recipes-support/openipmi/openipmi_2.0.34.bb b/meta-networking/recipes-support/openipmi/openipmi_2.0.34.bb
index 470ce1e25..eacbe5ce9 100644
--- a/meta-networking/recipes-support/openipmi/openipmi_2.0.34.bb
+++ b/meta-networking/recipes-support/openipmi/openipmi_2.0.34.bb
@@ -42,7 +42,9 @@ CFLAGS += "-D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64"
42 42
43EXTRA_OECONF = "--disable-static \ 43EXTRA_OECONF = "--disable-static \
44 --with-perl='${STAGING_BINDIR_NATIVE}/perl-native/perl' \ 44 --with-perl='${STAGING_BINDIR_NATIVE}/perl-native/perl' \
45 --with-glibver=2.0" 45 --with-glibver=2.0 \
46 --with-pythoncflags='-I${STAGING_INCDIR}/${PYTHON_DIR}${PYTHON_ABI}' \
47 "
46 48
47PACKAGECONFIG ??= "gdbm" 49PACKAGECONFIG ??= "gdbm"
48PACKAGECONFIG[gdbm] = "ac_cv_header_gdbm_h=yes,ac_cv_header_gdbm_h=no,gdbm," 50PACKAGECONFIG[gdbm] = "ac_cv_header_gdbm_h=yes,ac_cv_header_gdbm_h=no,gdbm,"
@@ -64,7 +66,7 @@ FILES:${PN}-dbg += " \
64 66
65do_configure () { 67do_configure () {
66 # Let's perform regular configuration first then handle perl issues. 68 # Let's perform regular configuration first then handle perl issues.
67 PYTHON_CPPFLAGS=-I${STAGING_INCDIR}/${PYTHON_DIR}${PYTHON_ABI} autotools_do_configure 69 autotools_do_configure
68 70
69 perl_ver=`perl -V:version | cut -d\' -f 2` 71 perl_ver=`perl -V:version | cut -d\' -f 2`
70 72