diff options
author | Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com> | 2021-02-06 22:43:59 +0100 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-02-06 13:53:09 -0800 |
commit | 225a957ba502e5a3edfa6f924defdf17bcc5c82c (patch) | |
tree | f2475b71ab5e6a2c06aafe4b37231be6421635bb /meta-networking | |
parent | 8f21c1209b9c9e01ad6c5aca992f1ed92271defa (diff) | |
download | meta-openembedded-225a957ba502e5a3edfa6f924defdf17bcc5c82c.tar.gz |
cannelloni: update to 1.0.0
Removed upstreamed patches.
Signed-off-by: Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r-- | meta-networking/recipes-connectivity/cannelloni/cannelloni/0001-Use-GNUInstallDirs-instead-of-hard-coding-paths.patch | 43 | ||||
-rw-r--r-- | meta-networking/recipes-connectivity/cannelloni/cannelloni/0002-include-missing-stdexcept-for-runtime_error.patch | 32 | ||||
-rw-r--r-- | meta-networking/recipes-connectivity/cannelloni/cannelloni_1.0.0.bb (renamed from meta-networking/recipes-connectivity/cannelloni/cannelloni_git.bb) | 9 |
3 files changed, 2 insertions, 82 deletions
diff --git a/meta-networking/recipes-connectivity/cannelloni/cannelloni/0001-Use-GNUInstallDirs-instead-of-hard-coding-paths.patch b/meta-networking/recipes-connectivity/cannelloni/cannelloni/0001-Use-GNUInstallDirs-instead-of-hard-coding-paths.patch deleted file mode 100644 index b78f0b329..000000000 --- a/meta-networking/recipes-connectivity/cannelloni/cannelloni/0001-Use-GNUInstallDirs-instead-of-hard-coding-paths.patch +++ /dev/null | |||
@@ -1,43 +0,0 @@ | |||
1 | From c74f04dbab4d586287347b1d5517f36e2f0c3d8e Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Thu, 19 Dec 2019 15:52:34 -0800 | ||
4 | Subject: [PATCH] Use GNUInstallDirs instead of hard-coding paths | ||
5 | |||
6 | Bump minimum cmake version to be >= 3.1 | ||
7 | |||
8 | Upstream-Status: Submitted [https://github.com/mguentner/cannelloni/pull/22] | ||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | CMakeLists.txt | 8 +++++--- | ||
12 | 1 file changed, 5 insertions(+), 3 deletions(-) | ||
13 | |||
14 | diff --git a/CMakeLists.txt b/CMakeLists.txt | ||
15 | index 51b354f..958e0eb 100644 | ||
16 | --- a/CMakeLists.txt | ||
17 | +++ b/CMakeLists.txt | ||
18 | @@ -1,4 +1,4 @@ | ||
19 | -cmake_minimum_required(VERSION 2.6) | ||
20 | +cmake_minimum_required(VERSION 3.1) | ||
21 | project(cannelloni) | ||
22 | |||
23 | list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake/modules") | ||
24 | @@ -60,6 +60,8 @@ set_target_properties ( cannelloni-common | ||
25 | SOVERSION 0 | ||
26 | ) | ||
27 | |||
28 | +include(GNUInstallDirs) | ||
29 | + | ||
30 | if(SCTP_SUPPORT) | ||
31 | add_library(sctpthread STATIC sctpthread.cpp) | ||
32 | target_link_libraries(sctpthread addsources sctp) | ||
33 | @@ -68,5 +70,5 @@ endif(SCTP_SUPPORT) | ||
34 | set_target_properties(addsources PROPERTIES LIBRARY_OUTPUT_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}) | ||
35 | target_link_libraries(cannelloni addsources cannelloni-common pthread) | ||
36 | |||
37 | -install(TARGETS cannelloni DESTINATION bin) | ||
38 | -install(TARGETS cannelloni-common DESTINATION lib) | ||
39 | +install(TARGETS cannelloni DESTINATION ${CMAKE_INSTALL_BINDIR}) | ||
40 | +install(TARGETS cannelloni-common DESTINATION ${CMAKE_INSTALL_LIBDIR}) | ||
41 | -- | ||
42 | 2.24.1 | ||
43 | |||
diff --git a/meta-networking/recipes-connectivity/cannelloni/cannelloni/0002-include-missing-stdexcept-for-runtime_error.patch b/meta-networking/recipes-connectivity/cannelloni/cannelloni/0002-include-missing-stdexcept-for-runtime_error.patch deleted file mode 100644 index 55f28dd67..000000000 --- a/meta-networking/recipes-connectivity/cannelloni/cannelloni/0002-include-missing-stdexcept-for-runtime_error.patch +++ /dev/null | |||
@@ -1,32 +0,0 @@ | |||
1 | From 1788762863cd1f657697575f6e73a22e661ccb43 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Mon, 23 Dec 2019 10:32:54 -0800 | ||
4 | Subject: [PATCH 2/2] include missing <stdexcept> for runtime_error | ||
5 | MIME-Version: 1.0 | ||
6 | Content-Type: text/plain; charset=UTF-8 | ||
7 | Content-Transfer-Encoding: 8bit | ||
8 | |||
9 | Fixes | ||
10 | error: ‘runtime_error’ is not a member of ‘std’ | ||
11 | |||
12 | Upstream-Status: Submitted [https://github.com/mguentner/cannelloni/pull/22] | ||
13 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
14 | --- | ||
15 | parser.cpp | 1 + | ||
16 | 1 file changed, 1 insertion(+) | ||
17 | |||
18 | diff --git a/parser.cpp b/parser.cpp | ||
19 | index 4afb9e0..5bcdbde 100644 | ||
20 | --- a/parser.cpp | ||
21 | +++ b/parser.cpp | ||
22 | @@ -2,6 +2,7 @@ | ||
23 | |||
24 | #include <arpa/inet.h> | ||
25 | #include <string.h> | ||
26 | +#include <stdexcept> | ||
27 | |||
28 | void parseFrames(uint16_t len, const uint8_t* buffer, std::function<canfd_frame*()> frameAllocator, | ||
29 | std::function<void(canfd_frame*, bool)> frameReceiver) | ||
30 | -- | ||
31 | 2.24.1 | ||
32 | |||
diff --git a/meta-networking/recipes-connectivity/cannelloni/cannelloni_git.bb b/meta-networking/recipes-connectivity/cannelloni/cannelloni_1.0.0.bb index d4a62bd92..0cf57ccdb 100644 --- a/meta-networking/recipes-connectivity/cannelloni/cannelloni_git.bb +++ b/meta-networking/recipes-connectivity/cannelloni/cannelloni_1.0.0.bb | |||
@@ -2,13 +2,8 @@ SUMMARY = "a SocketCAN over Ethernet tunnel" | |||
2 | HOMEPAGE = "https://github.com/mguentner/cannelloni" | 2 | HOMEPAGE = "https://github.com/mguentner/cannelloni" |
3 | LICENSE = "GPLv2" | 3 | LICENSE = "GPLv2" |
4 | 4 | ||
5 | SRC_URI = "git://github.com/mguentner/cannelloni.git;protocol=https \ | 5 | SRC_URI = "git://github.com/mguentner/cannelloni.git;protocol=https" |
6 | file://0001-Use-GNUInstallDirs-instead-of-hard-coding-paths.patch \ | 6 | SRCREV = "0bd7e27db35bdef361226882ae04205504f7b2f4" |
7 | file://0002-include-missing-stdexcept-for-runtime_error.patch \ | ||
8 | " | ||
9 | SRCREV = "82aa49b417b96fe46bb3f017ae1bfea928f20f9a" | ||
10 | |||
11 | PV = "20160414+${SRCPV}" | ||
12 | 7 | ||
13 | LIC_FILES_CHKSUM = "file://gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263" | 8 | LIC_FILES_CHKSUM = "file://gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
14 | 9 | ||