diff options
author | Khem Raj <raj.khem@gmail.com> | 2018-05-11 20:07:53 -0700 |
---|---|---|
committer | Armin Kuster <akuster808@gmail.com> | 2018-05-17 08:32:26 -0700 |
commit | 1570a3d44f565ccd02510529f74797de8377387e (patch) | |
tree | 54eec1b4db712ae7511b9328bba6992912206777 /meta-networking | |
parent | f1230ec9b1cf5f689e8c362582044415f131a4f8 (diff) | |
download | meta-openembedded-1570a3d44f565ccd02510529f74797de8377387e.tar.gz |
ipsec-tools: Disable gcc8 warnings
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r-- | meta-networking/recipes-support/ipsec-tools/ipsec-tools/0001-Disable-gcc8-specific-warnings.patch | 86 | ||||
-rw-r--r-- | meta-networking/recipes-support/ipsec-tools/ipsec-tools_0.8.2.bb | 1 |
2 files changed, 87 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/ipsec-tools/ipsec-tools/0001-Disable-gcc8-specific-warnings.patch b/meta-networking/recipes-support/ipsec-tools/ipsec-tools/0001-Disable-gcc8-specific-warnings.patch new file mode 100644 index 000000000..11a910393 --- /dev/null +++ b/meta-networking/recipes-support/ipsec-tools/ipsec-tools/0001-Disable-gcc8-specific-warnings.patch | |||
@@ -0,0 +1,86 @@ | |||
1 | From 282d492e4cab7b4d9c7321f4c0c55b615948e280 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Fri, 11 May 2018 14:09:17 -0700 | ||
4 | Subject: [PATCH] Disable gcc8 specific warnings | ||
5 | |||
6 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
7 | --- | ||
8 | src/libipsec/ipsec_dump_policy.c | 5 +++++ | ||
9 | src/libipsec/pfkey_dump.c | 5 +++++ | ||
10 | src/racoon/isakmp.c | 11 ++++++++++- | ||
11 | 3 files changed, 20 insertions(+), 1 deletion(-) | ||
12 | |||
13 | diff --git a/src/libipsec/ipsec_dump_policy.c b/src/libipsec/ipsec_dump_policy.c | ||
14 | index 4d0eb77..c3fc842 100644 | ||
15 | --- a/src/libipsec/ipsec_dump_policy.c | ||
16 | +++ b/src/libipsec/ipsec_dump_policy.c | ||
17 | @@ -275,6 +275,10 @@ ipsec_dump_policy1(policy, delimiter, withports) | ||
18 | return buf; | ||
19 | } | ||
20 | |||
21 | +#pragma GCC diagnostic push | ||
22 | +#if defined(__GNUC__) && (__GNUC__ >= 8) | ||
23 | +#pragma GCC diagnostic ignored "-Wformat-truncation" | ||
24 | +#endif | ||
25 | static char * | ||
26 | ipsec_dump_ipsecrequest(buf, len, xisr, bound, withports) | ||
27 | char *buf; | ||
28 | @@ -419,3 +423,4 @@ set_address(buf, len, sa, withports) | ||
29 | |||
30 | return buf; | ||
31 | } | ||
32 | +#pragma GCC diagnostic pop | ||
33 | diff --git a/src/libipsec/pfkey_dump.c b/src/libipsec/pfkey_dump.c | ||
34 | index 4627ebc..451e535 100644 | ||
35 | --- a/src/libipsec/pfkey_dump.c | ||
36 | +++ b/src/libipsec/pfkey_dump.c | ||
37 | @@ -691,6 +691,10 @@ str_ipport(sa) | ||
38 | /* | ||
39 | * set "/prefix[port number]" to buffer. | ||
40 | */ | ||
41 | +#pragma GCC diagnostic push | ||
42 | +#if defined(__GNUC__) && (__GNUC__ >= 8) | ||
43 | +#pragma GCC diagnostic ignored "-Wformat-truncation" | ||
44 | +#endif | ||
45 | static char * | ||
46 | str_prefport(family, pref, port, ulp) | ||
47 | u_int family, pref, port, ulp; | ||
48 | @@ -735,6 +739,7 @@ str_prefport(family, pref, port, ulp) | ||
49 | |||
50 | return buf; | ||
51 | } | ||
52 | +#pragma GCC diagnostic pop | ||
53 | |||
54 | static void | ||
55 | str_upperspec(ulp, p1, p2) | ||
56 | diff --git a/src/racoon/isakmp.c b/src/racoon/isakmp.c | ||
57 | index 7ff53a3..4addf24 100644 | ||
58 | --- a/src/racoon/isakmp.c | ||
59 | +++ b/src/racoon/isakmp.c | ||
60 | @@ -3124,7 +3124,12 @@ script_hook(iph1, script) | ||
61 | #endif | ||
62 | |||
63 | /* local address */ | ||
64 | +#pragma GCC diagnostic push | ||
65 | +#if defined(__GNUC__) && (__GNUC__ >= 8) | ||
66 | +#pragma GCC diagnostic ignored "-Wstringop-truncation" | ||
67 | +#endif | ||
68 | GETNAMEINFO(iph1->local, addrstr, portstr); | ||
69 | +#pragma GCC diagnostic pop | ||
70 | |||
71 | if (script_env_append(&envp, &envc, "LOCAL_ADDR", addrstr) != 0) { | ||
72 | plog(LLV_ERROR, LOCATION, NULL, "Cannot set LOCAL_ADDR\n"); | ||
73 | @@ -3138,8 +3143,12 @@ script_hook(iph1, script) | ||
74 | |||
75 | /* Peer address */ | ||
76 | if (iph1->remote != NULL) { | ||
77 | +#pragma GCC diagnostic push | ||
78 | +#if defined(__GNUC__) && (__GNUC__ >= 8) | ||
79 | +#pragma GCC diagnostic ignored "-Wstringop-truncation" | ||
80 | +#endif | ||
81 | GETNAMEINFO(iph1->remote, addrstr, portstr); | ||
82 | - | ||
83 | +#pragma GCC diagnostic pop | ||
84 | if (script_env_append(&envp, &envc, | ||
85 | "REMOTE_ADDR", addrstr) != 0) { | ||
86 | plog(LLV_ERROR, LOCATION, NULL, | ||
diff --git a/meta-networking/recipes-support/ipsec-tools/ipsec-tools_0.8.2.bb b/meta-networking/recipes-support/ipsec-tools/ipsec-tools_0.8.2.bb index 5cbeb15ad..020903d82 100644 --- a/meta-networking/recipes-support/ipsec-tools/ipsec-tools_0.8.2.bb +++ b/meta-networking/recipes-support/ipsec-tools/ipsec-tools_0.8.2.bb | |||
@@ -25,6 +25,7 @@ SRC_URI = "http://ftp.netbsd.org/pub/NetBSD/misc/ipsec-tools/0.8/ipsec-tools-${P | |||
25 | file://0001-Fix-header-issues-found-with-musl-libc.patch \ | 25 | file://0001-Fix-header-issues-found-with-musl-libc.patch \ |
26 | file://0002-cfparse-clear-memory-equal-to-size-of-array.patch \ | 26 | file://0002-cfparse-clear-memory-equal-to-size-of-array.patch \ |
27 | file://fix-CVE-2016-10396.patch \ | 27 | file://fix-CVE-2016-10396.patch \ |
28 | file://0001-Disable-gcc8-specific-warnings.patch \ | ||
28 | " | 29 | " |
29 | SRC_URI[md5sum] = "d53ec14a0a3ece64e09e5e34b3350b41" | 30 | SRC_URI[md5sum] = "d53ec14a0a3ece64e09e5e34b3350b41" |
30 | SRC_URI[sha256sum] = "8eb6b38716e2f3a8a72f1f549c9444c2bc28d52c9536792690564c74fe722f2d" | 31 | SRC_URI[sha256sum] = "8eb6b38716e2f3a8a72f1f549c9444c2bc28d52c9536792690564c74fe722f2d" |