summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorYoann Congal <yoann.congal@smile.fr>2024-05-17 17:12:15 +0200
committerKhem Raj <raj.khem@gmail.com>2024-05-19 08:28:01 -0700
commit1429a784c7da835f11b9d5aa144d05a63e3d953a (patch)
tree55d2b65c0ecab292d5bd77f88f4aa6dfc1c86843 /meta-networking
parent5d2e783591a304565cd6c8a895e698c4285caf67 (diff)
downloadmeta-openembedded-1429a784c7da835f11b9d5aa144d05a63e3d953a.tar.gz
squid: workaround a build failure with native gcc10
When build on Debian 11 (gcc10), squid fails to build[0] because of a bug[1] in the configure step (it mixes options between old native compiler and recent target compiler: the former needs the std=c++17 option, the latter doesn't). The workaround is to force the "-std=c++17" option for the native build. NB: Our Buildroot friends have the same workaround[2]. [0]: https://autobuilder.yoctoproject.org/typhoon/#/builders/155/builds/23/steps/28/logs/stdio [1]: https://bugs.squid-cache.org/show_bug.cgi?id=5376 Bug closed as invalid by upstream [2]: https://github.com/buildroot/buildroot/blob/932b52fad87d79d9f26a343edafe2981079de16e/package/squid/squid.mk#L24 Signed-off-by: Yoann Congal <yoann.congal@smile.fr> Reviewed-by: Alexandre Truong <alexandre.truong@smile.fr> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-daemons/squid/squid_6.9.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-networking/recipes-daemons/squid/squid_6.9.bb b/meta-networking/recipes-daemons/squid/squid_6.9.bb
index f0663a5e0..33d286e12 100644
--- a/meta-networking/recipes-daemons/squid/squid_6.9.bb
+++ b/meta-networking/recipes-daemons/squid/squid_6.9.bb
@@ -68,6 +68,11 @@ EXTRA_OECONF += "--with-default-user=squid \
68 --with-logdir=${localstatedir}/log/${BPN} \ 68 --with-logdir=${localstatedir}/log/${BPN} \
69 'PERL=${USRBINPATH}/env perl'" 69 'PERL=${USRBINPATH}/env perl'"
70 70
71# Workaround a build failure when using a native compiler that need -std=c++17
72# with a cross-compiler that doesn't.
73# Upstream issue closed as invalid : https://bugs.squid-cache.org/show_bug.cgi?id=5376
74BUILD_CXXFLAGS += "-std=c++17"
75
71export BUILDCXXFLAGS="${BUILD_CXXFLAGS}" 76export BUILDCXXFLAGS="${BUILD_CXXFLAGS}"
72 77
73TESTDIR = "test-suite" 78TESTDIR = "test-suite"