diff options
author | Khem Raj <raj.khem@gmail.com> | 2021-04-15 07:17:09 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-04-15 09:28:44 -0700 |
commit | 08c0280b7cea4dd1d61d98331c1cd327a82636f3 (patch) | |
tree | c968a5cb47b1842e436ce74c506cd40101f713b0 /meta-networking | |
parent | 7a5fbd9d46cdec887d7b370f567e740e7731bfec (diff) | |
download | meta-openembedded-08c0280b7cea4dd1d61d98331c1cd327a82636f3.tar.gz |
open-vm-tools: Fix build with gcc 11
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Cc: Trevor Gamblin <Trevor.Gamblin@windriver.com>
Diffstat (limited to 'meta-networking')
2 files changed, 30 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/open-vm-tools/open-vm-tools/0001-pollGtk-Fix-volatile-qualifier-exposed-incorrectly.patch b/meta-networking/recipes-support/open-vm-tools/open-vm-tools/0001-pollGtk-Fix-volatile-qualifier-exposed-incorrectly.patch new file mode 100644 index 0000000000..fdcd7d614e --- /dev/null +++ b/meta-networking/recipes-support/open-vm-tools/open-vm-tools/0001-pollGtk-Fix-volatile-qualifier-exposed-incorrectly.patch | |||
@@ -0,0 +1,29 @@ | |||
1 | From 524fd4db646b4ac2155074b4cedf8436a8ff726d Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Thu, 15 Apr 2021 06:58:31 -0700 | ||
4 | Subject: [PATCH] pollGtk: Fix volatile qualifier exposed incorrectly | ||
5 | |||
6 | GCC11 flags it | ||
7 | |||
8 | Fixes | ||
9 | glib-2.0/glib/gatomic.h:117:5: error: argument 2 of '__atomic_load' discards 'volatile' qualifier [-Werror=incompatible-pointer-types] | ||
10 | |||
11 | Upstream-Status: Pending | ||
12 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
13 | --- | ||
14 | open-vm-tools/lib/pollGtk/pollGtk.c | 2 +- | ||
15 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
16 | |||
17 | diff --git a/open-vm-tools/lib/pollGtk/pollGtk.c b/open-vm-tools/lib/pollGtk/pollGtk.c | ||
18 | index 4ccaeda6..336a8bf1 100644 | ||
19 | --- a/open-vm-tools/lib/pollGtk/pollGtk.c | ||
20 | +++ b/open-vm-tools/lib/pollGtk/pollGtk.c | ||
21 | @@ -127,7 +127,7 @@ typedef struct Poll { | ||
22 | } Poll; | ||
23 | |||
24 | static Poll *pollState; | ||
25 | -static volatile gsize inited = 0; | ||
26 | +static gsize inited = 0; | ||
27 | |||
28 | static VMwareStatus | ||
29 | PollGtkCallback(PollClassSet classSet, // IN | ||
diff --git a/meta-networking/recipes-support/open-vm-tools/open-vm-tools_11.2.5.bb b/meta-networking/recipes-support/open-vm-tools/open-vm-tools_11.2.5.bb index 256949a03d..473af8d41b 100644 --- a/meta-networking/recipes-support/open-vm-tools/open-vm-tools_11.2.5.bb +++ b/meta-networking/recipes-support/open-vm-tools/open-vm-tools_11.2.5.bb | |||
@@ -44,6 +44,7 @@ SRC_URI = "git://github.com/vmware/open-vm-tools.git;protocol=https \ | |||
44 | file://0001-Make-HgfsConvertFromNtTimeNsec-aware-of-64-bit-time_.patch;patchdir=.. \ | 44 | file://0001-Make-HgfsConvertFromNtTimeNsec-aware-of-64-bit-time_.patch;patchdir=.. \ |
45 | file://0002-hgfsServerLinux-Consider-64bit-time_t-possibility.patch;patchdir=.. \ | 45 | file://0002-hgfsServerLinux-Consider-64bit-time_t-possibility.patch;patchdir=.. \ |
46 | file://0001-hgfsmounter-Makefile.am-support-usrmerge.patch;patchdir=.. \ | 46 | file://0001-hgfsmounter-Makefile.am-support-usrmerge.patch;patchdir=.. \ |
47 | file://0001-pollGtk-Fix-volatile-qualifier-exposed-incorrectly.patch;patchdir=.. \ | ||
47 | " | 48 | " |
48 | 49 | ||
49 | SRC_URI_append_libc-musl = " file://0001-Add-resolv_compat.h-for-musl-builds.patch;patchdir=.. \ | 50 | SRC_URI_append_libc-musl = " file://0001-Add-resolv_compat.h-for-musl-builds.patch;patchdir=.. \ |