summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support
diff options
context:
space:
mode:
authorPoonam Jadhav <ppjadhav456@gmail.com>2024-07-25 19:15:06 +0530
committerKhem Raj <raj.khem@gmail.com>2024-07-25 07:58:08 -0700
commitec1d116c8c8ed00149a6b7bc03fdd678fdfc9bf5 (patch)
treeef9eeef9d83c80655f1cfbad7eb25ad47150f58c /meta-networking/recipes-support
parent1974c7a6d3b1ef9eb30cb335af380fce2f07501f (diff)
downloadmeta-openembedded-ec1d116c8c8ed00149a6b7bc03fdd678fdfc9bf5.tar.gz
tcpreplay: Fix CVE-2023-4256
Add patch to fix tcpreplay CVE-2023-4256 dlt_jnpr_ether_cleanup: check config before cleanup Links: https://github.com/appneta/tcpreplay/pull/851 https://github.com/appneta/tcpreplay/issues/813#issuecomment-2245557093 Signed-off-by: Poonam Jadhav <poonam.jadhav@kpit.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support')
-rw-r--r--meta-networking/recipes-support/tcpreplay/tcpreplay/CVE-2023-4256.patch27
-rw-r--r--meta-networking/recipes-support/tcpreplay/tcpreplay_4.4.4.bb1
2 files changed, 28 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/tcpreplay/tcpreplay/CVE-2023-4256.patch b/meta-networking/recipes-support/tcpreplay/tcpreplay/CVE-2023-4256.patch
new file mode 100644
index 000000000..2e4eee025
--- /dev/null
+++ b/meta-networking/recipes-support/tcpreplay/tcpreplay/CVE-2023-4256.patch
@@ -0,0 +1,27 @@
1From 62bc10d4f1d2c9e2833ef2898fb0170e9300a9dd Mon Sep 17 00:00:00 2001
2From: Marsman1996 <lqliuyuwei@outlook.com>
3Date: Tue, 2 Apr 2024 17:29:21 +0800
4Subject: [PATCH] dlt_jnpr_ether_cleanup: check config before cleanup
5
6CVE: CVE-2023-4256
7Upstream-Status: Backport [https://github.com/appneta/tcpreplay/pull/851]
8Signed-off-by: Poonam Jadhav <poonam.jadhav@kpit.com>
9---
10 src/tcpedit/plugins/dlt_jnpr_ether/jnpr_ether.c | 3 ++-
11 1 file changed, 2 insertions(+), 1 deletion(-)
12
13diff --git a/src/tcpedit/plugins/dlt_jnpr_ether/jnpr_ether.c b/src/tcpedit/plugins/dlt_jnpr_ether/jnpr_ether.c
14index c53ec297..9642a2c2 100644
15--- a/src/tcpedit/plugins/dlt_jnpr_ether/jnpr_ether.c
16+++ b/src/tcpedit/plugins/dlt_jnpr_ether/jnpr_ether.c
17@@ -164,8 +164,9 @@ dlt_jnpr_ether_cleanup(tcpeditdlt_t *ctx)
18 jnpr_ether_config_t *config;
19
20 config = (jnpr_ether_config_t *)ctx->encoder->config;
21- if (config->subctx != NULL)
22+ if (config != NULL && config->subctx != NULL) {
23 tcpedit_dlt_cleanup(config->subctx);
24+ }
25 safe_free(plugin->config);
26 plugin->config = NULL;
27 plugin->config_size = 0;
diff --git a/meta-networking/recipes-support/tcpreplay/tcpreplay_4.4.4.bb b/meta-networking/recipes-support/tcpreplay/tcpreplay_4.4.4.bb
index 26de40a65..16cff2f0e 100644
--- a/meta-networking/recipes-support/tcpreplay/tcpreplay_4.4.4.bb
+++ b/meta-networking/recipes-support/tcpreplay/tcpreplay_4.4.4.bb
@@ -11,6 +11,7 @@ SRC_URI = "https://github.com/appneta/${BPN}/releases/download/v${PV}/${BP}.tar.
11 file://0001-libopts.m4-set-POSIX_SHELL-to-bin-sh.patch \ 11 file://0001-libopts.m4-set-POSIX_SHELL-to-bin-sh.patch \
12 file://0001-configure.ac-unify-search-dirs-for-pcap-and-add-lib3.patch \ 12 file://0001-configure.ac-unify-search-dirs-for-pcap-and-add-lib3.patch \
13 file://0001-configure.ac-do-not-run-conftest-in-case-of-cross-co.patch \ 13 file://0001-configure.ac-do-not-run-conftest-in-case-of-cross-co.patch \
14 file://CVE-2023-4256.patch \
14" 15"
15 16
16SRC_URI[sha256sum] = "44f18fb6d3470ecaf77a51b901a119dae16da5be4d4140ffbb2785e37ad6d4bf" 17SRC_URI[sha256sum] = "44f18fb6d3470ecaf77a51b901a119dae16da5be4d4140ffbb2785e37ad6d4bf"