summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support
diff options
context:
space:
mode:
authorChangqing Li <changqing.li@windriver.com>2018-07-25 11:27:28 +0800
committerKhem Raj <raj.khem@gmail.com>2018-07-27 07:19:12 -0700
commit65ad10fd67a1f453c9c1c4c8961474b8b362c222 (patch)
tree3b9353f04284bc1d56b7e0bc9cb6fd14e70053da /meta-networking/recipes-support
parent82d57ef7adf24d7668fa006022f1c4b054c4b4de (diff)
downloadmeta-openembedded-65ad10fd67a1f453c9c1c4c8961474b8b362c222.tar.gz
libldb: upgrade 1.3.1 -> 1.4.1
Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support')
-rw-r--r--meta-networking/recipes-support/libldb/libldb/0001-libldb-fix-config-error.patch87
-rw-r--r--meta-networking/recipes-support/libldb/libldb/avoid-openldap-unless-wanted.patch16
-rw-r--r--[-rwxr-xr-x]meta-networking/recipes-support/libldb/libldb/do-not-import-target-module-while-cross-compile.patch19
-rw-r--r--meta-networking/recipes-support/libldb/libldb/libldb-fix-musl-libc-conflict-type-error.patch45
-rw-r--r--meta-networking/recipes-support/libldb/libldb/libldb-fix-musl-libc-unkown-type-error.patch31
-rw-r--r--meta-networking/recipes-support/libldb/libldb/options-1.4.1.patch (renamed from meta-networking/recipes-support/libldb/libldb/options-1.3.1.patch)65
-rw-r--r--meta-networking/recipes-support/libldb/libldb_1.4.1.bb (renamed from meta-networking/recipes-support/libldb/libldb_1.3.1.bb)10
7 files changed, 225 insertions, 48 deletions
diff --git a/meta-networking/recipes-support/libldb/libldb/0001-libldb-fix-config-error.patch b/meta-networking/recipes-support/libldb/libldb/0001-libldb-fix-config-error.patch
new file mode 100644
index 000000000..5818d57f7
--- /dev/null
+++ b/meta-networking/recipes-support/libldb/libldb/0001-libldb-fix-config-error.patch
@@ -0,0 +1,87 @@
1From bc4ff7e37ce120c257e52a81fe3475499dfd2573 Mon Sep 17 00:00:00 2001
2From: Changqing Li <changqing.li@windriver.com>
3Date: Tue, 24 Jul 2018 10:10:24 +0800
4Subject: [PATCH] libldb: fix config error
5
6Signed-off-by: Changqing Li <changqing.li@windriver.com>
7---
8 wscript | 58 +++++++++++++++++++++++++++++-----------------------------
9 1 file changed, 29 insertions(+), 29 deletions(-)
10
11diff --git a/wscript b/wscript
12index b0af7b6..8ad9f96 100644
13--- a/wscript
14+++ b/wscript
15@@ -115,40 +115,40 @@ def configure(conf):
16 onlyif='talloc tdb tevent pyldb-util',
17 implied_deps='replace talloc tdb tevent'):
18 conf.define('USING_SYSTEM_LDB', 1)
19+ if not Options.options.without_ldb_lmdb:
20+ if not conf.CHECK_CODE('return !(sizeof(size_t) >= 8)',
21+ "HAVE_64_BIT_SIZE_T_FOR_LMDB",
22+ execute=True,
23+ msg='Checking for a 64-bit host to '
24+ 'support lmdb'):
25+ Logs.warn("--without-ldb-lmdb implied as this "
26+ "host is not 64-bit")
27+
28+ if not conf.env.standalone_ldb and \
29+ not Options.options.without_ad_dc and \
30+ conf.CONFIG_GET('ENABLE_SELFTEST'):
31+ Logs.warn("NOTE: Some AD DC parts of selftest will fail")
32
33- if not conf.CHECK_CODE('return !(sizeof(size_t) >= 8)',
34- "HAVE_64_BIT_SIZE_T_FOR_LMDB",
35- execute=True,
36- msg='Checking for a 64-bit host to '
37- 'support lmdb'):
38- Logs.warn("--without-ldb-lmdb implied as this "
39- "host is not 64-bit")
40-
41- if not conf.env.standalone_ldb and \
42- not Options.options.without_ad_dc and \
43- conf.CONFIG_GET('ENABLE_SELFTEST'):
44- Logs.warn("NOTE: Some AD DC parts of selftest will fail")
45-
46- conf.env.REQUIRE_LMDB = False
47- else:
48- if conf.env.standalone_ldb:
49- if Options.options.without_ldb_lmdb:
50- conf.env.REQUIRE_LMDB = False
51- else:
52- conf.env.REQUIRE_LMDB = True
53- elif Options.options.without_ad_dc:
54 conf.env.REQUIRE_LMDB = False
55 else:
56- if Options.options.without_ldb_lmdb:
57- if not Options.options.without_ad_dc and \
58- conf.CONFIG_GET('ENABLE_SELFTEST'):
59- raise Utils.WafError('--without-ldb-lmdb conflicts '
60- 'with --enable-selftest while '
61- 'building the AD DC')
62-
63+ if conf.env.standalone_ldb:
64+ if Options.options.without_ldb_lmdb:
65+ conf.env.REQUIRE_LMDB = False
66+ else:
67+ conf.env.REQUIRE_LMDB = True
68+ elif Options.options.without_ad_dc:
69 conf.env.REQUIRE_LMDB = False
70 else:
71- conf.env.REQUIRE_LMDB = True
72+ if Options.options.without_ldb_lmdb:
73+ if not Options.options.without_ad_dc and \
74+ conf.CONFIG_GET('ENABLE_SELFTEST'):
75+ raise Utils.WafError('--without-ldb-lmdb conflicts '
76+ 'with --enable-selftest while '
77+ 'building the AD DC')
78+
79+ conf.env.REQUIRE_LMDB = False
80+ else:
81+ conf.env.REQUIRE_LMDB = True
82
83
84 if conf.CONFIG_SET('USING_SYSTEM_LDB'):
85--
862.7.4
87
diff --git a/meta-networking/recipes-support/libldb/libldb/avoid-openldap-unless-wanted.patch b/meta-networking/recipes-support/libldb/libldb/avoid-openldap-unless-wanted.patch
index 8ab094fa7..b30afeee2 100644
--- a/meta-networking/recipes-support/libldb/libldb/avoid-openldap-unless-wanted.patch
+++ b/meta-networking/recipes-support/libldb/libldb/avoid-openldap-unless-wanted.patch
@@ -1,6 +1,16 @@
1--- a/wscript 2015-11-18 12:43:33.000000000 +0100 1From 63570b98ef63c91d8508478fcbe6b89c90c8398f Mon Sep 17 00:00:00 2001
2+++ b/wscript 2015-11-18 12:46:25.000000000 +0100 2From: Jens Rehsack <rehsack@gmail.com>
3@@ -58,9 +58,7 @@ 3Date: Thu, 19 Nov 2015 20:45:56 +0100
4
5---
6 wscript | 4 +---
7 1 file changed, 1 insertion(+), 3 deletions(-)
8
9diff --git a/wscript b/wscript
10index e7c05d2..1633593 100644
11--- a/wscript
12+++ b/wscript
13@@ -161,9 +161,7 @@ def configure(conf):
4 if conf.env.standalone_ldb: 14 if conf.env.standalone_ldb:
5 conf.CHECK_XSLTPROC_MANPAGES() 15 conf.CHECK_XSLTPROC_MANPAGES()
6 16
diff --git a/meta-networking/recipes-support/libldb/libldb/do-not-import-target-module-while-cross-compile.patch b/meta-networking/recipes-support/libldb/libldb/do-not-import-target-module-while-cross-compile.patch
index fdd312c0a..ee4936a5a 100755..100644
--- a/meta-networking/recipes-support/libldb/libldb/do-not-import-target-module-while-cross-compile.patch
+++ b/meta-networking/recipes-support/libldb/libldb/do-not-import-target-module-while-cross-compile.patch
@@ -1,12 +1,21 @@
1From f4cda3a71311e4496b725bc5f46af93413ec7a1c Mon Sep 17 00:00:00 2001
2From: Bian Naimeng <biannm@cn.fujitsu.com>
3Date: Fri, 17 Jul 2015 11:58:49 +0800
4Subject: [PATCH] libldb: add new recipe
5
1Some modules such as dynamic library maybe cann't be imported while cross compile, 6Some modules such as dynamic library maybe cann't be imported while cross compile,
2we just check whether does the module exist. 7we just check whether does the module exist.
3 8
4Signed-off-by: Bian Naimeng <biannm@cn.fujitsu.com> 9Signed-off-by: Bian Naimeng <biannm@cn.fujitsu.com>
5 10
6Index: ldb-1.1.26/buildtools/wafsamba/samba_bundled.py 11---
7=================================================================== 12 buildtools/wafsamba/samba_bundled.py | 32 ++++++++++++++++++++++++--------
8--- ldb-1.1.26.orig/buildtools/wafsamba/samba_bundled.py 13 1 file changed, 24 insertions(+), 8 deletions(-)
9+++ ldb-1.1.26/buildtools/wafsamba/samba_bundled.py 14
15diff --git a/buildtools/wafsamba/samba_bundled.py b/buildtools/wafsamba/samba_bundled.py
16index 253d604..398cc6a 100644
17--- a/buildtools/wafsamba/samba_bundled.py
18+++ b/buildtools/wafsamba/samba_bundled.py
10@@ -2,6 +2,7 @@ 19@@ -2,6 +2,7 @@
11 20
12 import sys 21 import sys
@@ -15,7 +24,7 @@ Index: ldb-1.1.26/buildtools/wafsamba/samba_bundled.py
15 from Configure import conf 24 from Configure import conf
16 from samba_utils import TO_LIST 25 from samba_utils import TO_LIST
17 26
18@@ -230,17 +231,32 @@ def CHECK_BUNDLED_SYSTEM_PYTHON(conf, li 27@@ -249,17 +250,32 @@ def CHECK_BUNDLED_SYSTEM_PYTHON(conf, libname, modulename, minversion='0.0.0'):
19 # versions 28 # versions
20 minversion = minimum_library_version(conf, libname, minversion) 29 minversion = minimum_library_version(conf, libname, minversion)
21 30
diff --git a/meta-networking/recipes-support/libldb/libldb/libldb-fix-musl-libc-conflict-type-error.patch b/meta-networking/recipes-support/libldb/libldb/libldb-fix-musl-libc-conflict-type-error.patch
new file mode 100644
index 000000000..444fa3ff1
--- /dev/null
+++ b/meta-networking/recipes-support/libldb/libldb/libldb-fix-musl-libc-conflict-type-error.patch
@@ -0,0 +1,45 @@
1From 5bd7b5d04435bd593349825973ce32290f5f604d Mon Sep 17 00:00:00 2001
2From: Changqing Li <changqing.li@windriver.com>
3Date: Wed, 25 Jul 2018 09:55:25 +0800
4Subject: [PATCH] libldb: fix musl libc conflicting types error
5
6/third_party/cmocka/cmocka.h:126:28: error: conflicting types for 'uintptr_t'
7 typedef unsigned int uintptr_t;
8 ^~~~~~~~~
9use __DEFINED_uintptr_t in alltypes.h to check if uintptr already defined
10
11Upstream-Status: Pending
12
13Signed-off-by: Changqing Li <changqing.li@windriver.com>
14---
15 third_party/cmocka/cmocka.h | 7 +++----
16 1 file changed, 3 insertions(+), 4 deletions(-)
17
18diff --git a/third_party/cmocka/cmocka.h b/third_party/cmocka/cmocka.h
19index 4fd82a9..5443a08 100644
20--- a/third_party/cmocka/cmocka.h
21+++ b/third_party/cmocka/cmocka.h
22@@ -110,7 +110,7 @@ typedef uintmax_t LargestIntegralType;
23 ((LargestIntegralType)(value))
24
25 /* Smallest integral type capable of holding a pointer. */
26-#if !defined(_UINTPTR_T) && !defined(_UINTPTR_T_DEFINED)
27+#if !defined(__DEFINED_uintptr_t)
28 # if defined(_WIN32)
29 /* WIN32 is an ILP32 platform */
30 typedef unsigned int uintptr_t;
31@@ -134,9 +134,8 @@ typedef uintmax_t LargestIntegralType;
32 # endif /* __WORDSIZE */
33 # endif /* _WIN32 */
34
35-# define _UINTPTR_T
36-# define _UINTPTR_T_DEFINED
37-#endif /* !defined(_UINTPTR_T) || !defined(_UINTPTR_T_DEFINED) */
38+# define __DEFINED_uintptr_t
39+#endif /* !defined(__DEFINED_uintptr_t)
40
41 /* Perform an unsigned cast to uintptr_t. */
42 #define cast_to_pointer_integral_type(value) \
43--
442.7.4
45
diff --git a/meta-networking/recipes-support/libldb/libldb/libldb-fix-musl-libc-unkown-type-error.patch b/meta-networking/recipes-support/libldb/libldb/libldb-fix-musl-libc-unkown-type-error.patch
new file mode 100644
index 000000000..c0e7e8907
--- /dev/null
+++ b/meta-networking/recipes-support/libldb/libldb/libldb-fix-musl-libc-unkown-type-error.patch
@@ -0,0 +1,31 @@
1From d90534469c5c43bf2a97e5698a5ddb4b7471f92a Mon Sep 17 00:00:00 2001
2From: Changqing Li <changqing.li@windriver.com>
3Date: Tue, 24 Jul 2018 10:53:16 +0800
4Subject: [PATCH] libldb: fix musl libc unkoown type error
5
6tevent.h:1440:8: error: unknown type name 'pid_t'; did you mean 'div_t'?
7 pid_t *pid,
8 ^~~~~
9 div_t
10
11Signed-off-by: Changqing Li <changqing.li@windriver.com>
12---
13 lib/tevent/tevent.h | 2 ++
14 1 file changed, 2 insertions(+)
15
16diff --git a/lib/tevent/tevent.h b/lib/tevent/tevent.h
17index aa6fe0d..2572696 100644
18--- a/lib/tevent/tevent.h
19+++ b/lib/tevent/tevent.h
20@@ -32,6 +32,8 @@
21 #include <talloc.h>
22 #include <sys/time.h>
23 #include <stdbool.h>
24+#include <sys/stat.h>
25+#include <sys/types.h>
26
27 struct tevent_context;
28 struct tevent_ops;
29--
302.7.4
31
diff --git a/meta-networking/recipes-support/libldb/libldb/options-1.3.1.patch b/meta-networking/recipes-support/libldb/libldb/options-1.4.1.patch
index ffe253b63..357afbea5 100644
--- a/meta-networking/recipes-support/libldb/libldb/options-1.3.1.patch
+++ b/meta-networking/recipes-support/libldb/libldb/options-1.4.1.patch
@@ -1,7 +1,7 @@
1From a4da3ab4d76013aaa731d43d52ccca1ebd37c395 Mon Sep 17 00:00:00 2001 1From ffffd29bc6303d60b3d77048fbbf6776f6fbbe01 Mon Sep 17 00:00:00 2001
2From: Jackie Huang <jackie.huang@windriver.com> 2From: Changqing Li <changqing.li@windriver.com>
3Date: Wed, 21 Sep 2016 10:06:39 +0800 3Date: Thu, 19 Jul 2018 16:40:31 +0800
4Subject: [PATCH 1/1] ldb: Add configure options for packages 4Subject: [PATCH] ldb: Add configure options for packages
5 5
6Add configure options for the following packages: 6Add configure options for the following packages:
7 - acl 7 - acl
@@ -14,30 +14,22 @@ Add configure options for the following packages:
14Upstream-Status: Inappropriate [oe deterministic build specific] 14Upstream-Status: Inappropriate [oe deterministic build specific]
15 15
16Signed-off-by: Jackie Huang <jackie.huang@windriver.com> 16Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
17
18Update to version 1.4.1, and fix one configure error
19
20Cross answers file cross-answers-i586.txt is incomplete with
21"Checking for a 64-bit host to support lmdb: UNKNOWN"
22
23we don't support lmdb, so only check when lmdb is support
24
25Signed-off-by: Changqing Li <changqing.li@windriver.com>
17--- 26---
18 lib/replace/system/wscript_configure | 6 ++- 27 lib/replace/wscript | 94 ++++++++++++++++++++++++++++++++++++++++-------------
19 lib/replace/wscript | 94 +++++++++++++++++++++++++++--------- 28 wscript | 6 ++++
20 wscript | 7 +++ 29 2 files changed, 77 insertions(+), 23 deletions(-)
21 3 files changed, 83 insertions(+), 24 deletions(-)
22 30
23diff --git a/lib/replace/system/wscript_configure b/lib/replace/system/wscript_configure
24index 2035474..10f9ae7 100644
25--- a/lib/replace/system/wscript_configure
26+++ b/lib/replace/system/wscript_configure
27@@ -1,6 +1,10 @@
28 #!/usr/bin/env python
29
30-conf.CHECK_HEADERS('sys/capability.h')
31+import Options
32+
33+if Options.options.enable_libcap:
34+ conf.CHECK_HEADERS('sys/capability.h')
35+
36 conf.CHECK_FUNCS('getpwnam_r getpwuid_r getpwent_r')
37
38 # solaris varients of getXXent_r
39diff --git a/lib/replace/wscript b/lib/replace/wscript 31diff --git a/lib/replace/wscript b/lib/replace/wscript
40index 2f94d49..68b2d3a 100644 32index fd00a42..434192e 100644
41--- a/lib/replace/wscript 33--- a/lib/replace/wscript
42+++ b/lib/replace/wscript 34+++ b/lib/replace/wscript
43@@ -23,6 +23,41 @@ def set_options(opt): 35@@ -23,6 +23,41 @@ def set_options(opt):
@@ -113,9 +105,9 @@ index 2f94d49..68b2d3a 100644
113 conf.CHECK_HEADERS('port.h') 105 conf.CHECK_HEADERS('port.h')
114 conf.CHECK_HEADERS('sys/fcntl.h sys/filio.h sys/filsys.h sys/fs/s5param.h sys/fs/vx/quota.h') 106 conf.CHECK_HEADERS('sys/fcntl.h sys/filio.h sys/filsys.h sys/fs/s5param.h sys/fs/vx/quota.h')
115 conf.CHECK_HEADERS('sys/id.h sys/ioctl.h sys/ipc.h sys/mman.h sys/mode.h sys/ndir.h sys/priv.h') 107 conf.CHECK_HEADERS('sys/id.h sys/ioctl.h sys/ipc.h sys/mman.h sys/mode.h sys/ndir.h sys/priv.h')
116@@ -73,7 +121,9 @@ def configure(conf): 108@@ -108,7 +156,9 @@ def configure(conf):
117 109 conf.CHECK_HEADERS('sys/fileio.h sys/filesys.h sys/dustat.h sys/sysmacros.h')
118 conf.CHECK_CODE('', headers='rpc/rpc.h rpcsvc/yp_prot.h', define='HAVE_RPCSVC_YP_PROT_H') 110 conf.CHECK_HEADERS('xfs/libxfs.h netgroup.h')
119 111
120- conf.CHECK_HEADERS('valgrind.h valgrind/valgrind.h valgrind/memcheck.h') 112- conf.CHECK_HEADERS('valgrind.h valgrind/valgrind.h valgrind/memcheck.h')
121+ if Options.options.enable_valgrind: 113+ if Options.options.enable_valgrind:
@@ -124,7 +116,7 @@ index 2f94d49..68b2d3a 100644
124 conf.CHECK_HEADERS('nss_common.h nsswitch.h ns_api.h') 116 conf.CHECK_HEADERS('nss_common.h nsswitch.h ns_api.h')
125 conf.CHECK_HEADERS('sys/extattr.h sys/ea.h sys/proplist.h sys/cdefs.h') 117 conf.CHECK_HEADERS('sys/extattr.h sys/ea.h sys/proplist.h sys/cdefs.h')
126 conf.CHECK_HEADERS('utmp.h utmpx.h lastlog.h') 118 conf.CHECK_HEADERS('utmp.h utmpx.h lastlog.h')
127@@ -266,22 +316,20 @@ def configure(conf): 119@@ -340,22 +390,20 @@ def configure(conf):
128 120
129 conf.CHECK_FUNCS('prctl dirname basename') 121 conf.CHECK_FUNCS('prctl dirname basename')
130 122
@@ -161,7 +153,7 @@ index 2f94d49..68b2d3a 100644
161 153
162 conf.CHECK_CODE(''' 154 conf.CHECK_CODE('''
163 struct ucred cred; 155 struct ucred cred;
164@@ -632,7 +680,7 @@ removeea setea 156@@ -699,7 +747,7 @@ def configure(conf):
165 # look for a method of finding the list of network interfaces 157 # look for a method of finding the list of network interfaces
166 for method in ['HAVE_IFACE_GETIFADDRS', 'HAVE_IFACE_AIX', 'HAVE_IFACE_IFCONF', 'HAVE_IFACE_IFREQ']: 158 for method in ['HAVE_IFACE_GETIFADDRS', 'HAVE_IFACE_AIX', 'HAVE_IFACE_IFCONF', 'HAVE_IFACE_IFREQ']:
167 bsd_for_strlcpy = '' 159 bsd_for_strlcpy = ''
@@ -171,12 +163,12 @@ index 2f94d49..68b2d3a 100644
171 if conf.CHECK_CODE(''' 163 if conf.CHECK_CODE('''
172 #define %s 1 164 #define %s 1
173diff --git a/wscript b/wscript 165diff --git a/wscript b/wscript
174index 8ae5be3..a178cc4 100644 166index ad91bc6..2d20fee 100644
175--- a/wscript 167--- a/wscript
176+++ b/wscript 168+++ b/wscript
177@@ -31,6 +31,13 @@ def set_options(opt): 169@@ -36,6 +36,12 @@ def set_options(opt):
178 opt.RECURSE('lib/replace') 170 help='disable new LMDB backend for LDB',
179 opt.tool_options('python') # options for disabling pyc or pyo compilation 171 action='store_true', dest='without_ldb_lmdb', default=False)
180 172
181+ opt.add_option('--with-valgrind', 173+ opt.add_option('--with-valgrind',
182+ help=("enable use of valgrind"), 174+ help=("enable use of valgrind"),
@@ -184,10 +176,9 @@ index 8ae5be3..a178cc4 100644
184+ opt.add_option('--without-valgrind', 176+ opt.add_option('--without-valgrind',
185+ help=("disable use of valgrind"), 177+ help=("disable use of valgrind"),
186+ action="store_false", dest='enable_valgrind', default=False) 178+ action="store_false", dest='enable_valgrind', default=False)
187+ 179
188 def configure(conf): 180 def configure(conf):
189 conf.RECURSE('lib/tdb') 181 conf.RECURSE('lib/tdb')
190 conf.RECURSE('lib/tevent')
191-- 182--
1922.16.2 1832.7.4
193 184
diff --git a/meta-networking/recipes-support/libldb/libldb_1.3.1.bb b/meta-networking/recipes-support/libldb/libldb_1.4.1.bb
index 7e14cde35..ca152d9e0 100644
--- a/meta-networking/recipes-support/libldb/libldb_1.3.1.bb
+++ b/meta-networking/recipes-support/libldb/libldb_1.4.1.bb
@@ -8,7 +8,10 @@ RDEPENDS_pyldb += "python"
8 8
9SRC_URI = "http://samba.org/ftp/ldb/ldb-${PV}.tar.gz \ 9SRC_URI = "http://samba.org/ftp/ldb/ldb-${PV}.tar.gz \
10 file://do-not-import-target-module-while-cross-compile.patch \ 10 file://do-not-import-target-module-while-cross-compile.patch \
11 file://options-1.3.1.patch \ 11 file://options-1.4.1.patch \
12 file://0001-libldb-fix-config-error.patch \
13 file://libldb-fix-musl-libc-unkown-type-error.patch \
14 file://libldb-fix-musl-libc-conflict-type-error.patch \
12 " 15 "
13 16
14PACKAGECONFIG ??= "\ 17PACKAGECONFIG ??= "\
@@ -29,8 +32,8 @@ LIC_FILES_CHKSUM = "file://pyldb.h;endline=24;md5=dfbd238cecad76957f7f860fbe9ada
29 file://man/ldb.3.xml;beginline=261;endline=262;md5=137f9fd61040c1505d1aa1019663fd08 \ 32 file://man/ldb.3.xml;beginline=261;endline=262;md5=137f9fd61040c1505d1aa1019663fd08 \
30 file://tools/ldbdump.c;endline=19;md5=a7d4fc5d1f75676b49df491575a86a42" 33 file://tools/ldbdump.c;endline=19;md5=a7d4fc5d1f75676b49df491575a86a42"
31 34
32SRC_URI[md5sum] = "e5233f202bca27f6ce8474fb8ae65983" 35SRC_URI[md5sum] = "159a1b1a56dcccf410d1bba911be6076"
33SRC_URI[sha256sum] = "b19f2c9f55ae0f46aa5ebaea0bf1a47ec1ac135e1d78af0f6318cf50bf62cbd2" 36SRC_URI[sha256sum] = "2df13aa25b376b314ce24182c37691959019523de3cc5356c40c1a333b0890a2"
34 37
35inherit waf-samba 38inherit waf-samba
36 39
@@ -43,6 +46,7 @@ EXTRA_OECONF += "--disable-rpath \
43 --with-modulesdir=${libdir}/ldb/modules \ 46 --with-modulesdir=${libdir}/ldb/modules \
44 --with-privatelibdir=${libdir}/ldb \ 47 --with-privatelibdir=${libdir}/ldb \
45 --with-libiconv=${STAGING_DIR_HOST}${prefix}\ 48 --with-libiconv=${STAGING_DIR_HOST}${prefix}\
49 --without-ldb-lmdb \
46 " 50 "
47 51
48PACKAGES =+ "pyldb pyldb-dbg pyldb-dev" 52PACKAGES =+ "pyldb pyldb-dbg pyldb-dev"