summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/wireshark
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2018-02-07 07:29:40 +0530
committerArmin Kuster <akuster808@gmail.com>2018-03-12 10:02:03 -0700
commitadc97095885b962dfdf3c5b917f63818e8feaed4 (patch)
treed1d14d261c3e1e18b2b983cee695cf871b8543c9 /meta-networking/recipes-support/wireshark
parentbe70b5fe1d08d943c663843523cd5c766ec0622a (diff)
downloadmeta-openembedded-adc97095885b962dfdf3c5b917f63818e8feaed4.tar.gz
wireshark: update to new 2.4.5 series
[v2] Fix epan/.libs/libwireshark.so: error: undefined reference to 'gpg_strerror' and update to 2.4.5. includes: wnpa-sec-2018-05 The IEEE 802.11 dissector could crash. Bug 14442, CVE-2018-7335 wnpa-sec-2018-06 Multiple dissectors could go into large infinite loops. All ASN.1 BER dissectors (Bug 14444), along with the DICOM (Bug 14411), DMP (Bug 14408), LLTD (Bug 14419), OpenFlow (Bug 14420), RELOAD (Bug 14445), RPCoRDMA (Bug 14449), RPKI-Router (Bug 14414), S7COMM (Bug 14423), SCCP (Bug 14413), Thread (Bug 14428), Thrift (Bug 14379), USB (Bug 14421), and WCCP (Bug 14412) dissectors were susceptible. wnpa-sec-2018-07 The UMTS MAC dissector could crash. Bug 14339, CVE-2018-7334 wnpa-sec-2018-08 The DOCSIS dissector could crash. Bug 14446, CVE-2018-7337 wnpa-sec-2018-09 The FCP dissector could crash. Bug 14374, CVE-2018-7336 wnpa-sec-2018-10 The SIGCOMP dissector could crash. Bug 14398, CVE-2018-7320 wnpa-sec-2018-11 The pcapng file parser could crash. Bug 14403, CVE-2018-7420 wnpa-sec-2018-12 The IPMI dissector could crash. Bug 14409, CVE-2018-7417 wnpa-sec-2018-13 The SIGCOMP dissector could crash. Bug 14410, CVE-2018-7418 wnpa-sec-2018-14 The NBAP disssector could crash. Bug 14443, CVE-2018-7419 Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support/wireshark')
-rw-r--r--meta-networking/recipes-support/wireshark/files/libgcrypt.patch53
-rw-r--r--meta-networking/recipes-support/wireshark/wireshark_2.4.5.bb (renamed from meta-networking/recipes-support/wireshark/wireshark_2.2.12.bb)26
2 files changed, 66 insertions, 13 deletions
diff --git a/meta-networking/recipes-support/wireshark/files/libgcrypt.patch b/meta-networking/recipes-support/wireshark/files/libgcrypt.patch
new file mode 100644
index 000000000..2aa58f73c
--- /dev/null
+++ b/meta-networking/recipes-support/wireshark/files/libgcrypt.patch
@@ -0,0 +1,53 @@
1use OR PKG_CONFIG scheme for libgcrypt
2
3Upstream-Status: Inappropriate OE specific
4
5Signed-off-by: Armin Kuster <akuster808@gmail.com>
6
7Index: wireshark-2.4.4/m4/libgcrypt.m4
8===================================================================
9--- wireshark-2.4.4.orig/m4/libgcrypt.m4
10+++ wireshark-2.4.4/m4/libgcrypt.m4
11@@ -27,11 +27,11 @@ AC_DEFUN([AM_PATH_LIBGCRYPT],
12 libgcrypt_config_prefix="$withval", libgcrypt_config_prefix="")
13 if test x$libgcrypt_config_prefix != x ; then
14 if test x${LIBGCRYPT_CONFIG+set} != xset ; then
15- LIBGCRYPT_CONFIG=$libgcrypt_config_prefix/bin/libgcrypt-config
16+ LIBGCRYPT_CONFIG=$libgcrypt_config_prefix/libgcrypt.pc
17 fi
18 fi
19
20- AC_PATH_PROG(LIBGCRYPT_CONFIG, libgcrypt-config, no)
21+ AC_PATH_PROG(LIBGCRYPT_CONFIG, libgcrypt.pc, no)
22 tmp=ifelse([$1], ,1:1.2.0,$1)
23 if echo "$tmp" | grep ':' >/dev/null 2>/dev/null ; then
24 req_libgcrypt_api=`echo "$tmp" | sed 's/\(.*\):\(.*\)/\1/'`
25@@ -50,7 +50,7 @@ AC_DEFUN([AM_PATH_LIBGCRYPT],
26 sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\)/\2/'`
27 req_micro=`echo $min_libgcrypt_version | \
28 sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\)/\3/'`
29- libgcrypt_config_version=`$LIBGCRYPT_CONFIG --version`
30+ libgcrypt_config_version=`$PKG_CONFIG --modversion libgcrypt`
31 major=`echo $libgcrypt_config_version | \
32 sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\).*/\1/'`
33 minor=`echo $libgcrypt_config_version | \
34@@ -82,7 +82,7 @@ AC_DEFUN([AM_PATH_LIBGCRYPT],
35 # If we have a recent libgcrypt, we should also check that the
36 # API is compatible
37 if test "$req_libgcrypt_api" -gt 0 ; then
38- tmp=`$LIBGCRYPT_CONFIG --api-version 2>/dev/null || echo 0`
39+ tmp=`$PKG_CONFIG --api-version libgcrypt 2>/dev/null || echo 0`
40 if test "$tmp" -gt 0 ; then
41 AC_MSG_CHECKING([LIBGCRYPT API version])
42 if test "$req_libgcrypt_api" -eq "$tmp" ; then
43@@ -95,8 +95,8 @@ AC_DEFUN([AM_PATH_LIBGCRYPT],
44 fi
45 fi
46 if test $ok = yes; then
47- LIBGCRYPT_CFLAGS=`$LIBGCRYPT_CONFIG --cflags`
48- LIBGCRYPT_LIBS=`$LIBGCRYPT_CONFIG --libs`
49+ LIBGCRYPT_CFLAGS=`$PKG_CONFIG --cflags libgcrypt`
50+ LIBGCRYPT_LIBS=`$PKG_CONFIG --libs libgcrypt`
51 ifelse([$2], , :, [$2])
52 else
53 LIBGCRYPT_CFLAGS=""
diff --git a/meta-networking/recipes-support/wireshark/wireshark_2.2.12.bb b/meta-networking/recipes-support/wireshark/wireshark_2.4.5.bb
index 6c0b644c6..e330b99d7 100644
--- a/meta-networking/recipes-support/wireshark/wireshark_2.2.12.bb
+++ b/meta-networking/recipes-support/wireshark/wireshark_2.4.5.bb
@@ -4,14 +4,15 @@ SECTION = "net"
4LICENSE = "GPL-2.0" 4LICENSE = "GPL-2.0"
5LIC_FILES_CHKSUM = "file://COPYING;md5=6e271234ba1a13c6e512e76b94ac2f77" 5LIC_FILES_CHKSUM = "file://COPYING;md5=6e271234ba1a13c6e512e76b94ac2f77"
6 6
7DEPENDS = "pcre expat glib-2.0 glib-2.0-native" 7DEPENDS = "pcre expat glib-2.0 glib-2.0-native libgcrypt libgpg-error"
8 8
9SRC_URI = "https://2.na.dl.wireshark.org/src/all-versions/${BP}.tar.bz2" 9SRC_URI = "https://1.as.dl.wireshark.org/src/${BP}.tar.xz"
10SRC_URI += "file://libgcrypt.patch"
10 11
11PE = "1" 12SRC_URI[md5sum] = "2b6f1f37c72fa15a0a1863016a0abcc0"
13SRC_URI[sha256sum] = "b3b2ec29fba0f4a3a590438abe4054e56f19108d440fc2d61492db9d8ff16fd7"
12 14
13SRC_URI[md5sum] = "ebf3d4230d7a13408758cdf037c42d66" 15PE = "1"
14SRC_URI[sha256sum] = "3274458d1bb1658a5001465ecb07c7cbfc709571ef36bd062897570d4bab3ebc"
15 16
16inherit autotools pkgconfig perlnative 17inherit autotools pkgconfig perlnative
17 18
@@ -19,10 +20,9 @@ ARM_INSTRUCTION_SET = "arm"
19 20
20PACKAGECONFIG ?= "libpcap gnutls libnl libcap sbc" 21PACKAGECONFIG ?= "libpcap gnutls libnl libcap sbc"
21PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "x11", "gtk2 graphics", "", d)}" 22PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "x11", "gtk2 graphics", "", d)}"
22#PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "opengl", "gtk3", "", d)}"
23 23
24PACKAGECONFIG[libcap] = "--with-libcap=${STAGING_LIBDIR}, --with-libcap=no --enable-pcap-ng-default , libcap" 24PACKAGECONFIG[libcap] = "--with-libcap=${STAGING_DIR_HOST}/usr, --with-libcap=no --enable-pcap-ng-default , libcap"
25PACKAGECONFIG[libpcap] = "--with-pcap=${STAGING_LIBDIR} --with-pcap-remote, --with-pcap=no --enable-pcap-ng-default , libpcap" 25PACKAGECONFIG[libpcap] = "--with-pcap=${STAGING_DIR_HOST}/usr --with-pcap-remote, --with-pcap=no --enable-pcap-ng-default , libpcap"
26PACKAGECONFIG[libsmi] = "--with-libsmi=yes, --with-libsmi=no, libsmi" 26PACKAGECONFIG[libsmi] = "--with-libsmi=yes, --with-libsmi=no, libsmi"
27PACKAGECONFIG[libnl] = "--with-libnl=yes, --with-libnl=no, libnl" 27PACKAGECONFIG[libnl] = "--with-libnl=yes, --with-libnl=no, libnl"
28PACKAGECONFIG[portaudio] = "--with-portaudio=yes, --with-portaudio=no, portaudio-v19" 28PACKAGECONFIG[portaudio] = "--with-portaudio=yes, --with-portaudio=no, portaudio-v19"
@@ -30,7 +30,6 @@ PACKAGECONFIG[gtk2] = "--with-gtk=2, , gtk+"
30PACKAGECONFIG[gtk3] = "--with-gtk=3, , gtk+3" 30PACKAGECONFIG[gtk3] = "--with-gtk=3, , gtk+3"
31PACKAGECONFIG[graphics] = "--enable-wireshark, --with-gtk=no --disable-wireshark," 31PACKAGECONFIG[graphics] = "--enable-wireshark, --with-gtk=no --disable-wireshark,"
32PACKAGECONFIG[gnutls] = "--with-gnutls=yes, --with-gnutls=no, gnutls" 32PACKAGECONFIG[gnutls] = "--with-gnutls=yes, --with-gnutls=no, gnutls"
33PACKAGECONFIG[gcrypt] = "--with-gcrypt=yes, --with-gcrypt=no, libgcrypt"
34PACKAGECONFIG[ssl] = "--with-ssl=yes, --with-ssl=no, openssl" 33PACKAGECONFIG[ssl] = "--with-ssl=yes, --with-ssl=no, openssl"
35PACKAGECONFIG[krb5] = "--with-krb5=yes, --with-krb5=no, krb5" 34PACKAGECONFIG[krb5] = "--with-krb5=yes, --with-krb5=no, krb5"
36PACKAGECONFIG[lua] = "--with-lua=yes, --with-lua=no, lua" 35PACKAGECONFIG[lua] = "--with-lua=yes, --with-lua=no, lua"
@@ -38,14 +37,15 @@ PACKAGECONFIG[zlib] = "--with-zlib=yes, --with-zlib=no, zlib"
38PACKAGECONFIG[geoip] = "--with-geoip=yes, --with-geoip=no, geoip" 37PACKAGECONFIG[geoip] = "--with-geoip=yes, --with-geoip=no, geoip"
39PACKAGECONFIG[plugins] = "--with-plugins=yes, --with-plugins=no" 38PACKAGECONFIG[plugins] = "--with-plugins=yes, --with-plugins=no"
40PACKAGECONFIG[sbc] = "--with-sbc=yes, --with-sbc=no, sbc" 39PACKAGECONFIG[sbc] = "--with-sbc=yes, --with-sbc=no, sbc"
41 40PACKAGECONFIG[libssh] = "--with-libssh=${STAGING_DIR_HOST}/usr, --with-libssh=no, libssh2"
42PACKAGECONFIG[libssh] = "--with-libssh=${STAGING_LIBDIR}, --with-libssh=no, libssh2" 41PACKAGECONFIG[lz4] = "--with-lz4=${STAGING_DIR_HOST}/usr, --with-lz4=no, lz4"
43
44 42
45# these next two options require addional layers 43# these next two options require addional layers
46PACKAGECONFIG[c-ares] = "--with-c-ares=yes, --with-c-ares=no, c-ares" 44PACKAGECONFIG[c-ares] = "--with-c-ares=yes, --with-c-ares=no, c-ares"
47 45
48EXTRA_OECONF += "--with-qt=no --enable-tshark --enable-rawshark" 46EXTRA_OECONF += "--with-libgcrypt-prefix=${PKG_CONFIG_DIR} --with-qt=no --enable-tshark --enable-rawshark"
47
48LDFLAGS_append = " -lgpg-error"
49 49
50# Currently wireshark does not install header files 50# Currently wireshark does not install header files
51do_install_append () { 51do_install_append () {