diff options
author | Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> | 2019-10-31 04:56:27 +0800 |
---|---|---|
committer | Armin Kuster <akuster808@gmail.com> | 2019-11-24 12:28:29 -0800 |
commit | fdfa4cde192952ca7a63eb058d691e86a8e163fa (patch) | |
tree | 46ccc7922e5f2048dd47988856d2131fa4211ccb /meta-networking/recipes-support/wireshark/wireshark_3.0.6.bb | |
parent | ee5aa6911b2e93b89e67ae6167ee7d9a029b9262 (diff) | |
download | meta-openembedded-fdfa4cde192952ca7a63eb058d691e86a8e163fa.tar.gz |
wireshark: upgrade 3.0.3 -> 3.0.6
Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
[Bug fix only update
includes:
CVE-2019-16319
]
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support/wireshark/wireshark_3.0.6.bb')
-rw-r--r-- | meta-networking/recipes-support/wireshark/wireshark_3.0.6.bb | 81 |
1 files changed, 81 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/wireshark/wireshark_3.0.6.bb b/meta-networking/recipes-support/wireshark/wireshark_3.0.6.bb new file mode 100644 index 000000000..ccaa0c94a --- /dev/null +++ b/meta-networking/recipes-support/wireshark/wireshark_3.0.6.bb | |||
@@ -0,0 +1,81 @@ | |||
1 | DESCRIPTION = "wireshark - a popular network protocol analyzer" | ||
2 | HOMEPAGE = "http://www.wireshark.org" | ||
3 | SECTION = "net" | ||
4 | LICENSE = "GPL-2.0" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=6e271234ba1a13c6e512e76b94ac2f77" | ||
6 | |||
7 | DEPENDS = "pcre expat glib-2.0 glib-2.0-native libgcrypt libgpg-error libxml2 bison-native" | ||
8 | |||
9 | DEPENDS_append_class-target = " wireshark-native chrpath-replacement-native " | ||
10 | |||
11 | SRC_URI = "https://1.eu.dl.wireshark.org/src/all-versions/wireshark-${PV}.tar.xz" | ||
12 | |||
13 | UPSTREAM_CHECK_URI = "https://1.as.dl.wireshark.org/src" | ||
14 | |||
15 | SRC_URI[md5sum] = "c6f8d12a3efe21cc7885f7cb0c4bd938" | ||
16 | SRC_URI[sha256sum] = "a87f4022a0c15ddbf1730bf1acafce9e75a4e657ce9fa494ceda0324c0c3e33e" | ||
17 | |||
18 | PE = "1" | ||
19 | |||
20 | inherit cmake pkgconfig python3native perlnative upstream-version-is-even | ||
21 | |||
22 | PACKAGECONFIG ?= "libpcap gnutls libnl libcap sbc ${@bb.utils.contains('BBFILE_COLLECTIONS', 'qt5-layer', 'qt5', '', d)}" | ||
23 | |||
24 | PACKAGECONFIG_class-native = "libpcap gnutls ssl libssh" | ||
25 | |||
26 | PACKAGECONFIG[libcap] = "-DENABLE_CAP=ON,-DENABLE_CAP=OFF -DENABLE_PCAP_NG_DEFAULT=ON, libcap" | ||
27 | PACKAGECONFIG[libpcap] = "-DENABLE_PCAP=ON,-DENABLE_PCAP=OFF -DENABLE_PCAP_NG_DEFAULT=ON , libpcap" | ||
28 | PACKAGECONFIG[libsmi] = "-DENABLE_SMI=ON,-DENABLE_SMI=OFF,libsmi" | ||
29 | PACKAGECONFIG[libnl] = ",,libnl" | ||
30 | PACKAGECONFIG[portaudio] = "-DENABLE_PORTAUDIO=ON,-DENABLE_PORTAUDIO=OFF, portaudio-v19" | ||
31 | PACKAGECONFIG[gnutls] = "-DENABLE_GNUTLS=ON,-DENABLE_GNUTLS=OFF, gnutls" | ||
32 | PACKAGECONFIG[ssl] = ",,openssl" | ||
33 | PACKAGECONFIG[krb5] = "-DENABLE_KRB5=ON,-DENABLE_KRB5=OFF, krb5" | ||
34 | PACKAGECONFIG[lua] = "-DENABLE_LUA=ON,-DENABLE_LUA=OFF, lua" | ||
35 | PACKAGECONFIG[zlib] = "-DENABLE_ZLIB=ON,-DENABLE_ZLIB=OFF, zlib" | ||
36 | PACKAGECONFIG[geoip] = ",, geoip" | ||
37 | PACKAGECONFIG[plugins] = "-DENABLE_PLUGINS=ON,-DENABLE_PLUGINS=OFF" | ||
38 | PACKAGECONFIG[sbc] = "-DENABLE_SBC=ON,-DENABLE_SBC=OFF, sbc" | ||
39 | PACKAGECONFIG[libssh] = ",,libssh2" | ||
40 | PACKAGECONFIG[lz4] = "-DENABLE_LZ4=ON,-DENABLE_LZ4=OFF, lz4" | ||
41 | |||
42 | # these next two options require addional layers | ||
43 | PACKAGECONFIG[c-ares] = "-DENABLE_CARES=ON,-DENABLE_CARES=OFF, c-ares" | ||
44 | PACKAGECONFIG[qt5] = "-DENABLE_QT5=ON -DBUILD_wireshark=ON, -DENABLE_QT5=OFF -DBUILD_wireshark=OFF, qttools-native qtmultimedia qtsvg" | ||
45 | |||
46 | inherit ${@bb.utils.contains('PACKAGECONFIG', 'qt5', 'cmake_qt5', '', d)} | ||
47 | |||
48 | EXTRA_OECMAKE += "-DENABLE_NETLINK=ON \ | ||
49 | -DBUILD_mmdbresolve=OFF \ | ||
50 | -DBUILD_randpktdump=OFF \ | ||
51 | -DBUILD_androiddump=OFF \ | ||
52 | -DBUILD_dcerpcidl2wrs=OFF \ | ||
53 | -DM_INCLUDE_DIR=${includedir} \ | ||
54 | -DM_LIBRARY=${libdir} \ | ||
55 | " | ||
56 | CFLAGS_append = " -lm" | ||
57 | |||
58 | do_install_append_class-native() { | ||
59 | install -d ${D}${bindir} | ||
60 | for f in lemon | ||
61 | do | ||
62 | install -m 0755 ${B}/run/$f ${D}${bindir} | ||
63 | done | ||
64 | } | ||
65 | |||
66 | do_install_append_class-target() { | ||
67 | for f in `find ${D}${libdir} ${D}${bindir} -type f -executable` | ||
68 | do | ||
69 | chrpath --delete $f | ||
70 | done | ||
71 | } | ||
72 | |||
73 | PACKAGE_BEFORE_PN += "tshark" | ||
74 | |||
75 | FILES_tshark = "${bindir}/tshark ${mandir}/man1/tshark.*" | ||
76 | |||
77 | FILES_${PN} += "${datadir}*" | ||
78 | |||
79 | RDEPENDS_tshark = "wireshark" | ||
80 | |||
81 | BBCLASSEXTEND = "native" | ||