summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/wireshark/wireshark_2.2.11.bb
diff options
context:
space:
mode:
authorArmin Kuster <akuster@mvista.com>2017-12-19 07:38:46 -0800
committerArmin Kuster <akuster808@gmail.com>2018-02-09 10:49:04 +0530
commita370c771887107f424c723c0fcb3c246ffe022a4 (patch)
tree5b91c27be48c3730d20aae9b7c0612543e9a045c /meta-networking/recipes-support/wireshark/wireshark_2.2.11.bb
parentd8ce5a7195f1210912c698a135492df1e073447e (diff)
downloadmeta-openembedded-a370c771887107f424c723c0fcb3c246ffe022a4.tar.gz
wireshark: Update to 2.2.11
changed --with-ssh to --with-libssh=DIR includes: wnpa-sec-2017-47 : CVE-2017-17084 The IWARP_MPA dissector could crash. (Bug 14236) wnpa-sec-2017-48 : CVE-2017-17083 The NetBIOS dissector could crash. (Bug 14249) wnpa-sec-2017-49 : CVE-2017-17085 The CIP Safety dissector could crash. (Bug 14250) release notes: https://www.wireshark.org/docs/relnotes/wireshark-2.2.11.html Signed-off-by: Armin Kuster <akuster@mvista.com> Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support/wireshark/wireshark_2.2.11.bb')
-rw-r--r--meta-networking/recipes-support/wireshark/wireshark_2.2.11.bb71
1 files changed, 71 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/wireshark/wireshark_2.2.11.bb b/meta-networking/recipes-support/wireshark/wireshark_2.2.11.bb
new file mode 100644
index 000000000..5eb372e37
--- /dev/null
+++ b/meta-networking/recipes-support/wireshark/wireshark_2.2.11.bb
@@ -0,0 +1,71 @@
1DESCRIPTION = "wireshark - a popular network protocol analyzer"
2HOMEPAGE = "http://www.wireshark.org"
3SECTION = "net"
4LICENSE = "GPL-2.0"
5LIC_FILES_CHKSUM = "file://COPYING;md5=6e271234ba1a13c6e512e76b94ac2f77"
6
7DEPENDS = "pcre expat glib-2.0 glib-2.0-native"
8
9SRC_URI = "https://2.na.dl.wireshark.org/src/all-versions/${BP}.tar.bz2"
10
11PE = "1"
12
13SRC_URI[md5sum] = "a79ba6cda83be2a91bde4110fe194788"
14SRC_URI[sha256sum] = "a9f11621e85d7e1d72259157edd94825e72af3fd72e184b8474459f92ad5fc40"
15
16inherit autotools pkgconfig perlnative
17
18ARM_INSTRUCTION_SET = "arm"
19
20PACKAGECONFIG ?= "libpcap gnutls libnl libcap sbc"
21PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "x11", "gtk2 graphics", "", d)}"
22#PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "opengl", "gtk3", "", d)}"
23
24PACKAGECONFIG[libcap] = "--with-libcap=${STAGING_LIBDIR}, --with-libcap=no --enable-pcap-ng-default , libcap"
25PACKAGECONFIG[libpcap] = "--with-pcap=${STAGING_LIBDIR} --with-pcap-remote, --with-pcap=no --enable-pcap-ng-default , libpcap"
26PACKAGECONFIG[libsmi] = "--with-libsmi=yes, --with-libsmi=no, libsmi"
27PACKAGECONFIG[libnl] = "--with-libnl=yes, --with-libnl=no, libnl"
28PACKAGECONFIG[portaudio] = "--with-portaudio=yes, --with-portaudio=no, portaudio-v19"
29PACKAGECONFIG[gtk2] = "--with-gtk=2, , gtk+"
30PACKAGECONFIG[gtk3] = "--with-gtk=3, , gtk+3"
31PACKAGECONFIG[graphics] = "--enable-wireshark, --with-gtk=no --disable-wireshark,"
32PACKAGECONFIG[gnutls] = "--with-gnutls=yes, --with-gnutls=no, gnutls"
33PACKAGECONFIG[gcrypt] = "--with-gcrypt=yes, --with-gcrypt=no, libgcrypt"
34PACKAGECONFIG[ssl] = "--with-ssl=yes, --with-ssl=no, openssl"
35PACKAGECONFIG[krb5] = "--with-krb5=yes, --with-krb5=no, krb5"
36PACKAGECONFIG[lua] = "--with-lua=yes, --with-lua=no, lua"
37PACKAGECONFIG[zlib] = "--with-zlib=yes, --with-zlib=no, zlib"
38PACKAGECONFIG[geoip] = "--with-geoip=yes, --with-geoip=no, geoip"
39PACKAGECONFIG[plugins] = "--with-plugins=yes, --with-plugins=no"
40PACKAGECONFIG[sbc] = "--with-sbc=yes, --with-sbc=no, sbc"
41
42PACKAGECONFIG[libssh] = "--with-libssh=${STAGING_LIBDIR}, --with-libssh=no, libssh2"
43
44
45# these next two options require addional layers
46PACKAGECONFIG[c-ares] = "--with-c-ares=yes, --with-c-ares=no, c-ares"
47
48EXTRA_OECONF += "--with-qt=no --enable-tshark --enable-rawshark"
49
50# Currently wireshark does not install header files
51do_install_append () {
52
53 install -d ${D}/${includedir}/${BPN}
54 install -d ${D}/${includedir}/${BPN}/epan
55 install -d ${D}/${includedir}/${BPN}/epan/crypt
56 install -d ${D}/${includedir}/${BPN}/epan/dfilter
57 install -d ${D}/${includedir}/${BPN}/epan/dissectors
58 install -d ${D}/${includedir}/${BPN}/epan/ftypes
59 install -d ${D}/${includedir}/${BPN}/epan/wmem
60
61 install config.h ${D}/${includedir}/${BPN}
62 install ${S}/register.h ${D}/${includedir}/${BPN}
63 install -D ${S}/epan/*.h ${D}/${includedir}/${BPN}/epan
64 install -D ${S}/epan/crypt/*.h ${D}/${includedir}/${BPN}/epan/crypt
65 install -D ${S}/epan/dfilter/*.h ${D}/${includedir}/${BPN}/epan/dfilter
66 install -D ${S}/epan/dissectors/*.h ${D}/${includedir}/${BPN}/epan/dissectors
67 install -D ${S}/epan/ftypes/*.h ${D}/${includedir}/${BPN}/epan/ftypes
68 install -D ${S}/epan/wmem/*.h ${D}/${includedir}/${BPN}/epan/wmem
69}
70
71FILES_${PN} += "${datadir}*"