summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/wireshark/wireshark_2.0.4.bb
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2016-06-08 00:44:48 -0700
committerArmin Kuster <akuster808@gmail.com>2016-08-16 10:29:40 -0700
commit049ba0b0b2c85c442c4f394113b018346e5aa9a2 (patch)
tree32bb6a45338a80347f9312ab266ac6df7a7f1c2b /meta-networking/recipes-support/wireshark/wireshark_2.0.4.bb
parent5194d3590b031bb055a260e2418cdc2f684b20fa (diff)
downloadmeta-openembedded-049ba0b0b2c85c442c4f394113b018346e5aa9a2.tar.gz
wireshark: update to 2.0.4
The following vulnerabilities have been fixed: * [1]wnpa-sec-2016-29 The SPOOLS dissector could go into an infinite loop. Discovered by the CESG. * [2]wnpa-sec-2016-30 The IEEE 802.11 dissector could crash. ([3]Bug 11585) * [4]wnpa-sec-2016-31 The IEEE 802.11 dissector could crash. Discovered by Mateusz Jurczyk. ([5]Bug 12175) * [6]wnpa-sec-2016-32 The UMTS FP dissector could crash. ([7]Bug 12191) * [8]wnpa-sec-2016-33 Some USB dissectors could crash. Discovered by Mateusz Jurczyk. ([9]Bug 12356) * [10]wnpa-sec-2016-34 The Toshiba file parser could crash. Discovered by iDefense Labs. ([11]Bug 12394) * [12]wnpa-sec-2016-35 The CoSine file parser could crash. Discovered by iDefense Labs. ([13]Bug 12395) * [14]wnpa-sec-2016-36 The NetScreen file parser could crash. Discovered by iDefense Labs. ([15]Bug 12396) * [16]wnpa-sec-2016-37 The Ethernet dissector could crash. ([17]Bug 12440) Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com> (cherry picked from commit f316c4a32686e57c4b65e659fbf7d7936ac39ff6) Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support/wireshark/wireshark_2.0.4.bb')
-rw-r--r--meta-networking/recipes-support/wireshark/wireshark_2.0.4.bb60
1 files changed, 60 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/wireshark/wireshark_2.0.4.bb b/meta-networking/recipes-support/wireshark/wireshark_2.0.4.bb
new file mode 100644
index 000000000..8aec230ed
--- /dev/null
+++ b/meta-networking/recipes-support/wireshark/wireshark_2.0.4.bb
@@ -0,0 +1,60 @@
1DESCRIPTION = "wireshark - a popular network protocol analyzer"
2HOMEPAGE = "http://www.wireshark.org"
3SECTION = "net"
4LICENSE = "GPL-2.0"
5LIC_FILES_CHKSUM = "file://README.linux;md5=631e077455b7972172eb149195e065b0"
6
7DEPENDS = "perl-native pcre expat glib-2.0 sbc"
8
9SRC_URI = "https://2.na.dl.wireshark.org/src/all-versions/${BP}.tar.bz2"
10
11SRC_URI[md5sum] = "622928dc6cb31c227c672ec3ec697f28"
12SRC_URI[sha256sum] = "9ea9c82da9942194ebc8fc5c951a02e6d179afa7472cb6d96ca76154510de1a5"
13
14PE = "1"
15
16inherit autotools pkgconfig
17
18ARM_INSTRUCTION_SET = "arm"
19
20# Works with either gtk+ or gtk3.
21WHICH_GTK = "gtk+"
22
23PACKAGECONFIG ?= "libpcap gnutls libnl libcap"
24PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "x11", "gtk2 graphics", "", d)}"
25PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "ipv6", "ipv6", "", d)}"
26#PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "opengl", "gtk3", "", d)}"
27
28PACKAGECONFIG[libcap] = "--with-libcap=${STAGING_LIBDIR}, --with-libcap=no --enable-pcap-ng-default , libcap"
29PACKAGECONFIG[libpcap] = "--with-pcap=${STAGING_LIBDIR} --with-pcap-remote, --with-pcap=no --enable-pcap-ng-default , libpcap"
30PACKAGECONFIG[libsmi] = "--with-libsmi=yes, --with-libsmi=no, libsmi"
31PACKAGECONFIG[libnl] = "--with-libnl=yes, --with-libnl=no, libnl"
32PACKAGECONFIG[portaudio] = "--with-portaudio=yes, --with-portaudio=no, portaudio-v19"
33PACKAGECONFIG[gtk2] = "--with-gtk2=yes, --with-gtk2=no, gtk+"
34PACKAGECONFIG[gtk3] = "--with-gtk3=yes, --with-gtk3=no, gtk+3"
35PACKAGECONFIG[graphics] = "--enable-wireshark, --disable-wireshark,"
36PACKAGECONFIG[ipv6] = "--enable-ipv6, --disable-ipv6,"
37PACKAGECONFIG[gnutls] = "--with-gnutls=yes, --with-gnutls=no, gnutls"
38PACKAGECONFIG[gcrypt] = "--with-gcrypt=yes, --with-gcrypt=no, libgcrypt"
39PACKAGECONFIG[ssl] = "--with-ssl=yes, --with-ssl=no, openssl"
40PACKAGECONFIG[krb5] = "--with-krb5=yes, --with-krb5=no, krb5"
41PACKAGECONFIG[lua] = "--with-lua=yes, --with-lua=no, lua"
42PACKAGECONFIG[zlib] = "--with-zlib=yes, --with-zlib=no, zlib"
43PACKAGECONFIG[geoip] = "--with-geoip=yes, --with-geoip=no, geoip"
44PACKAGECONFIG[plugins] = "--with-plugins=yes, --with-plugins=no"
45
46# these next two options require addional layers
47PACKAGECONFIG[adns] = "--with-adns=yes, --with-adns=no, adns"
48PACKAGECONFIG[c-ares] = "--with-c-ares=yes, --with-c-ares=no, c-ares"
49
50EXTRA_OECONF += "--with-qt=no --enable-usr-local=no --enable-tshark --enable-rawshark"
51
52do_configure_prepend() {
53 # force to use fallback
54 sed -i -e '/^glib_prefix/s/=.*$/=""/' ${S}/aclocal-flags
55}
56
57ALLOW_EMPTY_${PN} = "1"
58INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
59
60FILES_${PN} += "${datadir}*"