summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/wireshark/wireshark/fix-fatal-no-names-found-git-error.patch
diff options
context:
space:
mode:
authorManjukumar Matha <manjukumar.harthikote-matha@xilinx.com>2018-08-09 15:37:36 -0700
committerKhem Raj <raj.khem@gmail.com>2018-08-11 15:00:23 -0700
commit661df548dddf723cdf055a4f76f4aa2c93f3774c (patch)
treecc251e551a76833503c16684d2f26aa0b8a72396 /meta-networking/recipes-support/wireshark/wireshark/fix-fatal-no-names-found-git-error.patch
parent98382d5c77900b504360e48ebdf4a4ef0082b9e1 (diff)
downloadmeta-openembedded-661df548dddf723cdf055a4f76f4aa2c93f3774c.tar.gz
wireshark_2.6.2.bb: Fix the configure error on git describe
This patch fixes the following error during do_configure task | fatal: No names found, cannot describe anything. | CMake Error at CMakeLists.txt:3086 (string): | string begin index: 1 is out of range 0 - 0 | Using --always is a fallback for fetching uniquely abbreviated commit object Signed-off-by: Manjukumar Matha <manjukumar.harthikote-matha@xilinx.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support/wireshark/wireshark/fix-fatal-no-names-found-git-error.patch')
-rw-r--r--meta-networking/recipes-support/wireshark/wireshark/fix-fatal-no-names-found-git-error.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/wireshark/wireshark/fix-fatal-no-names-found-git-error.patch b/meta-networking/recipes-support/wireshark/wireshark/fix-fatal-no-names-found-git-error.patch
new file mode 100644
index 000000000..80119e3fd
--- /dev/null
+++ b/meta-networking/recipes-support/wireshark/wireshark/fix-fatal-no-names-found-git-error.patch
@@ -0,0 +1,23 @@
1fixes
2
3| fatal: No names found, cannot describe anything.
4| CMake Error at CMakeLists.txt:3086 (string):
5| string begin index: 1 is out of range 0 - 0
6
7Use always to circumvent the issue if git tag is not present
8
9Upstream-status: Pending
10
11Signed-off-by: Manjukumar Matha <manjukumar.harthikote-matha@xilinx.com>
12---
13--- wireshark-2.6.1/CMakeLists.txt 2018-08-08 18:18:05.388318652 -0700
14+++ wireshark-2.6.1/CMakeLists-fix.txt 2018-08-08 18:22:27.829670496 -0700
15@@ -3078,7 +3078,7 @@
16 endif()
17
18 execute_process(
19- COMMAND git describe --abbrev=8 --match v[1-9]*
20+ COMMAND git describe --always --abbrev=8 --match v[1-9]*
21 OUTPUT_VARIABLE _git_description
22 OUTPUT_STRIP_TRAILING_WHITESPACE
23 WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}