summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/traceroute/traceroute_2.1.0.bb
diff options
context:
space:
mode:
authorWenzong Fan <wenzong.fan@windriver.com>2016-09-08 21:47:30 -0400
committerJoe MacDonald <joe_macdonald@mentor.com>2016-09-12 10:43:38 -0400
commit554bbfb7352d61397e95cbad3c4a963ca0ad2aba (patch)
tree9397a56bc5fcb38b7ebdec6f5bcdb73aeec07e8c /meta-networking/recipes-support/traceroute/traceroute_2.1.0.bb
parent467dc1f3b5d1c483724fa659a9d616f29ab9615c (diff)
downloadmeta-openembedded-554bbfb7352d61397e95cbad3c4a963ca0ad2aba.tar.gz
traceroute: update to 2.1.0
Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-support/traceroute/traceroute_2.1.0.bb')
-rw-r--r--meta-networking/recipes-support/traceroute/traceroute_2.1.0.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/traceroute/traceroute_2.1.0.bb b/meta-networking/recipes-support/traceroute/traceroute_2.1.0.bb
new file mode 100644
index 000000000..48a0c1279
--- /dev/null
+++ b/meta-networking/recipes-support/traceroute/traceroute_2.1.0.bb
@@ -0,0 +1,45 @@
1SUMMARY = "A new modern implementation of traceroute(8) utility for Linux systems"
2DESCRIPTION = "The traceroute utility displays the route used by IP packets on \
3their way to a specified network (or Internet) host. Traceroute displays \
4the IP number and host name (if possible) of the machines along the \
5route taken by the packets. Traceroute is used as a network debugging \
6tool. If you're having network connectivity problems, traceroute will \
7show you where the trouble is coming from along the route."
8SECTION = "net"
9HOMEPAGE = "http://traceroute.sourceforge.net/"
10LICENSE = "GPL-2.0+ & LGPL-2.1+"
11LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
12 file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
13
14inherit update-alternatives
15
16SRC_URI = "${SOURCEFORGE_MIRROR}/traceroute/traceroute/${BP}/${BP}.tar.gz \
17 file://filter-out-the-patches-from-subdirs.patch \
18"
19
20SRC_URI[md5sum] = "84d329d67abc3fb83fc8cb12aeaddaba"
21SRC_URI[sha256sum] = "3669d22a34d3f38ed50caba18cd525ba55c5c00d5465f2d20d7472e5d81603b6"
22
23EXTRA_OEMAKE = "VPATH=${STAGING_LIBDIR}"
24
25do_compile() {
26 export LDFLAGS="${TARGET_LDFLAGS} -L${S}/libsupp"
27 oe_runmake "env=yes"
28}
29
30do_install() {
31 install -d ${D}${bindir}
32 install -m755 ${BPN}/${BPN} ${D}${bindir}
33
34 install -m755 wrappers/tcptraceroute ${D}${bindir}
35
36 install -d ${D}${mandir}
37 install -p -m644 ${BPN}/${BPN}.8 ${D}${mandir}
38 ln -s ${BPN}.8 ${D}${mandir}/${BPN}6.8
39 ln -s ${BPN}.8 ${D}${mandir}/tcptraceroute.8
40
41}
42
43ALTERNATIVE_PRIORITY = "60"
44ALTERNATIVE_${PN} = "traceroute"
45ALTERNATIVE_LINK_NAME[traceroute] = "${bindir}/traceroute"