diff options
author | Huang Qiyu <huangqy.fnst@cn.fujitsu.com> | 2018-03-21 11:36:07 +0800 |
---|---|---|
committer | Joe MacDonald <joe_macdonald@mentor.com> | 2018-04-09 12:32:07 -0400 |
commit | fd77663ea91f12b771bb7754265f05c3e9301426 (patch) | |
tree | 5790cf99e0f7b5c9c0a69f2f20b97e47ede21492 /meta-networking/recipes-support/strongswan | |
parent | 4e15ee38556656502b9f7fee335a5b678d700390 (diff) | |
download | meta-openembedded-fd77663ea91f12b771bb7754265f05c3e9301426.tar.gz |
strongswan: 5.5.3 -> 5.6.2
1.Upgrade strongswan from 5.5.3 to 5.6.2.
2.Modify fix-funtion-parameter.patch, since the data has been changed.
Signed-off-by: Huang Qiyu <huangqy.fnst@cn.fujitsu.com>
Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-support/strongswan')
-rw-r--r-- | meta-networking/recipes-support/strongswan/files/fix-funtion-parameter.patch | 6 | ||||
-rw-r--r-- | meta-networking/recipes-support/strongswan/strongswan_5.6.2.bb (renamed from meta-networking/recipes-support/strongswan/strongswan_5.5.3.bb) | 4 |
2 files changed, 5 insertions, 5 deletions
diff --git a/meta-networking/recipes-support/strongswan/files/fix-funtion-parameter.patch b/meta-networking/recipes-support/strongswan/files/fix-funtion-parameter.patch index da96983e6d..846e0c6936 100644 --- a/meta-networking/recipes-support/strongswan/files/fix-funtion-parameter.patch +++ b/meta-networking/recipes-support/strongswan/files/fix-funtion-parameter.patch | |||
@@ -50,7 +50,7 @@ index ff33824..bd21446 100644 | |||
50 | */ | 50 | */ |
51 | -openssl_diffie_hellman_t *openssl_diffie_hellman_create( | 51 | -openssl_diffie_hellman_t *openssl_diffie_hellman_create( |
52 | +openssl_diffie_hellman_t *openssl_diffie_hellman_create_custom( | 52 | +openssl_diffie_hellman_t *openssl_diffie_hellman_create_custom( |
53 | diffie_hellman_group_t group, chunk_t g, chunk_t p) | 53 | diffie_hellman_group_t group, ...) |
54 | { | 54 | { |
55 | private_openssl_diffie_hellman_t *this; | 55 | private_openssl_diffie_hellman_t *this; |
56 | @@ -197,5 +197,11 @@ openssl_diffie_hellman_t *openssl_diffie_hellman_create( | 56 | @@ -197,5 +197,11 @@ openssl_diffie_hellman_t *openssl_diffie_hellman_create( |
@@ -70,12 +70,12 @@ index 53dc59c..eb69eaa 100644 | |||
70 | --- a/src/libstrongswan/plugins/openssl/openssl_diffie_hellman.h | 70 | --- a/src/libstrongswan/plugins/openssl/openssl_diffie_hellman.h |
71 | +++ b/src/libstrongswan/plugins/openssl/openssl_diffie_hellman.h | 71 | +++ b/src/libstrongswan/plugins/openssl/openssl_diffie_hellman.h |
72 | @@ -44,8 +44,10 @@ struct openssl_diffie_hellman_t { | 72 | @@ -44,8 +44,10 @@ struct openssl_diffie_hellman_t { |
73 | * @param p custom prime, if MODP_CUSTOM | 73 | * @param ... expects generator and prime as chunk_t if MODP_CUSTOM |
74 | * @return openssl_diffie_hellman_t object, NULL if not supported | 74 | * @return openssl_diffie_hellman_t object, NULL if not supported |
75 | */ | 75 | */ |
76 | -openssl_diffie_hellman_t *openssl_diffie_hellman_create( | 76 | -openssl_diffie_hellman_t *openssl_diffie_hellman_create( |
77 | +openssl_diffie_hellman_t *openssl_diffie_hellman_create_custom( | 77 | +openssl_diffie_hellman_t *openssl_diffie_hellman_create_custom( |
78 | diffie_hellman_group_t group, chunk_t g, chunk_t p); | 78 | diffie_hellman_group_t group, ...); |
79 | +openssl_diffie_hellman_t *openssl_diffie_hellman_create( | 79 | +openssl_diffie_hellman_t *openssl_diffie_hellman_create( |
80 | + diffie_hellman_group_t group); | 80 | + diffie_hellman_group_t group); |
81 | 81 | ||
diff --git a/meta-networking/recipes-support/strongswan/strongswan_5.5.3.bb b/meta-networking/recipes-support/strongswan/strongswan_5.6.2.bb index 97ebcd8a57..f2fe1f1cbc 100644 --- a/meta-networking/recipes-support/strongswan/strongswan_5.5.3.bb +++ b/meta-networking/recipes-support/strongswan/strongswan_5.6.2.bb | |||
@@ -12,8 +12,8 @@ SRC_URI = "http://download.strongswan.org/strongswan-${PV}.tar.bz2 \ | |||
12 | file://0001-memory.h-Include-stdint.h-for-uintptr_t.patch \ | 12 | file://0001-memory.h-Include-stdint.h-for-uintptr_t.patch \ |
13 | " | 13 | " |
14 | 14 | ||
15 | SRC_URI[md5sum] = "4afffe3c219bb2e04f09510905af836b" | 15 | SRC_URI[md5sum] = "46aa3aa18fbc4bd528f9a0345ce79913" |
16 | SRC_URI[sha256sum] = "c5ea54b199174708de11af9b8f4ecf28b5b0743d4bc0e380e741f25b28c0f8d4" | 16 | SRC_URI[sha256sum] = "e0a60a30ebf3c534c223559e1686497a21ded709a5d605c5123c2f52bcc22e92" |
17 | 17 | ||
18 | EXTRA_OECONF = " \ | 18 | EXTRA_OECONF = " \ |
19 | --without-lib-prefix \ | 19 | --without-lib-prefix \ |