summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/strongswan
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2013-04-15 19:06:25 +0100
committerJoe MacDonald <joe.macdonald@windriver.com>2013-04-29 14:02:39 -0400
commite6867fa02618c29a4469342bd3323f51445f9875 (patch)
tree1383b294100f0d26040d49bea3fb7e5ecc9bc6a3 /meta-networking/recipes-support/strongswan
parent36d5c2f3736bc1121f700fd11130bd4675afba0a (diff)
downloadmeta-openembedded-e6867fa02618c29a4469342bd3323f51445f9875.tar.gz
strongswan: move to meta-networking
Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Joe MacDonald <joe.macdonald@windriver.com>
Diffstat (limited to 'meta-networking/recipes-support/strongswan')
-rw-r--r--meta-networking/recipes-support/strongswan/strongswan_5.0.0.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/strongswan/strongswan_5.0.0.bb b/meta-networking/recipes-support/strongswan/strongswan_5.0.0.bb
new file mode 100644
index 000000000..eb49494ef
--- /dev/null
+++ b/meta-networking/recipes-support/strongswan/strongswan_5.0.0.bb
@@ -0,0 +1,36 @@
1DESCRIPTION = "strongSwan is an OpenSource IPsec implementation for the \
2Linux operating system."
3HOMEPAGE = "http://www.strongswan.org"
4SECTION = "console/network"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
7DEPENDS = "gmp openssl flex-native flex bison-native"
8PR = "r5"
9
10SRC_URI = "http://download.strongswan.org/strongswan-${PV}.tar.bz2"
11SRC_URI[md5sum] = "c8b861305def7c0abae04f7bbefec212"
12SRC_URI[sha256sum] = "efc13c86e715b5e596d9d8535640c830f83e977fe521afd2c70d68926c4b573e"
13
14EXTRA_OECONF = "--disable-curl --disable-soup --disable-ldap \
15 --enable-gmp --disable-mysql --disable-sqlite \
16 --enable-openssl"
17
18EXTRA_OECONF += "${@base_contains('DISTRO_FEATURES', 'systemd', '--with-systemdsystemunitdir=${systemd_unitdir}/system/', '--without-systemdsystemunitdir', d)}"
19
20inherit autotools systemd
21
22RRECOMMENDS_${PN} = "kernel-module-ipsec"
23
24PACKAGES += "${PN}-plugins"
25FILES_${PN} += "${libdir}/ipsec/lib*${SOLIBS}"
26FILES_${PN}-dev += "${libdir}/ipsec/lib*${SOLIBSDEV} ${libdir}/ipsec/*.la"
27FILES_${PN}-staticdev += "${libdir}/ipsec/*.a"
28FILES_${PN}-dbg += "${libdir}/ipsec/.debug ${libdir}/ipsec/plugins/.debug ${libexecdir}/ipsec/.debug"
29FILES_${PN}-plugins += "${libdir}/ipsec/plugins/*"
30
31INSANE_SKIP_${PN}-plugins = "staticdev"
32
33RPROVIDES_${PN} += "${PN}-systemd"
34RREPLACES_${PN} += "${PN}-systemd"
35RCONFLICTS_${PN} += "${PN}-systemd"
36SYSTEMD_SERVICE_${PN} = "${PN}.service"