summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/rdma-core
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-08-29 23:19:08 -0700
committerKhem Raj <raj.khem@gmail.com>2022-08-30 00:14:58 -0700
commitf88f52d563821b96e3b25903f71c80f68d5b1fde (patch)
tree94fa3bd9f4409ed0d236f8596687d63f02132f26 /meta-networking/recipes-support/rdma-core
parent5bed4f9a47712f8bd444cc3d0c1fd891f277b0aa (diff)
downloadmeta-openembedded-f88f52d563821b96e3b25903f71c80f68d5b1fde.tar.gz
rdma-core: Fix build with musl
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support/rdma-core')
-rw-r--r--meta-networking/recipes-support/rdma-core/rdma-core/0001-examples-Include-alloca.h-for-strdupa.patch29
-rw-r--r--meta-networking/recipes-support/rdma-core/rdma-core_42.0.bb4
2 files changed, 32 insertions, 1 deletions
diff --git a/meta-networking/recipes-support/rdma-core/rdma-core/0001-examples-Include-alloca.h-for-strdupa.patch b/meta-networking/recipes-support/rdma-core/rdma-core/0001-examples-Include-alloca.h-for-strdupa.patch
new file mode 100644
index 000000000..cb472d9db
--- /dev/null
+++ b/meta-networking/recipes-support/rdma-core/rdma-core/0001-examples-Include-alloca.h-for-strdupa.patch
@@ -0,0 +1,29 @@
1From a6c547e46bbadd2c08be9944a85308f6625263cb Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 29 Aug 2022 23:15:44 -0700
4Subject: [PATCH] examples: Include alloca.h for strdupa
5
6musl defines strdupa via a macro which uses alloca() therefore include
7the header to get the prototype
8
9Upstream-Status: Submitted [https://github.com/linux-rdma/rdma-core/pull/1212]
10Signed-off-by: Khem Raj <raj.khem@gmail.com>
11---
12 libibverbs/examples/asyncwatch.c | 1 +
13 1 file changed, 1 insertion(+)
14
15diff --git a/libibverbs/examples/asyncwatch.c b/libibverbs/examples/asyncwatch.c
16index 724796e58..842b94180 100644
17--- a/libibverbs/examples/asyncwatch.c
18+++ b/libibverbs/examples/asyncwatch.c
19@@ -36,6 +36,7 @@
20 #include <endian.h>
21 #include <getopt.h>
22 #include <string.h>
23+#include <alloca.h>
24
25 #include <util/compiler.h>
26 #include <infiniband/verbs.h>
27--
282.37.2
29
diff --git a/meta-networking/recipes-support/rdma-core/rdma-core_42.0.bb b/meta-networking/recipes-support/rdma-core/rdma-core_42.0.bb
index e1123dcc1..86243a52c 100644
--- a/meta-networking/recipes-support/rdma-core/rdma-core_42.0.bb
+++ b/meta-networking/recipes-support/rdma-core/rdma-core_42.0.bb
@@ -5,7 +5,9 @@ SECTION = "libs"
5DEPENDS = "libnl" 5DEPENDS = "libnl"
6RDEPENDS:${PN} = "bash perl" 6RDEPENDS:${PN} = "bash perl"
7 7
8SRC_URI = "git://github.com/linux-rdma/rdma-core.git;branch=master;protocol=https" 8SRC_URI = "git://github.com/linux-rdma/rdma-core.git;branch=master;protocol=https \
9 file://0001-examples-Include-alloca.h-for-strdupa.patch \
10 "
9SRCREV = "196bad56ed060612e22674b668b5ec3d8659ade3" 11SRCREV = "196bad56ed060612e22674b668b5ec3d8659ade3"
10S = "${WORKDIR}/git" 12S = "${WORKDIR}/git"
11 13