summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/openvpn
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-04-22 20:48:50 +0100
committerJoe MacDonald <joe_macdonald@mentor.com>2016-05-05 11:41:28 -0400
commit275b6c30fbe4f2e6d8c607e9f2eedd5c230c0802 (patch)
tree4fd20a242b848ec8497066801b86706de3defdce /meta-networking/recipes-support/openvpn
parent7a9c626092c7d3b10206c7ca4ea2827cca9cba4f (diff)
downloadmeta-openembedded-275b6c30fbe4f2e6d8c607e9f2eedd5c230c0802.tar.gz
meta-networking: use bb.utils.contains() instead of base_contains()
base_contains() is a compatibility wrapper and may warn in the future, so replace all instances with bb.utils.contains(). Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-support/openvpn')
-rw-r--r--meta-networking/recipes-support/openvpn/openvpn_2.3.8.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta-networking/recipes-support/openvpn/openvpn_2.3.8.bb b/meta-networking/recipes-support/openvpn/openvpn_2.3.8.bb
index f0109069c..de2348e8e 100644
--- a/meta-networking/recipes-support/openvpn/openvpn_2.3.8.bb
+++ b/meta-networking/recipes-support/openvpn/openvpn_2.3.8.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://openvpn.sourceforge.net"
3SECTION = "net" 3SECTION = "net"
4LICENSE = "GPLv2" 4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=5aac200199fde47501876cba7263cb0c" 5LIC_FILES_CHKSUM = "file://COPYING;md5=5aac200199fde47501876cba7263cb0c"
6DEPENDS = "lzo openssl iproute2 ${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}" 6DEPENDS = "lzo openssl iproute2 ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
7 7
8inherit autotools systemd 8inherit autotools systemd
9 9
@@ -22,7 +22,7 @@ CFLAGS += "-fno-inline"
22 22
23# I want openvpn to be able to read password from file (hrw) 23# I want openvpn to be able to read password from file (hrw)
24EXTRA_OECONF += "--enable-password-save --enable-iproute2" 24EXTRA_OECONF += "--enable-password-save --enable-iproute2"
25EXTRA_OECONF += "${@base_contains('DISTRO_FEATURES', 'pam', '', '--disable-plugin-auth-pam', d)}" 25EXTRA_OECONF += "${@bb.utils.contains('DISTRO_FEATURES', 'pam', '', '--disable-plugin-auth-pam', d)}"
26 26
27# Explicitly specify IPROUTE to bypass the configure-time check for /sbin/ip on the host. 27# Explicitly specify IPROUTE to bypass the configure-time check for /sbin/ip on the host.
28EXTRA_OECONF += "IPROUTE=/sbin/ip" 28EXTRA_OECONF += "IPROUTE=/sbin/ip"
@@ -38,7 +38,7 @@ do_install_append() {
38 install -dm 755 ${D}${sysconfdir}/openvpn/sample/sample-keys 38 install -dm 755 ${D}${sysconfdir}/openvpn/sample/sample-keys
39 install -m 644 ${S}/sample/sample-keys/* ${D}${sysconfdir}/openvpn/sample/sample-keys 39 install -m 644 ${S}/sample/sample-keys/* ${D}${sysconfdir}/openvpn/sample/sample-keys
40 40
41 if ${@base_contains('DISTRO_FEATURES','systemd','true','false',d)}; then 41 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
42 install -d ${D}/${systemd_unitdir}/system 42 install -d ${D}/${systemd_unitdir}/system
43 install -m 644 ${WORKDIR}/openvpn@.service ${D}/${systemd_unitdir}/system 43 install -m 644 ${WORKDIR}/openvpn@.service ${D}/${systemd_unitdir}/system
44 install -m 644 ${WORKDIR}/openvpn@.service ${D}/${systemd_unitdir}/system/openvpn@loopback-server.service 44 install -m 644 ${WORKDIR}/openvpn@.service ${D}/${systemd_unitdir}/system/openvpn@loopback-server.service