summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/ntp
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-07-29 17:04:53 +0200
committerKhem Raj <raj.khem@gmail.com>2021-08-03 10:21:25 -0700
commitc61dc077bbd81260e4f167fa2251643ba0ba6974 (patch)
tree66c3243f8f64ae60f66f70a16e8128c247254a65 /meta-networking/recipes-support/ntp
parentc5f7cfb8db54cfa4257797db5bd87828dea43296 (diff)
downloadmeta-openembedded-c61dc077bbd81260e4f167fa2251643ba0ba6974.tar.gz
Convert to new override syntax
This is the result of automated script (0.9.1) conversion: oe-core/scripts/contrib/convert-overrides.py . converting the metadata to use ":" as the override character instead of "_". Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support/ntp')
-rw-r--r--meta-networking/recipes-support/ntp/ntp_4.2.8p15.bb64
1 files changed, 32 insertions, 32 deletions
diff --git a/meta-networking/recipes-support/ntp/ntp_4.2.8p15.bb b/meta-networking/recipes-support/ntp/ntp_4.2.8p15.bb
index 37f67095c..4a719ae9c 100644
--- a/meta-networking/recipes-support/ntp/ntp_4.2.8p15.bb
+++ b/meta-networking/recipes-support/ntp/ntp_4.2.8p15.bb
@@ -42,11 +42,11 @@ EXTRA_OECONF += "--with-net-snmp-config=no \
42 --with-locfile=redhat \ 42 --with-locfile=redhat \
43 --without-rpath \ 43 --without-rpath \
44 " 44 "
45CFLAGS_append = " -DPTYS_ARE_GETPT -DPTYS_ARE_SEARCHED" 45CFLAGS:append = " -DPTYS_ARE_GETPT -DPTYS_ARE_SEARCHED"
46 46
47USERADD_PACKAGES = "${PN}" 47USERADD_PACKAGES = "${PN}"
48NTP_USER_HOME ?= "/var/lib/ntp" 48NTP_USER_HOME ?= "/var/lib/ntp"
49USERADD_PARAM_${PN} = "--system --home-dir ${NTP_USER_HOME} \ 49USERADD_PARAM:${PN} = "--system --home-dir ${NTP_USER_HOME} \
50 --no-create-home \ 50 --no-create-home \
51 --shell /bin/false --user-group ntp" 51 --shell /bin/false --user-group ntp"
52 52
@@ -66,7 +66,7 @@ PACKAGECONFIG[debug] = "--enable-debugging,--disable-debugging"
66PACKAGECONFIG[mdns] = "ac_cv_header_dns_sd_h=yes,ac_cv_header_dns_sd_h=no,mdns" 66PACKAGECONFIG[mdns] = "ac_cv_header_dns_sd_h=yes,ac_cv_header_dns_sd_h=no,mdns"
67PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6," 67PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
68 68
69do_install_append() { 69do_install:append() {
70 install -d ${D}${sysconfdir}/init.d 70 install -d ${D}${sysconfdir}/init.d
71 install -m 644 ${WORKDIR}/ntp.conf ${D}${sysconfdir} 71 install -m 644 ${WORKDIR}/ntp.conf ${D}${sysconfdir}
72 install -m 755 ${WORKDIR}/ntpd ${D}${sysconfdir}/init.d 72 install -m 755 ${WORKDIR}/ntpd ${D}${sysconfdir}/init.d
@@ -113,60 +113,60 @@ PACKAGES += "ntpdate sntp ntpdc ntpq ${PN}-tickadj ${PN}-utils"
113 113
114# ntp originally includes tickadj. It's split off for inclusion in small firmware images on platforms 114# ntp originally includes tickadj. It's split off for inclusion in small firmware images on platforms
115# with wonky clocks (e.g. OpenSlug) 115# with wonky clocks (e.g. OpenSlug)
116RDEPENDS_${PN} = "${PN}-tickadj" 116RDEPENDS:${PN} = "${PN}-tickadj"
117# ntpd require libgcc for execution 117# ntpd require libgcc for execution
118RDEPENDS_${PN} += "libgcc" 118RDEPENDS:${PN} += "libgcc"
119# Handle move from bin to utils package 119# Handle move from bin to utils package
120RPROVIDES_${PN}-utils = "${PN}-bin" 120RPROVIDES:${PN}-utils = "${PN}-bin"
121RREPLACES_${PN}-utils = "${PN}-bin" 121RREPLACES:${PN}-utils = "${PN}-bin"
122RCONFLICTS_${PN}-utils = "${PN}-bin" 122RCONFLICTS:${PN}-utils = "${PN}-bin"
123# ntpdc and ntpq were split out of ntp-utils 123# ntpdc and ntpq were split out of ntp-utils
124RDEPENDS_${PN}-utils = "ntpdc ntpq" 124RDEPENDS:${PN}-utils = "ntpdc ntpq"
125 125
126SYSTEMD_PACKAGES = "${PN} ntpdate sntp" 126SYSTEMD_PACKAGES = "${PN} ntpdate sntp"
127SYSTEMD_SERVICE_${PN} = "ntpd.service" 127SYSTEMD_SERVICE:${PN} = "ntpd.service"
128SYSTEMD_SERVICE_ntpdate = "ntpdate.service" 128SYSTEMD_SERVICE:ntpdate = "ntpdate.service"
129SYSTEMD_SERVICE_sntp = "sntp.service" 129SYSTEMD_SERVICE:sntp = "sntp.service"
130SYSTEMD_AUTO_ENABLE_sntp = "disable" 130SYSTEMD_AUTO_ENABLE:sntp = "disable"
131 131
132RPROVIDES_${PN} += "${PN}-systemd" 132RPROVIDES:${PN} += "${PN}-systemd"
133RREPLACES_${PN} += "${PN}-systemd" 133RREPLACES:${PN} += "${PN}-systemd"
134RCONFLICTS_${PN} += "${PN}-systemd" 134RCONFLICTS:${PN} += "${PN}-systemd"
135 135
136RPROVIDES_ntpdate += "ntpdate-systemd" 136RPROVIDES:ntpdate += "ntpdate-systemd"
137RREPLACES_ntpdate += "ntpdate-systemd" 137RREPLACES:ntpdate += "ntpdate-systemd"
138RCONFLICTS_ntpdate += "ntpdate-systemd" 138RCONFLICTS:ntpdate += "ntpdate-systemd"
139 139
140RSUGGESTS_${PN} = "iana-etc" 140RSUGGESTS:${PN} = "iana-etc"
141 141
142FILES_${PN} = "${sbindir}/ntpd.ntp ${sysconfdir}/ntp.conf ${sysconfdir}/init.d/ntpd \ 142FILES:${PN} = "${sbindir}/ntpd.ntp ${sysconfdir}/ntp.conf ${sysconfdir}/init.d/ntpd \
143 ${NTP_USER_HOME} \ 143 ${NTP_USER_HOME} \
144 ${systemd_unitdir}/ntp-units.d/60-ntpd.list \ 144 ${systemd_unitdir}/ntp-units.d/60-ntpd.list \
145" 145"
146FILES_${PN}-tickadj = "${sbindir}/tickadj" 146FILES:${PN}-tickadj = "${sbindir}/tickadj"
147FILES_${PN}-utils = "${sbindir} ${datadir}/ntp/lib" 147FILES:${PN}-utils = "${sbindir} ${datadir}/ntp/lib"
148RDEPENDS_${PN}-utils += "perl" 148RDEPENDS:${PN}-utils += "perl"
149FILES_ntpdate = "${sbindir}/ntpdate \ 149FILES:ntpdate = "${sbindir}/ntpdate \
150 ${sysconfdir}/network/if-up.d/ntpdate-sync \ 150 ${sysconfdir}/network/if-up.d/ntpdate-sync \
151 ${bindir}/ntpdate-sync \ 151 ${bindir}/ntpdate-sync \
152 ${sysconfdir}/default/ntpdate \ 152 ${sysconfdir}/default/ntpdate \
153 ${systemd_unitdir}/system/ntpdate.service \ 153 ${systemd_unitdir}/system/ntpdate.service \
154" 154"
155FILES_sntp = "${sbindir}/sntp \ 155FILES:sntp = "${sbindir}/sntp \
156 ${sysconfdir}/default/sntp \ 156 ${sysconfdir}/default/sntp \
157 ${systemd_unitdir}/system/sntp.service \ 157 ${systemd_unitdir}/system/sntp.service \
158 " 158 "
159FILES_ntpdc = "${sbindir}/ntpdc" 159FILES:ntpdc = "${sbindir}/ntpdc"
160FILES_ntpq = "${sbindir}/ntpq" 160FILES:ntpq = "${sbindir}/ntpq"
161 161
162CONFFILES_${PN} = "${sysconfdir}/ntp.conf" 162CONFFILES:${PN} = "${sysconfdir}/ntp.conf"
163CONFFILES_ntpdate = "${sysconfdir}/default/ntpdate" 163CONFFILES:ntpdate = "${sysconfdir}/default/ntpdate"
164 164
165INITSCRIPT_NAME = "ntpd" 165INITSCRIPT_NAME = "ntpd"
166# No dependencies, so just go in at the standard level (20) 166# No dependencies, so just go in at the standard level (20)
167INITSCRIPT_PARAMS = "defaults" 167INITSCRIPT_PARAMS = "defaults"
168 168
169pkg_postinst_ntpdate() { 169pkg_postinst:ntpdate() {
170 if ! grep -q -s ntpdate $D/var/spool/cron/root; then 170 if ! grep -q -s ntpdate $D/var/spool/cron/root; then
171 echo "adding crontab" 171 echo "adding crontab"
172 test -d $D/var/spool/cron || mkdir -p $D/var/spool/cron 172 test -d $D/var/spool/cron || mkdir -p $D/var/spool/cron
@@ -178,5 +178,5 @@ inherit update-alternatives
178 178
179ALTERNATIVE_PRIORITY = "100" 179ALTERNATIVE_PRIORITY = "100"
180 180
181ALTERNATIVE_${PN} = "ntpd" 181ALTERNATIVE:${PN} = "ntpd"
182ALTERNATIVE_LINK_NAME[ntpd] = "${sbindir}/ntpd" 182ALTERNATIVE_LINK_NAME[ntpd] = "${sbindir}/ntpd"