diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2021-07-29 17:04:53 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-08-03 10:21:25 -0700 |
commit | c61dc077bbd81260e4f167fa2251643ba0ba6974 (patch) | |
tree | 66c3243f8f64ae60f66f70a16e8128c247254a65 /meta-networking/recipes-support/ntp | |
parent | c5f7cfb8db54cfa4257797db5bd87828dea43296 (diff) | |
download | meta-openembedded-c61dc077bbd81260e4f167fa2251643ba0ba6974.tar.gz |
Convert to new override syntax
This is the result of automated script (0.9.1) conversion:
oe-core/scripts/contrib/convert-overrides.py .
converting the metadata to use ":" as the override character instead of "_".
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support/ntp')
-rw-r--r-- | meta-networking/recipes-support/ntp/ntp_4.2.8p15.bb | 64 |
1 files changed, 32 insertions, 32 deletions
diff --git a/meta-networking/recipes-support/ntp/ntp_4.2.8p15.bb b/meta-networking/recipes-support/ntp/ntp_4.2.8p15.bb index 37f67095c5..4a719ae9c8 100644 --- a/meta-networking/recipes-support/ntp/ntp_4.2.8p15.bb +++ b/meta-networking/recipes-support/ntp/ntp_4.2.8p15.bb | |||
@@ -42,11 +42,11 @@ EXTRA_OECONF += "--with-net-snmp-config=no \ | |||
42 | --with-locfile=redhat \ | 42 | --with-locfile=redhat \ |
43 | --without-rpath \ | 43 | --without-rpath \ |
44 | " | 44 | " |
45 | CFLAGS_append = " -DPTYS_ARE_GETPT -DPTYS_ARE_SEARCHED" | 45 | CFLAGS:append = " -DPTYS_ARE_GETPT -DPTYS_ARE_SEARCHED" |
46 | 46 | ||
47 | USERADD_PACKAGES = "${PN}" | 47 | USERADD_PACKAGES = "${PN}" |
48 | NTP_USER_HOME ?= "/var/lib/ntp" | 48 | NTP_USER_HOME ?= "/var/lib/ntp" |
49 | USERADD_PARAM_${PN} = "--system --home-dir ${NTP_USER_HOME} \ | 49 | USERADD_PARAM:${PN} = "--system --home-dir ${NTP_USER_HOME} \ |
50 | --no-create-home \ | 50 | --no-create-home \ |
51 | --shell /bin/false --user-group ntp" | 51 | --shell /bin/false --user-group ntp" |
52 | 52 | ||
@@ -66,7 +66,7 @@ PACKAGECONFIG[debug] = "--enable-debugging,--disable-debugging" | |||
66 | PACKAGECONFIG[mdns] = "ac_cv_header_dns_sd_h=yes,ac_cv_header_dns_sd_h=no,mdns" | 66 | PACKAGECONFIG[mdns] = "ac_cv_header_dns_sd_h=yes,ac_cv_header_dns_sd_h=no,mdns" |
67 | PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6," | 67 | PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6," |
68 | 68 | ||
69 | do_install_append() { | 69 | do_install:append() { |
70 | install -d ${D}${sysconfdir}/init.d | 70 | install -d ${D}${sysconfdir}/init.d |
71 | install -m 644 ${WORKDIR}/ntp.conf ${D}${sysconfdir} | 71 | install -m 644 ${WORKDIR}/ntp.conf ${D}${sysconfdir} |
72 | install -m 755 ${WORKDIR}/ntpd ${D}${sysconfdir}/init.d | 72 | install -m 755 ${WORKDIR}/ntpd ${D}${sysconfdir}/init.d |
@@ -113,60 +113,60 @@ PACKAGES += "ntpdate sntp ntpdc ntpq ${PN}-tickadj ${PN}-utils" | |||
113 | 113 | ||
114 | # ntp originally includes tickadj. It's split off for inclusion in small firmware images on platforms | 114 | # ntp originally includes tickadj. It's split off for inclusion in small firmware images on platforms |
115 | # with wonky clocks (e.g. OpenSlug) | 115 | # with wonky clocks (e.g. OpenSlug) |
116 | RDEPENDS_${PN} = "${PN}-tickadj" | 116 | RDEPENDS:${PN} = "${PN}-tickadj" |
117 | # ntpd require libgcc for execution | 117 | # ntpd require libgcc for execution |
118 | RDEPENDS_${PN} += "libgcc" | 118 | RDEPENDS:${PN} += "libgcc" |
119 | # Handle move from bin to utils package | 119 | # Handle move from bin to utils package |
120 | RPROVIDES_${PN}-utils = "${PN}-bin" | 120 | RPROVIDES:${PN}-utils = "${PN}-bin" |
121 | RREPLACES_${PN}-utils = "${PN}-bin" | 121 | RREPLACES:${PN}-utils = "${PN}-bin" |
122 | RCONFLICTS_${PN}-utils = "${PN}-bin" | 122 | RCONFLICTS:${PN}-utils = "${PN}-bin" |
123 | # ntpdc and ntpq were split out of ntp-utils | 123 | # ntpdc and ntpq were split out of ntp-utils |
124 | RDEPENDS_${PN}-utils = "ntpdc ntpq" | 124 | RDEPENDS:${PN}-utils = "ntpdc ntpq" |
125 | 125 | ||
126 | SYSTEMD_PACKAGES = "${PN} ntpdate sntp" | 126 | SYSTEMD_PACKAGES = "${PN} ntpdate sntp" |
127 | SYSTEMD_SERVICE_${PN} = "ntpd.service" | 127 | SYSTEMD_SERVICE:${PN} = "ntpd.service" |
128 | SYSTEMD_SERVICE_ntpdate = "ntpdate.service" | 128 | SYSTEMD_SERVICE:ntpdate = "ntpdate.service" |
129 | SYSTEMD_SERVICE_sntp = "sntp.service" | 129 | SYSTEMD_SERVICE:sntp = "sntp.service" |
130 | SYSTEMD_AUTO_ENABLE_sntp = "disable" | 130 | SYSTEMD_AUTO_ENABLE:sntp = "disable" |
131 | 131 | ||
132 | RPROVIDES_${PN} += "${PN}-systemd" | 132 | RPROVIDES:${PN} += "${PN}-systemd" |
133 | RREPLACES_${PN} += "${PN}-systemd" | 133 | RREPLACES:${PN} += "${PN}-systemd" |
134 | RCONFLICTS_${PN} += "${PN}-systemd" | 134 | RCONFLICTS:${PN} += "${PN}-systemd" |
135 | 135 | ||
136 | RPROVIDES_ntpdate += "ntpdate-systemd" | 136 | RPROVIDES:ntpdate += "ntpdate-systemd" |
137 | RREPLACES_ntpdate += "ntpdate-systemd" | 137 | RREPLACES:ntpdate += "ntpdate-systemd" |
138 | RCONFLICTS_ntpdate += "ntpdate-systemd" | 138 | RCONFLICTS:ntpdate += "ntpdate-systemd" |
139 | 139 | ||
140 | RSUGGESTS_${PN} = "iana-etc" | 140 | RSUGGESTS:${PN} = "iana-etc" |
141 | 141 | ||
142 | FILES_${PN} = "${sbindir}/ntpd.ntp ${sysconfdir}/ntp.conf ${sysconfdir}/init.d/ntpd \ | 142 | FILES:${PN} = "${sbindir}/ntpd.ntp ${sysconfdir}/ntp.conf ${sysconfdir}/init.d/ntpd \ |
143 | ${NTP_USER_HOME} \ | 143 | ${NTP_USER_HOME} \ |
144 | ${systemd_unitdir}/ntp-units.d/60-ntpd.list \ | 144 | ${systemd_unitdir}/ntp-units.d/60-ntpd.list \ |
145 | " | 145 | " |
146 | FILES_${PN}-tickadj = "${sbindir}/tickadj" | 146 | FILES:${PN}-tickadj = "${sbindir}/tickadj" |
147 | FILES_${PN}-utils = "${sbindir} ${datadir}/ntp/lib" | 147 | FILES:${PN}-utils = "${sbindir} ${datadir}/ntp/lib" |
148 | RDEPENDS_${PN}-utils += "perl" | 148 | RDEPENDS:${PN}-utils += "perl" |
149 | FILES_ntpdate = "${sbindir}/ntpdate \ | 149 | FILES:ntpdate = "${sbindir}/ntpdate \ |
150 | ${sysconfdir}/network/if-up.d/ntpdate-sync \ | 150 | ${sysconfdir}/network/if-up.d/ntpdate-sync \ |
151 | ${bindir}/ntpdate-sync \ | 151 | ${bindir}/ntpdate-sync \ |
152 | ${sysconfdir}/default/ntpdate \ | 152 | ${sysconfdir}/default/ntpdate \ |
153 | ${systemd_unitdir}/system/ntpdate.service \ | 153 | ${systemd_unitdir}/system/ntpdate.service \ |
154 | " | 154 | " |
155 | FILES_sntp = "${sbindir}/sntp \ | 155 | FILES:sntp = "${sbindir}/sntp \ |
156 | ${sysconfdir}/default/sntp \ | 156 | ${sysconfdir}/default/sntp \ |
157 | ${systemd_unitdir}/system/sntp.service \ | 157 | ${systemd_unitdir}/system/sntp.service \ |
158 | " | 158 | " |
159 | FILES_ntpdc = "${sbindir}/ntpdc" | 159 | FILES:ntpdc = "${sbindir}/ntpdc" |
160 | FILES_ntpq = "${sbindir}/ntpq" | 160 | FILES:ntpq = "${sbindir}/ntpq" |
161 | 161 | ||
162 | CONFFILES_${PN} = "${sysconfdir}/ntp.conf" | 162 | CONFFILES:${PN} = "${sysconfdir}/ntp.conf" |
163 | CONFFILES_ntpdate = "${sysconfdir}/default/ntpdate" | 163 | CONFFILES:ntpdate = "${sysconfdir}/default/ntpdate" |
164 | 164 | ||
165 | INITSCRIPT_NAME = "ntpd" | 165 | INITSCRIPT_NAME = "ntpd" |
166 | # No dependencies, so just go in at the standard level (20) | 166 | # No dependencies, so just go in at the standard level (20) |
167 | INITSCRIPT_PARAMS = "defaults" | 167 | INITSCRIPT_PARAMS = "defaults" |
168 | 168 | ||
169 | pkg_postinst_ntpdate() { | 169 | pkg_postinst:ntpdate() { |
170 | if ! grep -q -s ntpdate $D/var/spool/cron/root; then | 170 | if ! grep -q -s ntpdate $D/var/spool/cron/root; then |
171 | echo "adding crontab" | 171 | echo "adding crontab" |
172 | test -d $D/var/spool/cron || mkdir -p $D/var/spool/cron | 172 | test -d $D/var/spool/cron || mkdir -p $D/var/spool/cron |
@@ -178,5 +178,5 @@ inherit update-alternatives | |||
178 | 178 | ||
179 | ALTERNATIVE_PRIORITY = "100" | 179 | ALTERNATIVE_PRIORITY = "100" |
180 | 180 | ||
181 | ALTERNATIVE_${PN} = "ntpd" | 181 | ALTERNATIVE:${PN} = "ntpd" |
182 | ALTERNATIVE_LINK_NAME[ntpd] = "${sbindir}/ntpd" | 182 | ALTERNATIVE_LINK_NAME[ntpd] = "${sbindir}/ntpd" |