summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/netperf
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 22:49:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:23:17 +0200
commita45830a39bb47a9eab27980d52966226c9504ea4 (patch)
tree001209d9740e8668b2eeeac4212b3561aecebf29 /meta-networking/recipes-support/netperf
parent6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff)
downloadmeta-openembedded-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python tasks). * Some recipes were using tabs. * Some were using 8 spaces. * Some were using mix or different number of spaces. * Make them consistently use 4 spaces everywhere. * Yocto styleguide advises to use tabs (but the only reason to keep tabs is the need to update a lot of recipes). Lately this advice was also merged into the styleguide on the OE wiki. * Using 4 spaces in both types of tasks is better because it's less error prone when someone is not sure if e.g. do_generate_toolchain_file() is Python or shell task and also allows to highlight every tab used in .bb, .inc, .bbappend, .bbclass as potentially bad (shouldn't be used for indenting of multiline variable assignments and cannot be used for Python tasks). * Don't indent closing quote on multiline variables we're quite inconsistent wheater it's first character on line under opening quote or under first non-whitespace character in previous line. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-networking/recipes-support/netperf')
-rw-r--r--meta-networking/recipes-support/netperf/netperf_2.6.0.bb44
1 files changed, 22 insertions, 22 deletions
diff --git a/meta-networking/recipes-support/netperf/netperf_2.6.0.bb b/meta-networking/recipes-support/netperf/netperf_2.6.0.bb
index 7b7884060..eda78599c 100644
--- a/meta-networking/recipes-support/netperf/netperf_2.6.0.bb
+++ b/meta-networking/recipes-support/netperf/netperf_2.6.0.bb
@@ -26,31 +26,31 @@ CFLAGS_append = " -DDO_UNIX -DDO_IPV6 -D_GNU_SOURCE"
26# autotools.bbclass attends to include m4 files with path depth <= 2 by 26# autotools.bbclass attends to include m4 files with path depth <= 2 by
27# "find ${S} -maxdepth 2 -name \*.m4", so move m4 files from m4/m4. 27# "find ${S} -maxdepth 2 -name \*.m4", so move m4 files from m4/m4.
28do_configure_prepend() { 28do_configure_prepend() {
29 test -d m4/m4 && mv -f m4/m4 m4-files 29 test -d m4/m4 && mv -f m4/m4 m4-files
30} 30}
31 31
32do_install() { 32do_install() {
33 sed -e 's#/usr/sbin/#${sbindir}/#g' -i ${WORKDIR}/init 33 sed -e 's#/usr/sbin/#${sbindir}/#g' -i ${WORKDIR}/init
34 34
35 install -d ${D}${sbindir} ${D}${bindir} ${D}${sysconfdir}/init.d 35 install -d ${D}${sbindir} ${D}${bindir} ${D}${sysconfdir}/init.d
36 install -m 4755 src/netperf ${D}${bindir} 36 install -m 4755 src/netperf ${D}${bindir}
37 install -m 4755 src/netserver ${D}${sbindir} 37 install -m 4755 src/netserver ${D}${sbindir}
38 install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/netperf 38 install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/netperf
39 39
40 # man 40 # man
41 install -d ${D}${mandir}/man1/ 41 install -d ${D}${mandir}/man1/
42 install -m 0644 doc/netserver.man ${D}${mandir}/man1/netserver.1 42 install -m 0644 doc/netserver.man ${D}${mandir}/man1/netserver.1
43 install -m 0644 doc/netperf.man ${D}${mandir}/man1/netperf.1 43 install -m 0644 doc/netperf.man ${D}${mandir}/man1/netperf.1
44 44
45 # move scripts to examples directory 45 # move scripts to examples directory
46 install -d ${D}${docdir}/netperf/examples 46 install -d ${D}${docdir}/netperf/examples
47 install -m 0644 doc/examples/*_script ${D}${docdir}/netperf/examples/ 47 install -m 0644 doc/examples/*_script ${D}${docdir}/netperf/examples/
48 48
49 # docs .. 49 # docs ..
50 install -m 0644 COPYING ${D}${docdir}/netperf 50 install -m 0644 COPYING ${D}${docdir}/netperf
51 install -m 0644 Release_Notes ${D}${docdir}/netperf 51 install -m 0644 Release_Notes ${D}${docdir}/netperf
52 install -m 0644 README ${D}${docdir}/netperf 52 install -m 0644 README ${D}${docdir}/netperf
53 install -m 0644 doc/netperf_old.ps ${D}${docdir}/netperf 53 install -m 0644 doc/netperf_old.ps ${D}${docdir}/netperf
54} 54}
55 55
56INITSCRIPT_NAME="netperf" 56INITSCRIPT_NAME="netperf"